WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TC8. Xfbdev.tcz causes the error message "failed in waitforX"  (Read 1396 times)

Offline Frank69

  • WikiUser
  • *
  • Posts: 31
Hello,
I have a fresh TC8.0 installation. As a video driver I have installed graphics-4.8.17-tinycore.tcz and Xfbdev.tcz. I deleted Xvesa from "onboot.lst". When I start TC8.0, the display switches to a high resolution in text mode. Continuing with the error message "failed in waitingforX". Occasionally, TC8 continues and launches the desktop. White the command startx, you get the same message or starts X. Under TC7.2, everything works smoothly. Does anyone have any idea how to solve this?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #1 on: May 12, 2017, 03:45:41 AM »
Try this command:
Code: [Select]
$ cat ~/.xsession
..which should give a first line starting with Xfbdev.

Enter the complete first line at the command prompt and press enter - you should get an error message that gives an indication of the problem.

Offline Frank69

  • WikiUser
  • *
  • Posts: 31
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #2 on: May 12, 2017, 04:17:40 AM »
When I enter the "cat ~ / .xsession" command, I see on the first line
Code: [Select]
/usr/local/bin/Xfbdev -mouse /dev/input/mice,5 -nolisten tcp -I >/dev/null 2>&1 & If you run this after the command prompt, X starts with a gray screen and a cursor (cross). The cursor can be moved.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #3 on: May 12, 2017, 04:41:32 AM »
It looks like you have not loaded one or more of the flwm, aterm, wbar, Xlibs and Xprogs extensions?

BTW, I was in error earlier, you would need to enter the first line without ">/dev/null 2>&1" in order to see any error messages.

Offline Frank69

  • WikiUser
  • *
  • Posts: 31
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #4 on: May 12, 2017, 05:41:17 AM »
After a new installation on my laptop, I get a boot prompt.
I have downloaded and installed the Xvesa.tcz Xlibs.tcz Xprogs.tcz aterm.tcz flwm_topside.tcz wbar.tcz extensions. Then saved the extension names in onboot.lst. After a reboot I have downloaded Graphics-4.8.17-tinycore.tcz and Xfbdev.tcz. I replaced Xvesa.tcz with graphics-4.8.17-tinycore.tcz and Xfbdev.tcz in onboot.lst. Same result

The command
Code: [Select]
/ usr / local / bin / xfbdev -mouse / dev / input / mice, 5 -nolist tcp -I [/ code] returns no error message. X starts with a cursor

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #5 on: May 12, 2017, 05:57:44 AM »
I just booted tc-8.x x86 with the following and it worked fine:
Code: [Select]
$ cat /mnt/sdb1/tce/onboot.lst
aterm.tcz
flwm.tcz
wbar.tcz
Xfbdev.tcz
Xprogs.tcz

$ ps aux | grep X
 3054 root     /usr/local/bin/Xfbdev -mouse /dev/input/mice,5 -nolisten tcp -I
..note that graphics-KERNEL is not loaded
« Last Edit: May 12, 2017, 05:59:31 AM by Juanito »

Offline Frank69

  • WikiUser
  • *
  • Posts: 31
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #6 on: May 12, 2017, 08:25:00 AM »
This is what I have in onboot.lst  (I've temporarily eliminated Graphics-4.8.17 -tinycore.tcz)
Code: [Select]
Xfbdev.tcz
Xlibs.tcz
Xprogs
aterm.tcz
flwm_topside.tcz
wbar.tcz
nano.tcz
The command
Code: [Select]
ps aux | grep x returns as a result
1432 tc      grep x
I wonder. I use a thin client laptop that it is very slow. Could that have anything to do with it?
« Last Edit: May 12, 2017, 08:26:58 AM by Frank69 »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5470
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #7 on: May 12, 2017, 09:17:54 AM »
Hi Frank69
Do you really have  Xprogs  listed without the  .tcz  extension in your  onboot.lst  file?

Offline Frank69

  • WikiUser
  • *
  • Posts: 31
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #8 on: May 12, 2017, 09:45:32 AM »
My mistake. It is Xprogs.tcz.
I found this forum topic . Would the speed of my thin client laptop indeed have something to do with my problem? I'm using a Wyse X90cw. According to this site it should work.
« Last Edit: May 12, 2017, 09:56:38 AM by Frank69 »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9612
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #9 on: May 12, 2017, 09:58:35 AM »
That laptop has the Intel/PowerVR poulsbo graphics, which are extremely troublesome on all OSes. Does Xvesa not work?
The only barriers that can stop you are the ones you create yourself.

Offline Frank69

  • WikiUser
  • *
  • Posts: 31
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #10 on: May 12, 2017, 12:45:23 PM »
Xvesa works but the maximum screen resolution is 1024 x 768. My laptop has a resolution of 1366 x 768. If I try to change the resolution via the Control Panel, it does not appears to work.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #11 on: May 12, 2017, 02:01:48 PM »
Using Xvesa, If you exit to a console prompt and use xsetup.sh, does it show 1366 x 768 as an option?

If so, do things work if you choose it and then starttx?

Offline Frank69

  • WikiUser
  • *
  • Posts: 31
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #12 on: May 12, 2017, 11:03:20 PM »
If xsetup.sh is used i see a maximum resolution of 1024x786x24. Choose a lower resolution and then startx will change the resolution of the wbar a number of times, after which everything will returns to the original resolution i started with. If i leaves TC with "Exit to Prompt" and then xsetup, I can adjust the resolution but only up to 1024x786.
« Last Edit: May 12, 2017, 11:10:23 PM by Frank69 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9607
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #13 on: May 12, 2017, 11:26:43 PM »
If xsetup.sh does not show 1366x768,  I don't think you will get it with Xvesa.

Are you using legacy-bios or uefi boot?

If you are using uefi, it might be possible to set the screen resolution to 1366x768 using grub2 and then use Xfbdev without needing any "vga=" boot code.

Offline Frank69

  • WikiUser
  • *
  • Posts: 31
Re: TC8. Xfbdev.tcz causes the error message "failed in waitforX"
« Reply #14 on: May 12, 2017, 11:54:36 PM »
There is no uefi bios in my laptop. I did not use a VGA boot code. I thought that it was not necessary because it works under TC7.2.