WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: No way to use boot options  (Read 235 times)

Offline luiznetto

  • WikiUser
  • *
  • Posts: 6
No way to use boot options
« on: May 05, 2017, 05:41:14 PM »
Hi all
I have Tiny Core 8.0 that I downloaded and burnt the image (CorePlus-current.iso) onto a CD-RW. It boots fine, but with one problem: no boot options allowed, I mean those that you type. The first pre-boot screen shows a Grub-like kind of screen with several options, and I can use the up and down arrows to select one, but no way for my to type something like tinycore tce={hda1|sda1} or something like that. I try holding the Ctrl key, but it just boots into the desktop, without allowing me to type and enter the boot code. What is wrong? :(

Offline rdebath

  • WikiUser
  • *
  • Posts: 13
Re: No way to use boot options
« Reply #1 on: May 05, 2017, 06:38:57 PM »
With syslinux/extlinux you hit TAB.
--
Robert

Offline luiznetto

  • WikiUser
  • *
  • Posts: 6
Re: No way to use boot options
« Reply #2 on: May 07, 2017, 08:24:14 AM »
I pressed TAB, erased the previous boot code line and entered:

tinycore tce=sdb1

It completely ignored my request, went back to the first screen, and did the default boot as usual. ???

Offline luiznetto

  • WikiUser
  • *
  • Posts: 6
Re: No way to use boot options
« Reply #3 on: May 07, 2017, 10:42:42 AM »
Now I left the initial line of code there and just added

tce=sdb1 waitusb=20

(I chose it deliberately long so I could observe the boot process better) and pressed ENTER. It does boot, but I couldn't notice any delays for waitusb. When I got into the desktop, it seemed to remember something, like my wi-fi settings, the bookmarks on my firefox etc. I can run applications that are already "installed" in my usb stick by running, for example,

$ tce-run firefox-ESR

but the Appbrowser that's set to http://www.gtlib.gatech.edu/pub/tinycore won't let me browse for new applications or let my uninstall any of those I have already installed (in the usb-stick).

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4206
Re: No way to use boot options
« Reply #4 on: May 07, 2017, 11:03:18 AM »
You need to remove the cde boot option, or writing to the tce directory will be disabled.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2377
Re: No way to use boot options
« Reply #5 on: May 07, 2017, 09:50:34 PM »
Now I left the initial line of code there and just added

tce=sdb1 waitusb=20

(I chose it deliberately long so I could observe the boot process better) and pressed ENTER. It does boot, but I couldn't notice any delays for waitusb.
Also note that waitusb=20 is a limit not an instruction to wait 20 seconds. Meaning that the boot process will continue as soon as the USB has been detected even if detection is complete in 3 seconds no matter how long you specified to allow waiting for USB discovery.

:)

Online curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9441
Re: No way to use boot options
« Reply #6 on: May 08, 2017, 12:26:59 AM »
Waitusb only continues before the limit if you also passed an UUID or a LABEL to wait for; otherwise it will wait the full time.
The only barriers that can stop you are the ones you create yourself.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2377
No way to use boot options
« Reply #7 on: May 08, 2017, 04:39:34 AM »
Thanks curaga,  ok will have to look at that again.. 


Sent from my iPhone using Tapatalk