WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: rebuild kernel 4.4.39 didn't work  (Read 207 times)

Offline teh-botol

  • WikiUser
  • *
  • Posts: 23
rebuild kernel 4.4.39 didn't work
« on: April 23, 2017, 11:04:05 PM »
Hi,

I tried to change boot logo kernel 4.4.39 (piCore8) with mine.
But the kernel image size is much smaller.
Even tough my logo a little bigger than the default one.

Code: [Select]
tc@box:/mnt/mmcblk0p1$ ll kernel*
-rwxrwxrwx    1 tc       staff      4168056 Dec 26 16:41 kernel4439.img
-rwxrwxrwx    1 tc       staff      4277484 Dec 26 10:32 kernel4439v7.img
-rwxrwxrwx    1 tc       staff      4168016 Apr 24 04:09 kernelCustom.img


And it wont start. Just displaying a huge rainbow box.

FYI, I successfully change boot logo for kernel 4.1.20 (piCore7). And it works fine.

Need help.

Offline teh-botol

  • WikiUser
  • *
  • Posts: 23
Re: rebuild kernel 4.4.39 didn't work
« Reply #1 on: April 24, 2017, 07:29:16 AM »
I tried rebuild without changing configuration.
It's still not working.

Code: [Select]
tc@box:/mnt/mmcblk0p1$ ll kernel*
-rwxrwxrwx    1 tc       staff      4168056 Dec 26 16:41 kernel4439.img
-rwxrwxrwx    1 tc       staff      4277484 Dec 26 10:32 kernel4439v7.img
-rwxrwxrwx    1 tc       staff      4165592 Apr 24 04:09 kernelCustom.img


FYI, machine Raspberry Pi 3.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6886
    • My Community Forum
Re: rebuild kernel 4.4.39 didn't work
« Reply #2 on: April 24, 2017, 08:02:00 AM »
Did you add the header to the kernel required by the boot loader or it is the plain kernel after the compilation?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline teh-botol

  • WikiUser
  • *
  • Posts: 23
Re: rebuild kernel 4.4.39 didn't work
« Reply #3 on: April 24, 2017, 08:41:19 AM »
I think I know the problem.

The config file I use is for armv6 instead armv7.

*I didn't look at filename which didn't have "_v7+"
*And I didn't look at the url which "/8.x/armv6/"

Silly me  :-[
Sorry for the inconvenience.

I will update the result after rebuild.

Offline teh-botol

  • WikiUser
  • *
  • Posts: 23
Re: rebuild kernel 4.4.39 didn't work
« Reply #4 on: April 24, 2017, 07:00:09 PM »
Yep. It's working now.

Raspberry Pi 3 -- armv7.
http://tinycorelinux.net/8.x/armv7/releases/RPi/src/kernel/