WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: OpenVPN update please  (Read 130 times)

Offline rdebath

  • WikiUser
  • *
  • Posts: 13
OpenVPN update please
« on: April 23, 2017, 11:52:13 AM »
The version of OpenVPN in the extensions pool seems to be 2.2.2, this is about three years old.

It has lots of missing features including some I use, eg: compress, verify-x509-name, tls-crypt. Of those some are security enhancements, one prevents it working at all with my existing setup and others are support better encryption methods in OpenSSL.

In addition there is the "SWEET32" problem that hits OpenVPN because it's default encryption algorithm is Blowfish.

Does anyone have an update to this in the pipeline.

@gutmensch, you seem to be listed as the package owner, is this right or just by default ?
--
Robert

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5270
Re: OpenVPN update please
« Reply #1 on: April 23, 2017, 12:44:50 PM »
Hi rdebath
He hasn't been to the forum in a while so you might want to send gutmensch a PM.