WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: wBAR icons disabled from activation  (Read 171 times)

Offline PDP-8

  • Jr. Member
  • **
  • Posts: 61
wBAR icons disabled from activation
« on: April 19, 2017, 03:37:52 AM »
Corner-case issue noticed on TC and PiCore:

If a user clicks on any icon preceding the terminal icon, and summarily dismisses the window that comes up with the ESC key, rather than using the mouse to close the window, renders ALL wBAR icons insensitive to further mouse clicks.

Fortunately, the fix is simple from a user standpoint doing any of these:

1) Don't use the escape key to dismiss windows. :)

2) Click anywhere on the screen to bring up the hierarchical menu and go back to using icons

3) Go into a virtual terminal (ctrl-alt-f1) and back (ctrl-alt-f2) and icons are clickable again.

Minor nitpick on a corner case.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1400
Re: wBAR icons disabled from activation
« Reply #1 on: April 19, 2017, 03:55:09 AM »
Not so here. Not sure if I got you right though.
When I click the "Exit" icon in wbar and dismiss it with the ESCAPE key, things still work fine for me.
For you not?
Download a copy and keep it handy: Core book ;)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9072
Re: wBAR icons disabled from activation
« Reply #2 on: April 19, 2017, 03:55:38 AM »
does right-clicking on the wbar area fix things?

Offline PDP-8

  • Jr. Member
  • **
  • Posts: 61
Re: wBAR icons disabled from activation
« Reply #3 on: April 19, 2017, 01:07:57 PM »
Click on the APPS icon (or any other icon other to the left of the terminal icon) to bring up the window for that item.

Without clicking on anything, close the window by using the escape key.  Now try clicking on any of the icons again.  The icon just stutters a little bit.

I tried the right-click reset of the wBAR, but this does not reset the icon operation.  Only the 2 methods above seems to bring the icons back to normal.  A normal person (not me ) would probably just click around on the screen and reset it without knowing it. :)

I thought it may have been my laptop's keyboard, so I tried it on my Pi with a different keyboard, and it too seems to keep the esc key in a buffer or something that initially fools the mouse click.


Online coreplayer2

  • Hero Member
  • *****
  • Posts: 2349
Re: wBAR icons disabled from activation
« Reply #4 on: April 19, 2017, 10:34:46 PM »
Well, Maybe it's Window Manager related??

I'm using the greatest Hackedbox :p

I Select APPS icon, then hit Esc to close the window.  Thereafter all Wbar icons respond normally despite repeated attempts.

Sorry, can't help because I can't duplicate this..