WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore-9.0beta3 released  (Read 4100 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9636
Re: piCore-9.0beta3 released
« Reply #45 on: April 24, 2017, 08:56:14 AM »
Blueman uses blueman-manager and blueman-applet - use "ps aux | grep blue" to check if either of them are running and kill any instances if they are.

Next start blueman-manager in one terminal window and blueman-applet in another terminal window and check for any error messages.

Offline beerstein

  • Hero Member
  • *****
  • Posts: 520
Re: piCore-9.0beta3 released
« Reply #46 on: April 24, 2017, 10:28:58 AM »
both commands generated long lists - too long to post here. I just post the end part of both commands:

1. from blueman-applet:
UpdatePowerState (/usr/local/lib/python2.7/site-packages/blueman/plugins/applet/PowerManager.py:159)
off True
foff False
on True
current state False
new state False
_________
RequestPowerState (/usr/local/lib/python2.7/site-packages/blueman/plugins/applet/PowerManager.py:131)
Requesting 1
_________
on_power_state_change_requested (/usr/local/lib/python2.7/site-packages/blueman/plugins/applet/KillSwitch.py:119)
1
_________
UpdatePowerState (/usr/local/lib/python2.7/site-packages/blueman/plugins/applet/PowerManager.py:159)
off True
foff False
on True
current state False
new state False
_________
timeout (/usr/local/lib/python2.7/site-packages/blueman/plugins/applet/PowerManager.py:126)
Timeout reached while setting power state
_________
UpdatePowerState (/usr/local/lib/python2.7/site-packages/blueman/plugins/applet/PowerManager.py:159)
off True
foff False
on True
current state False
new state False
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

(blueman-applet:5797): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.



2. from blueman manager
pa_context_event (/usr/local/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py:341)
4
_________
on_pa_ready (/usr/local/lib/python2.7/site-packages/blueman/plugins/manager/PulseAudioProfile.py:27)
connected
_________
<lambda> (/usr/local/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py:353)
1
_________
get_interface_version (/usr/local/lib/python2.7/site-packages/blueman/bluez/BlueZInterface.py:13)
Detected BlueZ 5
_________
SetAdapter (/usr/local/lib/python2.7/site-packages/blueman/gui/DeviceList.py:269)
 
_________
SetAdapter (/usr/local/lib/python2.7/site-packages/blueman/gui/DeviceList.py:269)
No such adapter
_________
on_adapter_changed (/usr/local/lib/python2.7/site-packages/blueman/gui/manager/ManagerToolbar.py:80)
toolbar adapter None

(blueman-manager:5812): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/site-packages/blueman/gui/manager/ManagerMenu.py", line 92, in <lambda>
    item.connect('activate', lambda *args: self.blueman.Applet.open_plugin_dialog())
  File "/usr/local/lib/python2.7/site-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/local/lib/python2.7/site-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBu.ception: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
blueman-services version 2.0 starting
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
eth0

(blueman-services:5889): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/bullet-symbolic.svg.
This may indicate that pixbuf loaders or the mime database could not be found.
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
tc@box:~$

/usr/local/lib/python2.7/site-packages/blueman/gui/GenericList.py:6: PyGIWarning

It looks kike it can not find the default controller
t(w)o be(ers) or not t(w)o be(ers) that is the question

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9636
Re: piCore-9.0beta3 released
« Reply #47 on: April 24, 2017, 10:43:19 PM »
Did you comment out the disable bt overlay in the config?

(Also, please use code tags)

Offline beerstein

  • Hero Member
  • *****
  • Posts: 520
Re: piCore-9.0beta3 released
« Reply #48 on: April 25, 2017, 04:46:22 AM »
thanx -which config file do you mean? Just one or are there more than one?
t(w)o be(ers) or not t(w)o be(ers) that is the question

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9636

Offline beerstein

  • Hero Member
  • *****
  • Posts: 520
Re: piCore-9.0beta3 released
« Reply #50 on: April 27, 2017, 02:29:23 AM »
thank you Juanito. Now bluetooth works from command line. Connected a keyboard and a mouse, but had problems with an external bluetooth speaker. To hook this speaker up is probably another animal.
Pulseaudio comes into play here. Hmm?
Blueman does not work out of the box yet.
After the bluetooth daemon was running and I had the bluetooth command line:
Code: (bash) [Select]
[bluetooth]# connect 7C:1E:52:67:41:FA
Attempting to connect to 7C:1E:52:67:41:FA
I was able to start blueman from its icon in wbar and the management gui window was stable and working.
BTW: piCore with this configuration will be very useful with the newly introduced PI ZERO W, which has built in WIFI and Bluetooth - and is available too. Using Raspian with the ZERO ---> too slow IMO.
t(w)o be(ers) or not t(w)o be(ers) that is the question

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9636
Re: piCore-9.0beta3 released
« Reply #51 on: April 27, 2017, 04:30:35 AM »
yes, you will need pulseaudio to connect a bluetooth speaker