WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Apache can't execute index.php automatically  (Read 664 times)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5300
Re: Apache can't execute index.php automatically
« Reply #15 on: April 05, 2017, 06:23:04 PM »
Hi Adam
I don't recall the entire explanation but I think it had something to do with how tar handles paths.

Offline bkm

  • Jr. Member
  • **
  • Posts: 70
Re: Apache can't execute index.php automatically
« Reply #16 on: April 10, 2017, 09:56:20 AM »
Try adding this to your httpd.conf:

    <IfModule dir_module>
        DirectoryIndex index.php index.html
    </IfModule>

Very cool and many thanks to andyj for this. I wound up adding it to the very end of the httpd.conf file and it worked. However, if you really want to do it the right way, this same IfModlue appears around line# 223 in the httpd.conf file. You can edit it in place to match the syntax provided by andyj.

(Umm... YES, I did read the whole danged file eventually looking for any other settings that might be useful. I was bored  :P )

Just thought I would add this for those of us that like to do things cleanly when possible.  8)

BKM