WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Borked extension directory but backups work?  (Read 117 times)

Offline PDP-8

  • Jr. Member
  • **
  • Posts: 60
Borked extension directory but backups work?
« on: March 29, 2017, 01:35:50 AM »
First - thanks for picore!  TC was so nice I had to try it, so got my first PI rockin at the right resolutions, etc.

Problem which I researched - I seem to have borked my extension directory as not being writable, YET I am able
to have backups made when I shutdown, so I'm confused by the error that the APPS panel throws up.

Note - it *did* work initially, so I'm head-scratching at where I went wrong.

Things I have checked:
1) Made sure I have my TCE directory in /dev/mmcblk0p2 only.  Sure enough, when I mount and check it, I have the
TCE directory, along with the optional directory containing all my extensions.  There is NO tce directory in /dev/mmcblk0p1.

2) The APPS program complains about the mirror / network / directory not being writable.  Well, mirrors did work, my network
is up (I am on it now with Dillo), and I checked the permissions of the /dev/mmcblk0p2/tce/optional structure, and all are
writable by user and group.

3) Although maybe not directly related, mydata.tgz gets written just fine using filetool.sh, or when shutting down
graphically with the exit icon.

4) I also checked by running tce-setdrive and it informed me that /dev/mmcblk0p2 was already selected!  Note - issuing
tce-setdrive more than one time may not show this same message, but just drop back with no message.

NAUGHTY things I've done:
Explore the APPS maintenance functions.  Did some maintenance, without *truly* understanding, but no immediate harm was
detected.  BUT something tells me that my playing around here reset some pointers or something that borked my system.

Unless there is an easy diagnosis, I'll just start the install again from scratch.  Not a showstopper since it's fun.
Loving the pi experience, so thanks for picore!

Offline PDP-8

  • Jr. Member
  • **
  • Posts: 60
Re: Borked extension directory but backups work?
« Reply #1 on: March 29, 2017, 02:13:53 AM »
*** SOLVED ***

Whaddy'a know - it WAS a mirror(s) issue after all!

Even though the APPS program allowed me to choose the fastest mirror, that does not actually mean that it is serving!

I tried this a few times and got several that were fastest, but not actually working I guess.

So I chose the default server manually, and tada!  It's like nothing is wrong.

Cool - got some sysadmin skills sharpened. You know you're having fun when you should be asleep and hear birds waking up outside the window. :)