WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Core v8.0beta1  (Read 298 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9003
Core v8.0beta1
« on: March 14, 2017, 11:18:27 PM »
Team Tiny Core is pleased to announce that Tiny Core 8.0 Beta1 is available for public testing:

http://repo.tinycorelinux.net/8.x/x86/release_candidates/
http://repo.tinycorelinux.net/8.x/x86_64/release_candidates/

This is an beta level cut. If you decide to help test, then please test carefully. We don't want anyone to lose data.

Most extensions have been copied over from the 7.x repo - note that the Xorg-7.7 extensions have been updated and the ncurses and readline extensions have changed major versions.

We appreciate testing and feedback.

If you use distribution files note that you need a new vmlinuz and core.gz (or rootfs.gz + modules.gz)

Changelog for 8.0 beta1:
* busybox updated to 1.25.1 and cpio patched for uid/gid error
* kernel updated to 4.8.17
* glibc updated to 2.24
* gcc updated to 6.2.0
* e2fsprogs base libs/apps updated to 1.43.3
* util-linux base libs/apps updated to 2.28.2

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4176
Re: Core v8.0beta1
« Reply #1 on: March 15, 2017, 07:47:29 AM »
Something is weird with tce-update.
When updating libasound.tcz, every package in the repo is downloaded as a dependency.
There is no libasound.tcz.dep file in the repo.

------- Update ---------
I deleted the alsa, alsa-config, and libasound files from optional, and re-installed the 3 extensions.
There were no unusual deps loaded on installation.
« Last Edit: March 15, 2017, 08:16:03 AM by gerald_clark »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9003
Re: Core v8.0beta1
« Reply #2 on: March 16, 2017, 03:48:14 AM »
This change has been made to tce-update since 7.2:

https://github.com/tinycorelinux/Core-scripts/commit/992646e194a0effd1f81a8b5a76b463438951f3e

..but I don't see that causing the error you describe?

The other possibility is that libasound was updated about the same time as you reported the error - maybe it was something to do with that.

So far, I didn't manage to reproduce.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1344
Re: Core v8.0beta1
« Reply #3 on: March 21, 2017, 11:28:45 PM »
So far things work, except that Xorg uses the Gallium driver for the Intel 945GME (i915) which needed to be forced via xorg.conf.d before.
Is that expected to happen? Can I still use the old Intel driver somehow?
The Gallium driver provides only poor performance for me.
Download a copy and keep it handy: Core book ;)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9003
Re: Core v8.0beta1
« Reply #4 on: March 22, 2017, 09:56:57 PM »
Are you speaking of the modesetting driver loaded by Xorg or xf86-video-intel?

I guess that if gallium could be forced by settings in xorg.conf.d previously, it could be unforced by similar means?
« Last Edit: March 22, 2017, 09:59:24 PM by Juanito »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9003
Re: Core v8.0beta1
« Reply #5 on: March 24, 2017, 02:15:12 AM »
Doing some more checking, modesetting:
Code: [Select]
[   162.709] (II) Loading sub module "glamoregl"
[   162.709] (II) LoadModule: "glamoregl"
[   162.709] (II) Loading /usr/local/lib/xorg/modules/libglamoregl.so
[   162.728] (II) Module glamoregl: vendor="X.Org Foundation"
[   162.728] compiled for 1.19.1, module version = 1.0.0
[   162.728] ABI class: X.Org ANSI C Emulation, version 0.4
[   162.728] (II) glamor: OpenGL accelerated X.org driver based.
[   162.728] couldn't get display device
[   162.728] (EE) modeset(0): glamor initialization failed

modesetting + Xorg-7.7-3d:
Code: [Select]
[    43.604] (II) Loading sub module "glamoregl"
[    43.604] (II) LoadModule: "glamoregl"
[    43.604] (II) Loading /usr/local/lib/xorg/modules/libglamoregl.so
[    43.622] (II) Module glamoregl: vendor="X.Org Foundation"
[    43.622] compiled for 1.19.1, module version = 1.0.0
[    43.622] ABI class: X.Org ANSI C Emulation, version 0.4
[    43.622] (II) glamor: OpenGL accelerated X.org driver based.
[    43.693] (II) glamor: EGL version 1.4 (DRI2):
[    43.710] (II) modeset(0): glamor initialized

glxgears -> 300 frames in 5.0 seconds = 59.998 FPS

There is no mention of glamor in the Xorg log for xf86-video-intel with or without Xorg-7.7-3d