WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Ipv6 doesn't work  (Read 115 times)

Offline Looper

  • WikiUser
  • *
  • Posts: 18
Ipv6 doesn't work
« on: March 07, 2017, 01:31:26 AM »
I remaster a new Core with this Steps below :
-Install Tiny Core on VM Ware Workstation  (tc-installer)
-Config installed system (install Some Extension Like Openssl,OpenSSH , iptables ,ipv6 ,.... and Config them)
-Take a BackUP (filetool.sh -b)
-install ezremaster For Remastering
-Use Core.iso For .iso Require
-Use backupFile in /mnt/sda1/tc/mydata.gz
-and in next page i Use Load Button For All situation (Onboot , on init ,...)
-check fs flag and use chroot,..
-then next and Create .iso
when i use Created iso should be have the Same Config From My installed Tiny Croe
but when i boot and run Scrip (/opt/bootlocal.sh) Fore Some Setting (set ip , run Some Service)
i take Error For Set ipv6 on my interface (the Same Error When ever You Don't install ipv6 package ) ifconfig : socket :address family not supported by protocol linux

while ipv6 installed (i saw tail log when ezremaster worked) and .ko.gz file (on Live System) stored in /usr/local/lib/modules/4.x.x./kernel/ net/ipv6
and /lib/modules/kerner.tclocal/

It should be noted Other Modules Work very Well (iptables,openssl,openssh,...)
Please Help me to Solve this Problem ,...


Sent from my iPhone using Tapatalk

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9388
Re: Ipv6 doesn't work
« Reply #1 on: March 07, 2017, 02:16:00 AM »
You may need iana-etc and/or the full ifconfig (inetutils) or ip (iproute2).
The only barriers that can stop you are the ones you create yourself.

Offline Looper

  • WikiUser
  • *
  • Posts: 18
Re: Ipv6 doesn't work
« Reply #2 on: March 07, 2017, 02:25:07 PM »
You may need iana-etc and/or the full ifconfig (inetutils) or ip (iproute2).
i check ezremaster log,.. i saw ldconfig skipping all /usr/local/lib/....
how can i fix it ?