WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: wpa_supplicant seems to need missing dep liblzma5 in dCore-xenial  (Read 150 times)

Offline mcewanw

  • Full Member
  • ***
  • Posts: 102
Hi,

Just quickly tried using dCore-xenial.gz, vmlinuz-xenial and the dCore wireless sce's. However failed to connect with sudo wifi.sh (though my wifi network is displayed by the resultant scan).

I tried running wpa_supplicant manually but noted liblzma5 was a missing dependency, so I imagine that may be the problem.

I'm new to dCore and long time since I used tinycore. How do I fetch liblzma5 manually in dCore?

Many thanks,

William

Offline mcewanw

  • Full Member
  • ***
  • Posts: 102
Re: wpa_supplicant seems to need missing dep liblzma5 in dCore-xenial
« Reply #1 on: February 25, 2017, 03:20:18 AM »
In relation to my above post I should mention that I do not have an ethernet connection from this machine so was trying to side-load the wireless packages. I note that wpa_supplicant itself has openssl as a dependency. I read elsewhere that openssl should have liblzma5 as a dep but didn't originally (I think). I can't do any sce-updates though since no internet connection in dCore until I get wireless working...

William

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9176
Re: wpa_supplicant seems to need missing dep liblzma5 in dCore-xenial
« Reply #2 on: February 26, 2017, 04:07:50 AM »
Thanks for finding this issue.  I just now added liblzma5 as a dep to openssl.  I will repack the wireless SCEs this evening when I get in. 

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9176
Re: wpa_supplicant seems to need missing dep liblzma5 in dCore-xenial
« Reply #3 on: February 26, 2017, 09:21:14 PM »
The prebuilt wireless.sce extensions for the supported dCore x86 ports have been rebuilt with the liblzma5 dependency added.