WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?  (Read 743 times)

Offline silvio

  • WikiUser
  • *
  • Posts: 7
Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« on: February 07, 2017, 11:13:08 AM »
Hello,
I would love the use something that needs Qt4, but if I looked right, until now there is no Qt4 support in the current 8.X repository. Can I use the tcz files of the previous release 7.0 of tiny core linux for Raspberry somehow? or will it not work because of some reasons?

The 7.0 release of tiny core linux didn't run on my Raspberry 3.

I don't know how to compile such a big project (Qt4). Is there a repository of the old tcz-build-projects somewhere, maybe I could use it and try to adapt it?

Thank you in advance.

Silvio

Offline silvio

  • WikiUser
  • *
  • Posts: 7
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #1 on: February 07, 2017, 01:41:06 PM »
I copied all qt4-files from 7.X repo manually into the optional-folder of my 8.1.5 tc and made some really ugly and dirty adoptions (renamings) in the .dep files. Now I can run qmake and make and it fails at the beginning, because it cannot find some headers, but those files are at least somewhere . Does anyone have an idea?
:

Code: [Select]
tc@box:~/GUI$ make
/usr/local/bin/qmake -o Makefile GUI.pro
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/tmp/tcloop/qt4-dev/usr/local/mkspecs/linux-g++ -I. -I/usr/local/include/QtCore -I/usr/local/include/QtNetwork -I/usr/local/include/QtGui -I/usr/local/include -I. -I. -o main.o main.cpp
g++: error trying to exec 'as': execvp: No such file or directory
In file included from /usr/include/c++/6.3.0/armv7l-unknown-linux-gnueabihf/bits/c++config.h:507:0,
                 from /usr/include/c++/6.3.0/utility:68,
                 from /usr/include/c++/6.3.0/algorithm:60,
                 from /usr/local/include/QtCore/qglobal.h:68,
                 from /usr/local/include/QtCore/qnamespace.h:45,
                 from /usr/local/include/QtCore/qobjectdefs.h:45,
                 from /usr/local/include/QtGui/qwindowdefs.h:45,
                 from /usr/local/include/QtGui/qwidget.h:46,
                 from /usr/local/include/QtGui/qmainwindow.h:45,
                 from /usr/local/include/QtGui/QMainWindow:1,
                 from GUI/mainwindow.h:5,
                 from main.cpp:1:
/usr/include/c++/6.3.0/armv7l-unknown-linux-gnueabihf/bits/os_defines.h:39:22: fatal error: features.h: No such file or directory
 #include <features.h>
                      ^
compilation terminated.
make: *** [Makefile:354: main.o] Error 2
tc@box:~/GUI$ sudo find / -name "features.h"
/tmp/tcloop/gcc/usr/include/c++/6.3.0/parallel/features.h
find: /proc/4419: No such file or directory
/usr/include/c++/6.3.0/parallel/features.h
tc@box:~/GUI$

Online Misalf

  • Hero Member
  • *****
  • Posts: 1547
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #2 on: February 07, 2017, 04:25:06 PM »
I don't know if QT4 from 7.x will work on 8.x, but in theory you did the right thing.
However, you need to install  compiletc.tcz  in order to get the most needed stuff for compiling?
Download a copy and keep it handy: Core book ;)

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6897
    • My Community Forum
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #3 on: February 07, 2017, 09:41:05 PM »
I did not try the 7.x on 8.x but it is expected to work. Qt4/Qt5 for 8.x is on the todo list but with low priority.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline silvio

  • WikiUser
  • *
  • Posts: 7
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #4 on: February 08, 2017, 05:30:04 PM »
Thank you for all responses. The hint using the compiletc helped a lot. Now it goes through until linking process. I get some kind of this messages :

Code: [Select]
moc_mainwindow.o:(.rodata+0x244): undefined reference to `typeinfo for QMainWindow'

But I made a big step forward.
thanks a lot.

Silvio

Offline silvio

  • WikiUser
  • *
  • Posts: 7
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #5 on: February 09, 2017, 09:15:44 AM »
I have no idea and searched the internet for hours. Possible that the current compiler version and the version the libs are being made are to far away !? But currently I have no idea.. If anyone has an idea, please let me know.

Code: [Select]
g++ -Wl,-O1 -Wl,-rpath,/usr/local/lib -o GUI.exe main.o mainwindow.o winAVG_Setup.o communicationThread.o tty_fifo.o sharedMemory.o DiagramWindow.o hilfsFkt.o AnalogGaugeWindow.o StatisticsWindow.o LoggerWindow.o keyboard.o keyboardlineedit.o configStatLoggerWindow.o configAmplifierCoeffWindow.o moc_mainwindow.o moc_winAVG_Setup.o moc_DiagramWindow.o moc_AnalogGaugeWindow.o moc_StatisticsWindow.o moc_LoggerWindow.o moc_keyboard.o moc_keyboardlineedit.o moc_configStatLoggerWindow.o moc_configAmplifierCoeffWindow.o    -L/usr/local/lib -lQtGui -L/usr/local/lib -L/usr/X11R6/lib -lQtNetwork -lQtCore -lpthread
moc_mainwindow.o:(.rodata+0x244): undefined reference to `typeinfo for QMainWindow'
moc_winAVG_Setup.o:(.rodata+0x64): undefined reference to `typeinfo for QDialog'
moc_DiagramWindow.o:(.rodata+0x44): undefined reference to `typeinfo for QWidget'
moc_AnalogGaugeWindow.o:(.rodata+0x4c): undefined reference to `typeinfo for QWidget'
moc_StatisticsWindow.o:(.rodata+0x4c): undefined reference to `typeinfo for QWidget'
moc_LoggerWindow.o:(.rodata+0x44): undefined reference to `typeinfo for QWidget'
moc_keyboard.o:(.rodata+0xfc): undefined reference to `typeinfo for QDialog'
moc_keyboardlineedit.o:(.rodata+0x13c): undefined reference to `typeinfo for QLineEdit'
moc_configStatLoggerWindow.o:(.rodata+0x78): undefined reference to `typeinfo for QDialog'
moc_configAmplifierCoeffWindow.o:(.rodata+0x90): undefined reference to `typeinfo for QDialog'
collect2: error: ld returned 1 exit status
make: *** [Makefile:149: GUI.exe] Error 1
tc@box:~/GUI$

thanks in advance

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5346
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #6 on: February 09, 2017, 09:26:19 AM »
Hi silvio
Did you install the  qt dev  extensions? It looks like the  qt headers  are not being found.

Offline silvio

  • WikiUser
  • *
  • Posts: 7
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #7 on: February 10, 2017, 06:50:45 AM »
Hello Rich,
yes, I installed compilertc (gcc only doesn't work) and qt4-dev (and all the recursive tcz's automatically through this). qmake (part of qt4-dev) works without any problem and the compiler generates all object files (called via make), but the last step, linking to an executable file, fails. At the moment I didn't find a solution. If you have an other idea what I can try, I will be thankful. May be there is an additional option for the compiler, which I don't need for other distributions of Linux.

I found one very old post that indicates a compiler version conflict. Maybe I can try to use an other version of gcc/++ ?!
or a second point, the order of libraries.

Very interesting.. all this

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9378
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #8 on: February 10, 2017, 11:03:38 PM »
What version of qt-4.x are you trying to compile?

Did you take a look at this:

http://tinycorelinux.net/6.x/x86/tcz/src/qt-4.x/compile_qt4

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9520
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #9 on: February 11, 2017, 01:24:02 AM »
Looks like your app needs "-fno-rtti".
The only barriers that can stop you are the ones you create yourself.

Offline silvio

  • WikiUser
  • *
  • Posts: 7
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #10 on: February 13, 2017, 07:51:21 AM »
What version of qt-4.x are you trying to compile?

Did you take a look at this:

http://tinycorelinux.net/6.x/x86/tcz/src/qt-4.x/compile_qt4

This looks very interesting. I should try this.


Looks like your app needs "-fno-rtti".
I have read this too, but I didn't need it on other distributions of Linux. But I will check this too.

Thank you very much, I'll give feedback

Silvio

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6897
    • My Community Forum
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #11 on: February 13, 2017, 07:55:05 AM »
Just let you know, I bult Qt 5.8.0 for piCore 8.x I will pack it to .tcz in next days
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline silvio

  • WikiUser
  • *
  • Posts: 7
Re: Can I use Qt4-tcz's from Raspberry TCL 7.0 in 8.X somehow?
« Reply #12 on: February 13, 2017, 10:39:22 AM »
I added
Quote
QMAKE_CXXFLAGS += -fno-rtti
in the qt project file and it works for me. It compiles and links as it should do and the application seems to run without any issue.

Thank you for all your help!!

Qt5 sounds interesting , by the way ;)