WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: What happened to wireshark? Can anybody help install a version on TC 7.2?  (Read 1285 times)

Offline Rochey

  • WikiUser
  • *
  • Posts: 8
Re: What happened to wireshark? Can anybody help install a version on TC 7.2?
« Reply #15 on: February 09, 2017, 09:50:25 AM »
Just tested and it all looks good. I found wireshark in the repo! yay!

Also just tried to do a packet capture on both the Wireless and Wired interface an they both looked good.

Finally I can confirm that I didn't need to run it as sudo
 ;D

Thanks for all your help guys!!

Offline pstavirs

  • WikiUser
  • *
  • Posts: 2
Re: What happened to wireshark? Can anybody help install a version on TC 7.2?
« Reply #16 on: October 18, 2017, 10:11:23 PM »
Wireshark doesn't seem to work on the latest 8.2 release (32-bit). Exits with a X-Windows error of bad value - parameter out of range for operation.

Any ideas what's wrong and how to fix?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9608
Re: What happened to wireshark? Can anybody help install a version on TC 7.2?
« Reply #17 on: October 18, 2017, 10:35:39 PM »
It will not work for me with Xvesa, but will work with Xorg-7.7

Loading adwaita-icon-theme also reduces the warning message count...

Offline pstavirs

  • WikiUser
  • *
  • Posts: 2
Re: What happened to wireshark? Can anybody help install a version on TC 7.2?
« Reply #18 on: October 21, 2017, 09:25:17 PM »
Thanks @Juanito! It works for me also with Xorg-7.7 but not with Xvesa.

I also tried to build the Qt version of Wireshark (which has become the preferred version since Wireshark 2.x), but that also has the same problem.

In case someone's interested, here's my script to create wireshark-qt
Code: newbielink:javascript:void(0); [nonactive]
#/bin/sh

set -e
set -x

VERSION=2.4.2
PREFIX=/tmp/wireshark
LOCAL_EXTENSIONS=./local

# pre-req/dependencies
tce-load -wi compiletc libpcap-dev qt-4.x-dev
tce-load -wi autoconf automake libtool-dev libgcrypt-dev libcap-dev

# get and build protobuf
if [ ! -d wireshark-$VERSION ]; then
  wget https://2.na.dl.wireshark.org/src/wireshark-$VERSION.tar.xz
  tar xf wireshark-$VERSION.tar.xz
fi
cd wireshark-$VERSION
if [ ! -f config.h ]; then
  ./autogen.sh
  ./configure
fi

# TinyCore recommended flags
export CFLAGS="-march=i486 -mtune=i686 -O2"
export CXXFLAGS="-march=i486 -mtune=i686 -O2"
export LDFLAGS="-Wl,-O1"

# build and install
make -j`cat /proc/cpuinfo | grep processor | wc -l`
mkdir -p /tmp/wireshark
DESTDIR=/tmp/wireshark make install-strip

# package wireshark
PACKAGE=wireshark-qt
mksquashfs $PREFIX $PACKAGE.tcz
md5sum $PACKAGE.tcz > $PACKAGE.tcz.md5.txt
echo -e "qt-4.x-base.tcz\nlibpcap.tcz\nlibgcrypt\nlibasound" > $PACKAGE.tcz.dep
mkdir -p $LOCAL_EXTENSIONS
mv $PACKAGE.tcz* $LOCAL_EXTENSIONS

Note - some dependencies may be missing from above script

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9608
Re: What happened to wireshark? Can anybody help install a version on TC 7.2?
« Reply #19 on: October 21, 2017, 10:24:43 PM »
comment added to wireshark info file