WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: tce-load -wi curl.tcz | same commands but different error on different VMs  (Read 368 times)

Offline Adam

  • Full Member
  • ***
  • Posts: 121
Hi,

I've 3 unique experiences when installing curl. These 3 boxes installed from the Core 7.2.iso that I just downloaded.

This is the command that I use
tce-load -wi curl.tcz

1st box, no problem at all
Code: [Select]
tc@box1:~$ tce-load -wi curl.tcz
curl is already installed!
tc@box1:~$ curl
curl: try 'curl --help' or 'curl --manual' for more information
tc@box1:~$

2nd box, curl downloaded but not installed
Code: [Select]
tc@box2:~$ tce-load -wi curl.tcz
curl is already downloaded.
tc@box2:~$
tc@box2:~$ curl
-sh: curl: not found
tc@box2:~$

3rd box, error message "/tmp/tcloop/libssh2 failed: Invalid argument"
Code: [Select]
tc@box3:~$ tce-load -wi curl.tcz
curl.tcz.dep OK
mount: mounting /dev/loop34 on /tmp/tcloop/libssh2 failed: Invalid argument
tc@box3:~$
tc@box3:~$ curl
-sh: curl: not found
tc@box3:~$
« Last Edit: February 04, 2017, 05:09:53 AM by Adam »

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1540
Re: tce-load -wi curl.tcz | same commands but different error on different VMs
« Reply #1 on: February 04, 2017, 02:54:37 PM »
Onstead of
Code: [Select]
tce-load -wi curl.tcz
do
Code: [Select]
tce-load -w curl.tcz
tce-load -i curl.tcz

About the loop mount error, maybe the extension wasn't downloaded correctly, try
Code: [Select]
rm /etc/sysconfig/tcedir/optional/libssh2.tcz
tce-load -w libssh2.tcz
tce-load -i libssh2.tcz
Download a copy and keep it handy: Core book ;)