WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Cant start piCore 6.0-SSH on recently purchased R-Pi B+  (Read 1930 times)

Offline andriusr

  • WikiUser
  • *
  • Posts: 34
Cant start piCore 6.0-SSH on recently purchased R-Pi B+
« on: December 27, 2016, 05:19:27 AM »
Hi all,
I recently purchased R-Pi B+ and have problem - piCore 6.0-SSH does not starts on this system at all. The green LED on board lightens up, and stays on, which probably indicates some reading from SD card issue. I have some lagacy software that runs on 6.0 only, so I would be glad if someone can provide ideas how to fix it.
The same R-Pi starts perfectly with piCore 8.0-SSH. And SD card that does not work on new R-Pi B+ works very well on old one. So, it is probably related to the booting from SD card - some files probably needs to be updated.
Andrius

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7168
    • My Community Forum
Re: Cant start piCore 6.0-SSH on recently purchased R-Pi B+
« Reply #1 on: December 27, 2016, 05:22:33 AM »
What is missing in 8.x repo?

Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline andriusr

  • WikiUser
  • *
  • Posts: 34
Re: Cant start piCore 6.0-SSH on recently purchased R-Pi B+
« Reply #2 on: December 27, 2016, 05:37:24 AM »
bmarkus,
if I understand correctly, there is no way to fix 6.0-SSH files?

Offline andriusr

  • WikiUser
  • *
  • Posts: 34
Re: Cant start piCore 6.0-SSH on recently purchased R-Pi B+
« Reply #3 on: December 27, 2016, 10:34:51 PM »
Checked on raspberry forums and it seems there is no other way - just update. Probably bootcode.bin from piCore 6.0-SSH is not compatible with current revision of B+.
By the way, my tcz that was compiled/created on 6.0 still works on 8.0. I created single tcz file that includes all libraries I need in order to shorten boot time. Was expecting that it will not work on 8.0, however, it seems still OK. More testing is needed, for sure...