WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Adobe Flash Player (new beta) extension  (Read 685 times)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2436
Adobe Flash Player (new beta) extension
« on: November 05, 2016, 04:49:00 PM »
Finally an update and change in policy starting with v24
http://blogs.adobe.com/flashplayer/2016/08/beta-news-flash-player-npapi-for-linux.html#sthash.6721uaBB.dpbs

A new Flash plugin (beta version) for all supported Linux x86 & x86_64 Web browsers is available, currently version 24,0,0,145
v24.x beta release notes http://fpdownload.macromedia.com/pub/labs/flashruntimes/shared/air24_flashplayer24_releasenotes.pdf

Whether v11.2 will remain available is in question, though at present the min hardware requirements don't appear to have changed any.

v11.2 requirements
Quote
Linux

    2.33GHz or faster x86-compatible processor, or Intel Atom 1.6GHz or faster processor for netbooks
    32- and 64-bit: Red Hat® Enterprise Linux® (RHEL) 5.6 or later, openSUSE® 11.3 or later, or Ubuntu 10.04 or later
    Latest versions of Firefox or Google Chrome
    512MB of RAM; 128MB of graphics memory

Note: Flash Player 11.2 is the last supported Flash Player version for Linux. Adobe will continue to provide security updates.

v24.x requirements
Quote
Linux

    2.33GHz or faster x86-compatible processor, or Intel Atom 1.6GHz or faster processor for netbooks
    YUM, TAR.GZ, RPM and APT packages for NPAPI and PPAPI
    Latest versions of Mozilla Firefox or Google Chrome
    512MB of RAM; 128MB of graphics memory


At this point I feel a cautionary note is in order and I quote from Adobe's beta release notes:
Quote
The Flash Player beta is designed for evaluation purposes only. We do not recommended that this release be used on production systems or for any mission-critical work.


Meanwhile, I've modified the Original getFlash script to download and install Flash-player version 24.x.  I've had no issues with running the script, or the beta flash player plugin.   The beta download links may remain valid a while I hope.   

An important note: Please uninstall any previously installed flash10 or Flash11 extension before proceeding.

A "getFlash_beta.tcz" extension is being submitted asap.  However,  anyone wanting to test the getFlash_beta extension or get the the latest flash Player version 24.x please pm me for the latest getflash_beta.tcz



Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2436
Re: Adobe Flash Player (new beta) extension
« Reply #1 on: January 01, 2017, 12:57:16 AM »
Updates to getFlash_beta extensions, now supporting OSS, Alsa and Pulseaudio have been submitted.


the getFlash11 is no longer working since the update to Flash v24 went official.


Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2436
Re: Adobe Flash Player (new beta) extension
« Reply #2 on: January 02, 2017, 11:40:41 AM »
Moving forward, we'll have getFlash.tcz and getFlash_beta.tcz extension.

getFlash.tcz extension submitted today supports all TC-7 x86, x86_64 OSS, Alsa and pulseaudio installations.  This extension will fetch the latest officially supported flash version, currently at v24.0.0.186

The getFlash_beta.tcz extension will fetch the latest beta version, currently at v24.0.0.189.  Since the download path is not version dependent  this will likely still operate normally even if getFlash is temporarily broken. 


getFlash11 is depreciated, in fact is currently broken and will be no longer available.

Enjoy the latest Flash

Offline thane

  • Hero Member
  • *****
  • Posts: 616
Re: Adobe Flash Player (new beta) extension
« Reply #3 on: January 02, 2017, 03:29:29 PM »
FWIW, getFlash_beta worked for me, and the Flash beta version seems OK. Looking forward to trying getFlash since generally I like to stick with supported versions. Thanks coreplayer2 for all the work!

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2436
Re: Adobe Flash Player (new beta) extension
« Reply #4 on: January 02, 2017, 03:37:08 PM »
Thanks Thane, is good to hear.  I was getting a little concerned when you had trouble with deps etc etc..