WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: VMware tools/Open VM tools problem (x86_64 port)  (Read 2520 times)

Offline zacchi4k

  • WikiUser
  • *
  • Posts: 12
VMware tools/Open VM tools problem (x86_64 port)
« on: October 28, 2016, 07:15:49 AM »
Please note that I'm using the x86_64 port of TinyCore!!
I have some problems installing and using both VMware tools and Open VM Tools on a TinyCore virtual machine.

VMware tools:
After extracting the archive to /vmware/, I can't even start the installer.
Running vmware-install.pl (even with sudo) returns "line 6: ./vmware-install.real.pl: not found".
Running vmware-install.real.pl returns "sh: ./vmware-install.real.pl: not found".
It's like the file doesn't exist, but it's clearly there.

Open VM Tools:
I can actually download and install Open VM Tools from the Apps.... application, but only the mouse integration seems to work.
No automatic resizing and, most importantly, trying to enable shared folders (which I really need) returns an error regrading mounting the folders in the guest OS (even without any folders configured).

Can someone help me?


Screenshots:

Offline andyj

  • Sr. Member
  • ****
  • Posts: 476
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #1 on: October 28, 2016, 02:36:09 PM »
Read the comments for open-vm-tools in the app browser, they're important if you want it to work.
« Last Edit: October 28, 2016, 02:41:24 PM by andyj »

Offline zacchi4k

  • WikiUser
  • *
  • Posts: 12
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #2 on: October 29, 2016, 03:35:04 AM »
Read the comments for open-vm-tools in the app browser, they're important if you want it to work.



I can't find anything that could help me, not even that VMware KB link.

Offline andyj

  • Sr. Member
  • ****
  • Posts: 476
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #3 on: October 29, 2016, 05:04:12 AM »
Hmmm... I thought it was supposed to say this:

Comments:       Download and install in console before reboot; do not install while in X.
                Add to ~/.profile before startx to enable shared folders:
                        [ $(which vmware-checkvm) ] && [ vmware-checkvm ] && [ -d /mnt/hgfs ] && vmhgfs-fuse /mnt/hgfs
                Add to ~/.xsession after mouse-config to enable copy/paste, mouse grab/ungrab, and desktop resizing:
                        [ $(which vmware-checkvm) ] && [ vmware-checkvm ] && vmware-user &
                Move wbar to upper left vertical because wbar doesn't know when the desktop is resized.
                Aterm text does not render correctly, use lxterminal instead.
                Kernel modules removed, now all tools are userspace.
                Verify permissions for /dev/fuse are 1666.
                Loading the extension should create /mnt/hgfs. Verify that it happened and the permissions are 777.
                Files in shared folders will not be visible to anyone other than the user that
                        mounts them, including root. This is why if the shared folders are mounted
                        in a directory that is in a tree in /opt/.filetool.lst, backups will fail.
                Xorg and its dependencies are not needed for text only VM's.

Offline zacchi4k

  • WikiUser
  • *
  • Posts: 12
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #4 on: October 30, 2016, 12:28:46 AM »
Hmmm... I thought it was supposed to say this:

Comments:       Download and install in console before reboot; do not install while in X.
                Add to ~/.profile before startx to enable shared folders:
                        [ $(which vmware-checkvm) ] && [ vmware-checkvm ] && [ -d /mnt/hgfs ] && vmhgfs-fuse /mnt/hgfs
                Add to ~/.xsession after mouse-config to enable copy/paste, mouse grab/ungrab, and desktop resizing:
                        [ $(which vmware-checkvm) ] && [ vmware-checkvm ] && vmware-user &
                Move wbar to upper left vertical because wbar doesn't know when the desktop is resized.
                Aterm text does not render correctly, use lxterminal instead.
                Kernel modules removed, now all tools are userspace.
                Verify permissions for /dev/fuse are 1666.
                Loading the extension should create /mnt/hgfs. Verify that it happened and the permissions are 777.
                Files in shared folders will not be visible to anyone other than the user that
                        mounts them, including root. This is why if the shared folders are mounted
                        in a directory that is in a tree in /opt/.filetool.lst, backups will fail.
                Xorg and its dependencies are not needed for text only VM's.

Sorry, but I'm a total noob with Linux.
Does "-/" mean the root folder? I've tried to place the files there but it didn't work.

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2509
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #5 on: October 30, 2016, 01:22:54 AM »
Hi
Code: [Select]
~/
a tilde followed by a forward slash means 'home directory', typically this is /home/tc 
note: strictly speaking the " ~ " alone represents the home directory.

Also a period in front of the file name means the file has hidden attributes, therefore
Code: [Select]
~/.profileis a hidden file in the home directory.  In tinycore this will likely expand to " /home/tc/.profile "
« Last Edit: October 30, 2016, 01:48:21 AM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2509
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #6 on: October 30, 2016, 02:02:20 AM »
When I was new to Linux, I spend some time experimenting at the terminal, learning where I was exactly.
for example: you could have changed to the ~/ directory and asked the Present working directory variable where you where?
Code: [Select]
cd ~/; echo $PWD
or in keeping with simplicity
Code: [Select]
cd ~; pwd :P
« Last Edit: October 30, 2016, 02:32:22 AM by coreplayer2 »

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5420
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #7 on: October 30, 2016, 05:18:48 AM »
Hi coreplayer2
or in keeping with simplicity
Code: [Select]
cd ~; pwd :P
Or even simpler:
Code: [Select]
cd; pwd

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2509
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #8 on: October 30, 2016, 10:24:04 AM »
Rich,  8)
I have to agree the default path of " cd " is useful in returning to the home directory if that's all you wanted to accomplish right?   
However,  if someone new to Linux might wanted to know where ~/ was?  Seems logical they would change to ~/ then verify the location.   
Same for /

zacchi4k on the other hand, mistook the tilde key ( ~ ) for a hyphen ( - ) which can lead to a lot of confusion since the - option used with cd command refers to the last PWD. 


Offline zacchi4k

  • WikiUser
  • *
  • Posts: 12
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #9 on: October 30, 2016, 11:11:13 AM »
Rich,  8)
I have to agree the default path of " cd " is useful in returning to the home directory if that's all you wanted to accomplish right?   
However,  if someone new to Linux might wanted to know where ~/ was?  Seems logical they would change to ~/ then verify the location.   
Same for /

zacchi4k on the other hand, mistook the tilde key ( ~ ) for a hyphen ( - ) which can lead to a lot of confusion since the - option used with cd command refers to the last PWD.
IDK why I saw it as an hyphen...... Firefox for TC saw them as hyphens.
« Last Edit: October 30, 2016, 11:15:06 AM by zacchi4k »

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1575
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #10 on: October 30, 2016, 12:12:53 PM »
You might want to install additional fonts then.
Download a copy and keep it handy: Core book ;)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2509
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #11 on: October 30, 2016, 12:20:55 PM »
It's an easy mistake, but I've never seen Firefox mistake the ~ for a -
just saying

Offline zacchi4k

  • WikiUser
  • *
  • Posts: 12
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #12 on: October 30, 2016, 12:27:50 PM »
Hmmm... I thought it was supposed to say this:

Comments:       Download and install in console before reboot; do not install while in X.
                Add to ~/.profile before startx to enable shared folders:
                        [ $(which vmware-checkvm) ] && [ vmware-checkvm ] && [ -d /mnt/hgfs ] && vmhgfs-fuse /mnt/hgfs
                Add to ~/.xsession after mouse-config to enable copy/paste, mouse grab/ungrab, and desktop resizing:
                        [ $(which vmware-checkvm) ] && [ vmware-checkvm ] && vmware-user &
                Move wbar to upper left vertical because wbar doesn't know when the desktop is resized.
                Aterm text does not render correctly, use lxterminal instead.
                Kernel modules removed, now all tools are userspace.
                Verify permissions for /dev/fuse are 1666.
                Loading the extension should create /mnt/hgfs. Verify that it happened and the permissions are 777.
                Files in shared folders will not be visible to anyone other than the user that
                        mounts them, including root. This is why if the shared folders are mounted
                        in a directory that is in a tree in /opt/.filetool.lst, backups will fail.
                Xorg and its dependencies are not needed for text only VM's.
Just tried it.
Went to console and created all the files with vi. Results? The same. Still doesn't work.
« Last Edit: October 30, 2016, 12:31:17 PM by zacchi4k »

Offline andyj

  • Sr. Member
  • ****
  • Posts: 476
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #13 on: October 30, 2016, 03:48:40 PM »
You shouldn't have had to create any files. They should already have been there. You only needed to add one line to .profile and one line to .xsession.

Offline zacchi4k

  • WikiUser
  • *
  • Posts: 12
Re: VMware tools/Open VM tools problem (x86_64 port)
« Reply #14 on: October 31, 2016, 12:51:29 AM »
It's an easy mistake, but I've never seen Firefox mistake the ~ for a -
just saying

This is how the ~ appears in Firefox for TC:


However I noticed it appears correctly in a quoted message: