WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: No HD in TC 7.2 under Hyper-V  (Read 560 times)

Offline redetho

  • WikiUser
  • *
  • Posts: 5
No HD in TC 7.2 under Hyper-V
« on: October 22, 2016, 02:02:16 AM »
Dear experts,
I do not get access to the harddisk (VHD) in TC 7.2 under desktop Hyper-V Win 10 Pro (same issue in TC 7.1, 7.0).
Please see boot error messages attached.

Same set-up works with TC 6.4.1.
Please help

BR
Redetho

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9387
Re: No HD in TC 7.2 under Hyper-V
« Reply #1 on: October 24, 2016, 06:05:42 AM »
That your disk detection would time out points to a bug either in the kernel or in HyperV. I'm afraid I can't point to any quick fix, you'd need to try different kernel and/or hyperv versions.
The only barriers that can stop you are the ones you create yourself.

Offline redetho

  • WikiUser
  • *
  • Posts: 5
Re: No HD in TC 7.2 under Hyper-V
« Reply #2 on: January 10, 2017, 11:55:34 AM »
Hi curaga,
I had another look at this.
There is an older thread about the same issue
http://forum.tinycorelinux.net/index.php/topic,19216.0.html?PHPSESSID=vfG99sKqccG7rcvBENLZn2

Juanito wrote then
 "hv_storvsc module added back into base and 6.4.1 iso's/distribution files reposted"
which solved the issue.

Could you check whether 7.x have inherited that issue?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9387
Re: No HD in TC 7.2 under Hyper-V
« Reply #3 on: January 11, 2017, 02:11:14 AM »
The module is present in 7.x, so it's not the same issue.
The only barriers that can stop you are the ones you create yourself.