WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: wifi is not working  (Read 2573 times)

Offline xpdx

  • WikiUser
  • *
  • Posts: 11
wifi is not working
« on: October 07, 2016, 04:17:01 AM »
Greetings,

For a Micro Core installed on HDD I can't use the wifi.

It seems that I have to
Quote
blacklist the bcma and b43 modules for wl to work with your wifi
as coreplayer2 said on #tinycorelinux IRC channel

Here are the last outputs:

Code: [Select]
tc@box:~$ tce-load -w pci-utils
pci-utils is already downloaded.
tc@box:~$ tce-load -i pci-utils
pci-utils is already installed!
tc@box:~$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port [8086:2a01] (rev 0c)
00:19.0 Ethernet controller [0200]: Intel Corporation 82562GT 10/100 Network Connection [8086:10c4] (rev 03)
00:1a.0 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 [8086:2834] (rev 03)
00:1a.1 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03)
00:1a.7 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 03)
00:1c.4 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 [8086:2847] (rev 03)
00:1d.0 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)
00:1d.1 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)
00:1d.2 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)
00:1d.7 USB controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HM (ICH8M) LPC Interface Controller [8086:2815] (rev 03)
00:1f.1 IDE interface [0101]: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller [8086:2850] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] [8086:2829] (rev 03)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV516/M62-S [Mobility Radeon X1350] [1002:7196]
10:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312] (rev 02)
tc@box:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82562GT 10/100 Network Connection (rev 03)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 03)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV516/M62-S [Mobility Radeon X1350]
10:00.0 Network controller: Broadcom Corporation BCM4311 802.11a/b/g (rev 02)
tc@box:~$

Code: [Select]

tc@box:~$ iwconfig
ip_vti0   no wireless extensions.

dummy0    no wireless extensions.

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11abg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
tunl0     no wireless extensions.

tc@box:~$ dmesg | tail -20
b43 ssb0:0: Falling back to user helper
Broadcom 43xx driver loaded [ Features: PMNLS ]
b43 ssb0:0: Direct firmware load for b43/ucode13.fw failed with error -2
b43 ssb0:0: Falling back to user helper
b43 ssb0:0: Direct firmware load for b43-open/ucode13.fw failed with error -2
b43 ssb0:0: Falling back to user helper
b43 ssb0:0: Direct firmware load for b43-open/ucode13.fw failed with error -2
b43 ssb0:0: Falling back to user helper
b43-phy0 ERROR: Firmware file "b43/ucode13.fw" request failed (err=-11)
b43-phy0 ERROR: Firmware file "b43-open/ucode13.fw" request failed (err=-11)
b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
e1000e 0000:00:19.0 eth0: 10/100 speed: disabling TSO
wl: module license 'MIXED/Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
malloc in abgphy done
malloc in abgphy done
eth1: Broadcom BCM4312 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)
ERROR @wl_dev_intvar_get : error (-1)
ERROR @wl_cfg80211_get_tx_power : error (-1)
tc@box:~$

Thank you.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9462
Re: wifi is not working
« Reply #1 on: October 07, 2016, 04:50:22 AM »
If you look up your hardware, Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312], here:

https://wireless.wiki.kernel.org/en/users/Drivers/b43

..it would seem that you have the choice of either the reverse engineered b43 kernel driver or the closed source wl kernel driver

If you choose to use the b43 driver, you will need to "cut" the broadcom firmware, which is not easy to do if you are new to linux.

If you  choose to use the wl driver, you will need to blacklist the bcma, ssb and b43 drivers so that they are not loaded when tinycore boots and/or the wireless-KERNEL extension is loaded (you can see from your dmesg output that the b43 driver is trying unsuccessfully to load the ucode13.fw firmware).

You don't mention what you are using to boot tinycore, but you need to add "blacklist=bcma, ssb, b43" to the bootloader  boot codes if you choose to use the wl-modules-KERNEL extension containing the wl driver.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6907
    • My Community Forum
Re: wifi is not working
« Reply #2 on: October 07, 2016, 04:52:19 AM »
As in the log:

Firmware file "b43-open/ucode13.fw" request failed

Install firmware.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline xpdx

  • WikiUser
  • *
  • Posts: 11
Re: wifi is not working
« Reply #3 on: October 07, 2016, 08:28:26 AM »
Thank you bmarkus

Excuse me, I forgot to say, I am a Linux beginner,

Tell me please is this the correct way?

Code: [Select]
tc@box:~$ tce-load -wi firmware-broadcom_bcm43xx.tcz
firmware-broadcom_bcm43xx is already installed!

If this is the correct way for
As in the log:

Firmware file "b43-open/ucode13.fw" request failed

Install firmware.


It seems that it had been installed before the outputs form the initial first topic was out.

Thank you.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1553
Re: wifi is not working
« Reply #4 on: October 07, 2016, 08:43:29 AM »
Try  tce-load -i xyz.tcz  (without the -w option).

-w  downloads
-i  installs
If the extension was already downloaded previously and  tce -wi xyz.tcz  is used, tce-load will abort and not install.

So actually, often it's more reliable to use tce-load in two steps:
Code: [Select]
tce-load -w xyz.tcz
tce-load -i xyz.tcz
« Last Edit: October 07, 2016, 08:45:28 AM by Misalf »
Download a copy and keep it handy: Core book ;)

Offline xpdx

  • WikiUser
  • *
  • Posts: 11
Re: wifi is not working
« Reply #5 on: October 07, 2016, 09:09:22 AM »
I appreciate Misalf,

Code: [Select]
tc@box:~$ tce-load -w firmware-broadcom_bcm43xx.tcz
firmware-broadcom_bcm43xx is already downloaded.
tc@box:~$ tce-load -i firmware-broadcom_bcm43xx.tcz
firmware-broadcom_bcm43xx is already installed!
tc@box:~$

Regards.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6907
    • My Community Forum
Re: wifi is not working
« Reply #6 on: October 07, 2016, 09:40:56 AM »
As I see, fw is not in the TC repo. You can download it here:

https://github.com/OpenELEC/wlan-firmware/blob/master/firmware/b43/ucode13.fw

As I do not have such adapter, can't test it. If it doesn't work Google.

Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2494
Re: wifi is not working
« Reply #7 on: October 07, 2016, 07:52:10 PM »
Great, if this fw works maybe we'll not have to blacklist or use wl modules


Offline xpdx

  • WikiUser
  • *
  • Posts: 11
Re: wifi is not working
« Reply #8 on: October 07, 2016, 11:55:53 PM »
Excuse me, I am novice and maybe even not a part time Linux user...

I couldn't manage to find how to set up/load on Tiny Core the ucode13.fw
https://github.com/OpenELEC/wlan-firmware/blob/master/firmware/b43/ucode13.fw


Respectfully.


Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 2494
Re: wifi is not working
« Reply #9 on: October 08, 2016, 12:13:44 AM »
Hi

to use the firmware file, download it and copy to /usr/local/lib/firmware/ucode13.fw
if the firmware directory does not exist, create it.
add ucode13.fw file to your backup list  (control panel > Backup /Restore) then make a backup.

remove any bcma,ssb and b43 blacklisted modules from extlinux.conf   
remove wl-modules-4.2.9-tinycore.tcz from mnt/sda2/tc7-x86/onboot.lst 

then reboot

confirm /usr/local/lib/firmware/ucode13.fw exists
confirm ucode13.fw is in use, check   dmesg | tail -20
« Last Edit: October 08, 2016, 12:19:07 AM by coreplayer2 »

Offline xpdx

  • WikiUser
  • *
  • Posts: 11
Re: wifi is not working
« Reply #10 on: October 08, 2016, 01:58:53 AM »
My apologizes,

I am trying for one hour to copy from the terminal and paste the outputs in here, pressing both touchpad left-right buttons from the wireless keyboard(no middle button), but very rarely is working...

I've done my best, hopefully I've done correctly all the coreplay2 steps indicates...

to use the firmware file, download it and copy to /usr/local/lib/firmware/ucode13.fw
if the firmware directory does not exist, create it.

Code: [Select]
ls /usr/local/lib/firmware
The ucode13.fw was there together with brcm folder but after reboot, ucode13.fw wasn't there any more.

add ucode13.fw file to your backup list  (control panel > Backup /Restore) then make a backup.

remove any bcma,ssb and b43 blacklisted modules from extlinux.conf   
remove wl-modules-4.2.9-tinycore.tcz from mnt/sda2/tc7-x86/onboot.lst 

Done all that, no wifi yet... unfortunately... :) Keep going :)
« Last Edit: October 08, 2016, 02:05:48 AM by xpdx »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9462
Re: wifi is not working
« Reply #11 on: October 08, 2016, 05:26:02 AM »
did you create the firmware folder before copying the firmware file to it:

Code: [Select]
$ sudo mkdir -p /usr/local/lib/firmware
$ sudo cp ucode13.fw /usr/local/lib/firmware

Offline xpdx

  • WikiUser
  • *
  • Posts: 11
Re: wifi is not working
« Reply #12 on: October 08, 2016, 05:53:54 AM »
Thank you Juanito

Done again (maybe trying for the fourth time) exactly as you said Juanito, checked if the the files is there before reboot, it was, after reboot gone again...

The firmware folder has already been there before starting all the process from scratch, and before copying the file in it.

Best wishes.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1553
Re: wifi is not working
« Reply #13 on: October 08, 2016, 06:16:23 AM »
Did you
add ucode13.fw file to your backup list  (control panel > Backup /Restore) then make a backup.
?
Download a copy and keep it handy: Core book ;)

Offline xpdx

  • WikiUser
  • *
  • Posts: 11
Re: wifi is not working
« Reply #14 on: October 08, 2016, 09:00:29 AM »
Maybe I am not doing it correct?

Control panel - > Backup/Restore - Chose Action Backup, let device like it is from default /sda1/tce and press Go.

Maybe it was a problem because when I did it for the first time I pasted in the Device field  /usr/local/lib/firmware/ucode13.fw and for action was Dry Run and I pressed Go.

After that I saw I made a mistake, I closed the Backup/Restore windows and it opened again as default with /sda1/tce for Device, I chose Backup as action and pressed go.

After restart, because I thought I messed up with the restore, and that's why ufcode13.fw is not there any more, I copied again the ucode13.fw to /usr/local/lib/firmware/ I checked if it is there, it was. Continuing with Control Panel - Backup - let as default with /sda1/tce for Device, I chose Backup as action and pressed go.

At the end of Backup it is saying "Done"

And tried it for a few times more, but still ucode13.fw is disappearing after restart.
« Last Edit: October 08, 2016, 09:13:04 AM by xpdx »