WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Web browsers requiring ca-certificates  (Read 1287 times)

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Web browsers requiring ca-certificates
« on: September 20, 2016, 03:01:05 PM »
Spent some time in a minimal boot environment playing with browsers. Could the following please have  ca-certificates  added as a dependency. Not sure why Debian doesn't do this as default, without this dependency most browsers are almost unusable.

netsurf-gtk
surf
lynx
qupzilla
links2
midori (reportedly added earlier but does not show on re-import)

Please let me know when posted, will re-import and retest. Thanks.



Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9278
Re: Web browsers requiring ca-certificates
« Reply #1 on: October 05, 2016, 05:03:08 PM »
Just saw this, added the ca-certificates dep to them.
Thanks.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Web browsers requiring ca-certificates
« Reply #2 on: October 08, 2016, 08:17:42 PM »
Thanks Jason, all check out good, nicer browsing experience.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Web browsers requiring ca-certificates
« Reply #3 on: October 16, 2016, 02:15:33 PM »
The arora browser would also benefit from ca-certificates, thanks.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Web browsers requiring ca-certificates
« Reply #4 on: October 16, 2016, 02:23:21 PM »
...and Dooble too please, can't even access HTTPS without it (no continue anyway prompt).

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9278
Re: Web browsers requiring ca-certificates
« Reply #5 on: October 16, 2016, 04:35:13 PM »
Ok, done.  I also added it to firefox as in dCore-xenial it does not work in a minimal environment without it, will not accept keyboard input into the search field. 

I added ca-certificates as a dep to the following packages, hopefully covers the webkit based browsers:
libwebkitgtk-1.0-0
libwebkitgtk-3.0-0
libwebkitqt4

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Web browsers requiring ca-certificates
« Reply #6 on: October 16, 2016, 08:22:57 PM »
Appears ca-certificates was applied to all required except  arora  which uses  libqt5webkit5  , thanks.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Web browsers requiring ca-certificates
« Reply #7 on: October 18, 2016, 03:55:13 PM »
Last update check still missing in Arora.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9278
Re: Web browsers requiring ca-certificates
« Reply #8 on: October 18, 2016, 04:13:29 PM »
Misspelling on my part of libqt5webkit5, as it is a change in format from libqtwebkit4.  Should be good now.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Web browsers requiring ca-certificates
« Reply #9 on: October 19, 2016, 04:13:38 AM »
Got it now, thanks.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Web browsers requiring ca-certificates
« Reply #10 on: October 19, 2016, 07:28:26 PM »
OK, last one is otter-browser but it's PPA only, not sure if you can attach the dependency or should i just add wiki note?
http://wiki.tinycorelinux.net/dcore:desktop_applications#otter_browser

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9278
Re: Web browsers requiring ca-certificates
« Reply #11 on: October 20, 2016, 02:26:49 PM »
Added ca-certificates to the dependency list of otter-browser.