WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: How to make alsa work with Xvesa if hdmi is the default sound device  (Read 1393 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9252
If, like me, you have a laptop with intel sound where hdmi is always set as the default alsa device rather than the laptop speakers, you will have found that sound will not work with Xvesa.

To fix this, force the laptop speakers to be the default device and then, although there will be some error messages, sound will work with Xvesa.

* force the laptop speakers to be the default by modifying modprobe.conf like this:
Code: [Select]
$ cat /etc/modprobe.conf
# /etc/modprobe.conf: Modprobe config file.
#
options snd-hda-intel id=PCH index=0
options snd-hda-intel id=HDMI index=1

* load the alsa extension
* use alsamixer to un-mute the master volume control