WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: JWM's Apps Menu empty in 2.1rc1  (Read 1850 times)

Offline SvOlli

  • Full Member
  • ***
  • Posts: 193
  • Linux Developer
JWM's Apps Menu empty in 2.1rc1
« on: June 17, 2009, 08:01:18 AM »
Hello,

I've set up a double boot system for booting both 2.0 and 2.1rc1 just by changing the initrd. In 2.1rc1 the "Apps" submenu has no entry. In 2.0 they are back again. Switching to 2.1rc1 will make them disappear again, and so on.

I've used Opera and SciTE as applications for testing.

I might have the time for checking the details out on the weekend...

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: JWM's Apps Menu empty in 2.1rc1
« Reply #1 on: June 17, 2009, 08:19:33 AM »
2.0 and 2.1 use very different application menu files.
2.0 is a collection of includes while 2.1 is a single text file.
If you are using any kind of persistency you will have issues switching back and forth.
If you let the system rebuild the menu during boot, as is normal, then should not be a problem.
10+ Years Contributing to Linux Open Source Projects.

Offline SvOlli

  • Full Member
  • ***
  • Posts: 193
  • Linux Developer
Re: JWM's Apps Menu empty in 2.1rc1
« Reply #2 on: June 18, 2009, 10:04:14 AM »
Thanks for the explanation. Is there any way I can trigger this process "by hand" (e.g. from the shell by calling a script or removing a file before reboot)?

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: JWM's Apps Menu empty in 2.1rc1
« Reply #3 on: June 19, 2009, 08:04:12 AM »
Even with using a tclocal I did not see any issues. However, the include extension menu is:

/usr/local/tce.menu/menu

Manually calling jwm_makemenu on each menu item in /usr/local/tce.menu/ directory will rebuild the extension menu.
10+ Years Contributing to Linux Open Source Projects.

Offline SvOlli

  • Full Member
  • ***
  • Posts: 193
  • Linux Developer
Re: JWM's Apps Menu empty in 2.1rc1
« Reply #4 on: June 19, 2009, 03:54:18 PM »
Ah, I found the problem:
I've got /usr/local/bin/awk installed which states when running jwm_makemenu:
awk: cmd. line:18: (FILENAME=/usr/local/tce.menu/menu FNR=4) fatal: file `/usr/local/tce.menu/' is a directory.

If I change the line 9 in /usr/bin/jwm_makemenu from:
Code: [Select]
awk -v appname="$1" -v outfile="$OUTFILE"to:
Code: [Select]
busybox awk -v appname="$1" -v outfile="$OUTFILE"the menus are created. I haven't done anything with awk, so I can't tell if the script needs fixing, but at least, I can introduce a workaround.  ;)