WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: ALSA problem with VirtualBox and Intel HD Audio  (Read 6769 times)

Offline duplipensar

  • WikiUser
  • *
  • Posts: 4
ALSA problem with VirtualBox and Intel HD Audio
« on: February 26, 2016, 04:33:40 PM »

I'm have some problems with audio inside the guest system (Tiny Core x86 6.4.1). I test the sound with aplay and it play well and nice when I am using virtualbox “ICH AC97” audio controller. But when I change the virtualbox controller to “Intel HD Audio” I got the error:

#aplay test.wav
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
aplay: main:722: audio open error: No such file or directory

The funny thing is I kind remember it worked well in the past with both audio controllers (only with virtualbox SoundBlaster 16 it never worked). So, to make sure the problem was not in my installation I make the same test using a TinyCore liveCD as downloaded in the site (with Xvesa and no audio). I booted it and installed ONLY alsa-config.tcz (and consequently its dependencies pci-utils.tcz, alsa.tcz, etc). I did the test with “Intel HD Audio” and got exact same error. And the same test from the liveCD using “ICH AC97” works very well.

That's kind driving me crazy here because I almost sure I remember it working in both audio controllers. But it could be a false memory.

Looking in the internet I only find similar problems with people with more then one audio cards and they solve that using a file .asoundrc in the home directory or with the line “option snd_hda_intel index=1” in a modprobe config file. I tried both and in my case with only one card those don't solve the problem.

What I have missed? Does anyone know how to fix it? I can do sound with “ICH AC97” but I need make it working with “Intel HD Audio” too.

Follow some information of the system (Intel HD Audio version):
Virtualbox version 4.3.18;
Host: Windows 7;
Guest: Tiny Core x86 6.4.1 original liveCD.
Only thing I installed after the boot is a download+load (using Apps) in the alsa-config.tcz witch bring all dependencies (I also did it in parts. first download and them tce-load to check for errors and everything looks OK).


00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:05.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 01)
00:06.0 USB controller: Apple Inc. KeyLargo/Intrepid USB
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0b.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller
00:0d.0 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 02)

Module                  Size  Used by    Not tainted
snd_hda_codec_idt      45056  1
snd_hda_codec_generic    36864  1 snd_hda_codec_idt
snd_hda_intel          20480  0
snd_hda_controller     20480  1 snd_hda_intel
snd_hda_codec          57344  4 snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
snd_hwdep              12288  1 snd_hda_codec
snd_pcm                49152  3 snd_hda_intel,snd_hda_controller,snd_hda_codec
snd_timer              20480  1 snd_pcm
snd                    40960  7 snd_hda_codec_idt,snd_hda_codec_generic,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore              12288  2 snd_hda_codec,snd
joydev                 16384  0
cpufreq_conservative    12288  0
cpufreq_stats          12288  0
cpufreq_userspace      12288  0
cpufreq_powersave      12288  0
ppdev                  12288  0
parport_pc             24576  0
parport                24576  2 ppdev,parport_pc
battery                16384  0
squashfs               24576  8
loop                   20480 16
ac                     12288  0
microcode              12288  0
e1000                  77824  0
pcspkr                 12288  0

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 1: STAC9221 A1 Digital [STAC9221 A1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Thank you for any help!

Offline duplipensar

  • WikiUser
  • *
  • Posts: 4
Re: ALSA problem with VirtualBox and Intel HD Audio
« Reply #1 on: February 26, 2016, 08:09:04 PM »

I have some news. I was able to make the "aplay test.wav" play after reloading the module with parementers:

#modprobe -r snd_hda_intel
#modprobe snd_hda_intel model=intel-mac-v3

After that the "aplay -l" shows two devices, the digital device that always was there and a new analog device. And after that the "aplay test.wav" play the audio correctly.

But I note the PCM channel are still missing in the alsamixer. Does anyone know why PCM are still missing?

Also, why it didn't work in the normal startup? Is there some bug in the hardware detection that was supposed to pass the parameter 'model=intel-mac-v3' and did not passed it? Does anyone else has this problem in a real hardware (outside the virtualbox)?

And, guys. I have the memory the HDA has worked before withou any module reload need in the virtualbox. Does someone know what I could be doing wrong to need this module reload?

Thank you.
« Last Edit: February 26, 2016, 08:32:55 PM by duplipensar »

Offline duplipensar

  • WikiUser
  • *
  • Posts: 4
Re: ALSA problem with VirtualBox and Intel HD Audio
« Reply #2 on: February 26, 2016, 08:28:05 PM »
I also just downloaded and tried the new TinyCore 7.0 liveCd. Did the same tests and the problem continues.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12401
Re: ALSA problem with VirtualBox and Intel HD Audio
« Reply #3 on: February 26, 2016, 10:13:55 PM »
You could try loading the alsa-config extension before the alsa extension.

To do this, you will need to edit your alsa-config.tcz.dep file locally and delete "alsa.tcz", reboot and then load alsa-config before alsa.

Offline duplipensar

  • WikiUser
  • *
  • Posts: 4
Re: ALSA problem with VirtualBox and Intel HD Audio
« Reply #4 on: February 27, 2016, 05:40:10 AM »
I have notice PCM appears in alsamixer after execution of aplay once. In other words not just after the module reload.

You could try loading the alsa-config extension before the alsa extension.
It didn't work. Exact same behavior. It only worked after reload the snd_hda_intel with model=intel-mac-v3 parameter.

Thank you.