WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: wicd daemon doesn't start  (Read 9431 times)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #60 on: April 17, 2016, 03:05:17 PM »
Code: [Select]
sudo wicd
just starts the daemon.

It should do so, but it does not. This is the problem.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: wicd daemon doesn't start
« Reply #61 on: April 17, 2016, 03:38:40 PM »
Please read the info file.
Download a copy and keep it handy: Core book ;)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: wicd daemon doesn't start
« Reply #62 on: April 17, 2016, 09:52:27 PM »
Just to be clear:

For the carl9170 driver to work properly, the firmware and wireless-KERNEL extensions need to be loaded before the carl9170-modules-KERNEL extension is loaded.

This would normally be taken care of by the carl9170-modules-KERNEL dep file, but I am not sure that you have this file in your tce/optional folder.

For the wicd extension to work, both the dbus and wicd daemons need to be started and the carl9170-modules-KERNEL extension loaded before double-clicking on the wicd icon/running "wicd-gtk --no-tray".

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #63 on: April 17, 2016, 10:35:55 PM »
I reboot and startx. Then:

Code: [Select]
tc@box:~$ tce-load -i firmware
firmware.tcz: OK
tc@box:~$ tce-load -i wireless-4.2.9-tinycore
wireless-4.2.9-tinycore.tcz: OK
tc@box:~$ tce-load -i carl9170-modules-4.2.9-tinycore
carl9170-modules-4.2.9-tinycore.tcz: OK
tc@box:~$ tce-load -i wicd
libffi5.tcz: OK
ncurses-utils.tcz: OK
net-tools.tcz: OK
dhcpcd.tcz: OK
libiw.tcz: OK
wireless_tools.tcz: OK
readline.tcz: OK
libnl.tcz: OK
wpa_supplicant-dbus.tcz: OK
gdbm.tcz: OK
bzip2-lib.tcz: OK
sqlite3.tcz: OK
python.tcz: OK
urwid.tcz: OK
dbus-python.tcz: OK
pycairo.tcz: OK
gobject-introspection.tcz: OK
pygobject.tcz: OK
pygtk.tcz: OK
wicd.tcz: OK
tc@box:~$ sudo /usr/local/etc/init.d/dbus start
tc@box:~$ sudo /usr/local/etc/init.d/wicd start
Starting wicd daemon
tc@box:~$ wicd-gtk --no-tray

The gui started, I connected to the wireless network, but the browser doesn't load pages. The light on the adapter has also been turned off.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #64 on: April 17, 2016, 11:09:09 PM »
I added to /opt/bootlocal.sh:
Code: [Select]
/usr/local/etc/init.d/dbus restart
/usr/local/etc/init.d/wicd start

I added to /opt/.filetool.lst:
Code: [Select]
usr/local/etc/wicd
var/lib/wicd/configurations

I added firmware, wireless-4.2.9-tinycore, carl9170-modules-4.2.9-tinycore & wicd extensions to onboot list.

I rebooted.

I started wicd daemon and conected to the wireless network. Again, firefox doesn't load pages and the light on the adapter has been turned off.

/mnt/sda1/tce/optional/carl9170-modules-4.2.9-tinycore.tcz.dep exists and its content is:

Code: [Select]
wireless-KERNEL.tcz
firmware.tcz

Note that wireless-KERNEL.tcz is written this way and not wireless-4.2.9-tinycore.tcz.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: wicd daemon doesn't start
« Reply #65 on: April 17, 2016, 11:28:10 PM »
Note that wireless-KERNEL.tcz is written this way and not wireless-4.2.9-tinycore.tcz.

That is correct - try entering the command "echo $KERNEL"

I presume wicd shows you a list of available wifi networks, that you chose one of them, entered the password and it appeared to connect?

Do you see any error messages in dmesg (you can see the last 20 lines, for example, by using "dmesg | tail -20")?

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #66 on: April 17, 2016, 11:51:20 PM »
Note that wireless-KERNEL.tcz is written this way and not wireless-4.2.9-tinycore.tcz.

That is correct - try entering the command "echo $KERNEL"

Where? I tried it to the terminal, but nothing happened.

I presume wicd shows you a list of available wifi networks, that you chose one of them, entered the password and it appeared to connect?

Exactly. But it doesn't load pages, although it appears to be connected. On the other hand, wired network appears disconnected, but it loads pages.

Do you see any error messages in dmesg (you can see the last 20 lines, for example, by using "dmesg | tail -20")?

Code: [Select]
tc@box:~$ dmesg | tail -20
input: phy0 WPS Button as /devices/pci0000:00/0000:00:02.0/usb1/1-2/1-2:1.0/ieee80211/phy0/input9
usb 1-2: Atheros AR9170 is registered as 'phy0'
eth0: DSPCFG accepted after 0 usec.
eth0: link up.
eth0: Setting full-duplex based on negotiated link capability.
mtrr: no MTRR for d8000000,3ff0000 found
wlan0: authenticate with dc:02:8e:7f:4e:df
wlan0: send auth to dc:02:8e:7f:4e:df (try 1/3)
wlan0: authenticated
wlan0: associate with dc:02:8e:7f:4e:df (try 1/3)
wlan0: RX AssocResp from dc:02:8e:7f:4e:df (capab=0x431 status=0 aid=1)
wlan0: associated
eth0: Autonegotiation advertising 0x5e1  partner 0x00.
eth0: link down.
eth0: Autonegotiation advertising 0x5e1  partner 0x45e1.
eth0: link up.
eth0: Autonegotiation advertising 0x5e1  partner 0x00.
eth0: link down.
eth0: Autonegotiation advertising 0x5e1  partner 0x45e1.
eth0: link up.
tc@box:~$

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: wicd daemon doesn't start
« Reply #67 on: April 18, 2016, 12:04:06 AM »
dmesg looks OK in terms of your wifi connection - it might be better to test your wifi connection without the wired cable connection plugged in just to sure it is working.

You could also try:
Code: [Select]
$ sudo ifconfig eth0 down
$ sudo ifconfig wlan0 up
..just to be sure you have only the wifi connection.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #68 on: April 18, 2016, 12:10:49 AM »
I plugged out ethernet cable every time I tested wifi connection, but these commands got the job done:

Code: [Select]
$ sudo ifconfig eth0 down
$ sudo ifconfig wlan0 up

This is my first post with wifi connection. Thanks a lot.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: wicd daemon doesn't start
« Reply #69 on: April 18, 2016, 12:18:17 AM »
Great  :)

BTW, I mislead you with "echo $KERNEL" - this will not work from a terminal window/console, but wireless-KERNEL.tcz is correct in the dep file.

You might want to check out the home grown wifi extension - it has a lot less deps than wicd.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #70 on: April 18, 2016, 12:53:02 AM »
You might want to check out the home grown wifi extension - it has a lot less deps than wicd.

This also works, although the first time I lost connection suddenly. After rebooting seems to work fine. Thanks again.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12071
Re: wicd daemon doesn't start
« Reply #71 on: April 18, 2016, 01:02:12 AM »
Take care not to load both the wifi and wicd extensions - wifi uses wpa_supplicant and wicd uses wpa_supplicant-dbus, which cannot both be loaded at the same time.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #72 on: April 18, 2016, 04:18:54 AM »
It seems that this was the problem.

I deleted from /opt/bootlocal.sh these lines:
Code: [Select]
/usr/local/etc/init.d/dbus restart
/usr/local/etc/init.d/wicd start

I deleted from /opt/.filetool.lst these lines:
Code: [Select]
usr/local/etc/wicd
var/lib/wicd/configurations

I deleted wicd extension from onboot list.

I rebooted.

Wifi extension seems to work without problem now.