WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: wicd daemon doesn't start  (Read 9451 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12094
Re: wicd daemon doesn't start
« Reply #45 on: April 17, 2016, 04:56:57 AM »
Were you at the console prompt or in a terminal window in a gui?

Usually you need to enter "xsetup.sh" to get that message.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #46 on: April 17, 2016, 05:26:36 AM »
At the console prompt. I can't get in a gui.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12094
Re: wicd daemon doesn't start
« Reply #47 on: April 17, 2016, 05:35:57 AM »
You can choose your displays native resolution and your mouse type and then see if the gui starts.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #48 on: April 17, 2016, 06:00:18 AM »
I didn't know my displays native resolution and thought to try them one by one. I chose the first one, and now the gui is a small rectangular at the center of the screen (all the other is black). I tried to reboot, but after "startx" I got to the same gui, without being asked again about resolution. Then I opened a terminal and tried "xsetup.sh", but there is not much space for the display and I can't see the cursor. I typed in blind "15" and pressed enter and it went to the next question (about mouse setup). But this time I try to type "1" (for usb mouse) and press enter, but nothing happens. In conclusion, I don't know how to correct the resolution setup.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12094
Re: wicd daemon doesn't start
« Reply #49 on: April 17, 2016, 06:15:07 AM »
Maybe the best would be to reboot, load Xorg-7.7 flwm aterm and wbar and then startx.

Otherwise, you could google for your display native resolution and use Xvesa.

BTW, if you change xsetup.sh from inside a gui, you need to exit to the console and startx again for the changes to take effect.
« Last Edit: April 17, 2016, 06:16:50 AM by Juanito »

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #50 on: April 17, 2016, 07:32:23 AM »
Maybe the best would be to reboot, load Xorg-7.7 flwm aterm and wbar and then startx.

It worked. Thanks.

Quote
It looks like you need to download the firmware extension with "tce-load -w firmware" and then try to load the carl9170-modules-4.2.9-tinycore extension again.
Code: [Select]
$ tce-load -w firmware
   firmware is already downloaded.

Then, "Download + Load" carl9170-modules-4.2.9-tinycore.tcz and wicd.tcz from Apps -> Cloud -> Browse.

After all:

Code: [Select]
$ sudo wicd
sudo: wicd: command not found

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12094
Re: wicd daemon doesn't start
« Reply #51 on: April 17, 2016, 09:18:23 AM »
OK, but did you check dmesg to see if the carl9170 driver loaded and that it loaded the carl9170-1.fw firmware?

Take a look at the wicd info file, you need:
Code: [Select]
$ sudo /usr/local/etc/init.d/dbus start
$ sudo /usr/local/etc/init.d/wicd start
$ wicd-gtk --no-tray

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #52 on: April 17, 2016, 09:36:50 AM »
OK, but did you check dmesg to see if the carl9170 driver loaded and that it loaded the carl9170-1.fw firmware?

I see none of them at dmesg.

Code: [Select]
$ sudo /usr/local/etc/init.d/dbus start
sudo: /usr/local/etc/init.d/dbus: command not found
$ sudo /usr/local/etc/init.d/wicd start
sudo: /usr/local/etc/init.d/wicd: command not found
$ wicd-gtk --no-tray
sh: wicd-gtk: not found

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12094
Re: wicd daemon doesn't start
« Reply #53 on: April 17, 2016, 12:35:43 PM »
Did you load the wicd extension?

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #54 on: April 17, 2016, 01:07:04 PM »
Code: [Select]
$ tce-load -w wicd.tcz
   wicd is already downloaded.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: wicd daemon doesn't start
« Reply #55 on: April 17, 2016, 02:06:56 PM »
Code: [Select]
tce-load -w ...
Downloads extensions
Code: [Select]
tce-load -i ...
Installs already downloaded extensons
Code: [Select]
tce-load -wi ...
Downloads and installs extensions; Only works if not already downloaded.
Download a copy and keep it handy: Core book ;)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #56 on: April 17, 2016, 02:23:15 PM »
Code: [Select]
tce-load -w ...
Downloads extensions
Code: [Select]
tce-load -i ...
Installs already downloaded extensons
Code: [Select]
tce-load -wi ...
Downloads and installs extensions; Only works if not already downloaded.

Thanks a lot.

Code: [Select]
tc@box:~$ tce-load -i firmware
firmware.tcz: OK
tc@box:~$ tce-load -i carl9170-modules-4.2.9-tinycore.tcz
wireless-4.2.9-tinycore.tcz not found!
tc@box:~$ tce-load -wi carl9170-modules-4.2.9-tinycore.tcz
carl9170-modules-4.2.9-tinycore is already downloaded.
tc@box:~$ tce-load -i carl9170-modules-4.2.9-tinycore.tcz
wireless-4.2.9-tinycore.tcz not found!

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: wicd daemon doesn't start
« Reply #57 on: April 17, 2016, 02:33:16 PM »
carl9170-modules-4.2.9-tinycore.tcz  depends on  wireless-4.2.9-tinycore.tcz  which you don't have because you downloaded  carl9170...tcz  manually, thus dependencies didn't get resolved.

If you see mesages like "wireless-4.2.9-tinycore.tcz not found!", just download it via
Code: [Select]
tce-load -w wireless-4.2.9-tinycore
and then try your previous command again.
Code: [Select]
tce-load -i carl9170-modules-4.2.9-tinycore
Download a copy and keep it handy: Core book ;)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #58 on: April 17, 2016, 02:39:40 PM »
Thanks again.

Code: [Select]
tc@box:~$ tce-load -w wireless-4.2.9-tinycore
wireless-4.2.9-tinycore is already downloaded.
tc@box:~$ tce-load -i wireless-4.2.9-tinycore
wireless-4.2.9-tinycore.tcz: OK
tc@box:~$ tce-load -i carl9170-modules-4.2.9-tinycore
carl9170-modules-4.2.9-tinycore.tcz: OK
tc@box:~$ tce-load -i wicd
libffi5.tcz: OK
ncurses.tcz: OK
ncurses-utils.tcz: OK
net-tools.tcz: OK
dhcpcd.tcz: OK
libiw.tcz: OK
wireless_tools.tcz: OK
readline.tcz: OK
libnl.tcz: OK
wpa_supplicant-dbus.tcz: OK
gdbm.tcz: OK
bzip2-lib.tcz: OK
sqlite3.tcz: OK
python.tcz: OK
urwid.tcz: OK
dbus-python.tcz: OK
pycairo.tcz: OK
gobject-introspection.tcz: OK
pygobject.tcz: OK
pygtk.tcz: OK
wicd.tcz: OK
tc@box:~$ sudo wicd
tc@box:~$

Nothing again.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: wicd daemon doesn't start
« Reply #59 on: April 17, 2016, 02:48:41 PM »
Code: [Select]
sudo wicd
just starts the daemon.

See extension info in Apps GUI or
http://tinycorelinux.net/7.x/x86/tcz/wicd.tcz.info
on how to use wicd properly on Core.
Download a copy and keep it handy: Core book ;)