WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: wicd daemon doesn't start  (Read 9301 times)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #30 on: April 16, 2016, 08:27:45 AM »
Code: [Select]
tc@box:~$ wget -c http://repo.tinycorelinux.net/7.x/x86/tcz/carl9170-modules-4.2
.9-tinycore.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
carl9170-modules-4.2 100% |*******************************| 36864   0:00:00 ETA
tc@box:~$ wget -c http://repo.tinycorelinux.net/7.x/x86/tcz/carl9170-modules-4.2
.9-tinycore.tcz.dep
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
carl9170-modules-4.2 100% |*******************************|    33   0:00:00 ETA
tc@box:~$ wget -c http://repo.tinycorelinux.net/7.x/x86/tcz/carl9170-modules-4.2
.9-tinycore.tcz.md5.txt
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
carl9170-modules-4.2 100% |*******************************|    70   0:00:00 ETA
tc@box:~$


Does this mean it has been installed? But:

Code: [Select]
tc@box:~$ carl9170-modules-4.2
/bin/sh: carl9170-modules-4.2: not found
tc@box:~$


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11879
Re: wicd daemon doesn't start
« Reply #31 on: April 16, 2016, 08:30:46 AM »
No, it means it has been downloaded - now you need to copy the three files to your tce/optional folder and then load the extension with "tce-load -i carl9170-modules-KERNEL"

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: wicd daemon doesn't start
« Reply #32 on: April 16, 2016, 08:59:22 AM »
TL-WN821N_V4_150909.zip  indeed fails to extract using  unzip .
This works:
Code: [Select]
7z x TL-WN821N_V4_150909.zip
requires  p7zip.tcz .
Download a copy and keep it handy: Core book ;)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #33 on: April 16, 2016, 09:02:16 AM »
Code: [Select]
tc@box:~$ tce-load -i carl9170-modules-KERNEL
carl9170-modules-4.2.9-tinycore.tcz: OK
tc@box:~$

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #34 on: April 16, 2016, 09:13:09 AM »
TL-WN821N_V4_150909.zip  indeed fails to extract using  unzip .
This works:
Code: [Select]
7z x TL-WN821N_V4_150909.zip
requires  p7zip.tcz .

Indeed. Thanks.

I read at PDF:

Quote
System version: Ubuntu 14.04.1
Kernel version: 3.16.0-30-generic
Gcc version:4.8.2

This is not a problem?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11879
Re: wicd daemon doesn't start
« Reply #35 on: April 16, 2016, 11:22:39 AM »
Good - the extension is loaded.

You can check with "lsmod" if the carl9170 module loaded and, if not, load it with "sudo modprobe carl9170".

Once you've verified that the module is loaded, it would also be good to check with something like "dmesg | tail -20" that the carl9170 firmware also loaded.

Then you should be ready to try wicd again...

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #36 on: April 16, 2016, 11:47:50 AM »
Code: [Select]
c@box:~$ lsmod
Module                  Size  Used by    Not tainted
speedstep_lib          12288  0
cpufreq_conservative    12288  0
cpufreq_stats          12288  0
cpufreq_powersave      12288  0
cpufreq_userspace      12288  0
ppdev                  12288  0
squashfs               24576 149
lz4_decompress         12288  1 squashfs
parport_pc             24576  0
floppy                 45056  0
pcspkr                 12288  0
8250_fintek            12288  0
parport                28672  2 ppdev,parport_pc
video                  20480  0
backlight              12288  1 video
natsemi                20480  0
loop                   16384 298
battery                16384  0
ac                     12288  0
acpi_cpufreq           12288  0
tc@box:~$ tce-load -i carl9170-modules-KERNEL
carl9170-modules-4.2.9-tinycore.tcz: OK
tc@box:~$ lsmod
Module                  Size  Used by    Not tainted
carl9170               57344  0
mac80211              221184  1 carl9170
ath                    16384  1 carl9170
cfg80211              135168  3 carl9170,mac80211,ath
speedstep_lib          12288  0
cpufreq_conservative    12288  0
cpufreq_stats          12288  0
cpufreq_powersave      12288  0
cpufreq_userspace      12288  0
ppdev                  12288  0
squashfs               24576 150
lz4_decompress         12288  1 squashfs
parport_pc             24576  0
floppy                 45056  0
pcspkr                 12288  0
8250_fintek            12288  0
parport                28672  2 ppdev,parport_pc
video                  20480  0
backlight              12288  1 video
natsemi                20480  0
loop                   16384 300
battery                16384  0
ac                     12288  0
acpi_cpufreq           12288  0
tc@box:~$ dmesg | tail -20
random: nonblocking pool is initialized
eth0: DSPCFG accepted after 0 usec.
eth0: link up.
eth0: Setting full-duplex based on negotiated link capability.
mtrr: no MTRR for d8000000,3ff0000 found
usb 1-2: reset full-speed USB device number 3 using ohci-pci
usb 1-2: Direct firmware load for carl9170-1.fw failed with error -2
usb 1-2: Falling back to user helper
usbcore: registered new interface driver carl9170
usb 1-2: driver   API: 1.9.7 2012-12-15 [1-1]
usb 1-2: firmware API: 1.9.6 2012-07-07
ath: EEPROM regdomain: 0x809c
ath: EEPROM indicates we should expect a country code
ath: doing EEPROM country->regdmn map search
ath: country maps to regdmn code: 0x52
ath: Country alpha2 being used: CN
ath: Regpair used: 0x52
ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
input: phy0 WPS Button as /devices/pci0000:00/0000:00:02.0/usb1/1-2/1-2:1.0/ieee80211/phy0/input9
usb 1-2: Atheros AR9170 is registered as 'phy0'
tc@box:~$

wicd still doesn't work. This line is the cause?

Code: [Select]
usb 1-2: Direct firmware load for carl9170-1.fw failed with error -2

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11879
Re: wicd daemon doesn't start
« Reply #37 on: April 16, 2016, 10:16:30 PM »
Did you copy the dep file, carl9170-modules-4.2.9-tinycore.tcz.dep, to your tce/optional folder?

This should have loaded the firmware extension that contains carl9170-1.fw.

Also, it's worth checking in dmesg to see if carl9170-1.fw is mentioned twice - the second mention would be to confirm that it has been successfully loaded.

Edit: an example of what I mean, but with intel wifi hardware:
Code: [Select]
$ dmesg
...
iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7260-15.ucode failed with error -2
iwlwifi 0000:02:00.0: Falling back to user helper
iwlwifi 0000:02:00.0: loaded firmware version 15.227938.0 op_mode iwlmvm
iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
« Last Edit: April 16, 2016, 10:52:38 PM by Juanito »

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #38 on: April 17, 2016, 12:47:29 AM »
Did you copy the dep file, carl9170-modules-4.2.9-tinycore.tcz.dep, to your tce/optional folder?

Yes, and it's still there.

Also, it's worth checking in dmesg to see if carl9170-1.fw is mentioned twice - the second mention would be to confirm that it has been successfully loaded.

It's mentioned once and this to say that the load failed:

Code: [Select]
usb 1-2: Direct firmware load for carl9170-1.fw failed with error -2
I see that the carl9170-modules-4.2.9-tinycore extension is now there at "Apps -> Cloud -> Browse" list, but I can't add it to the onboot list.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11879
Re: wicd daemon doesn't start
« Reply #39 on: April 17, 2016, 12:56:59 AM »
Hmm - /usr/local/lib/firmware/carl9170-1.fw is present in the firmware extension - could you double-check that it is loaded using "tce-status -i | grep firmware"?

'Strange that you cannot add carl9170-modules-4.2.9-tinycore onboot using the apps gui - you could always edit tce/onboot.lst manually, but that's not the point.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #40 on: April 17, 2016, 01:04:57 AM »
Code: [Select]
tc@box:~$ tce-status -i | grep firmware
firmware
firmware-iwlwifi
tc@box:~$

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11879
Re: wicd daemon doesn't start
« Reply #41 on: April 17, 2016, 01:13:10 AM »
You don't need firmware-iwlwifi, but I don't think that's the cause of the problem.

Maybe you could reboot with nothing loaded onboot and then try "tce-load -i carl9170-modules-4.2.9-tinycore" and check dmesg to see if the firmware loaded.

If that doesn't work, about the only thing I can think of is to try the firmware from https://github.com/chunkeey/carl9170fw

Apparently, you should see something like this:
Code: [Select]
[14402.310944] usb 1-1.2: new high-speed USB device number 9 using dwc_otg
[14402.459068] usb 1-1.2: New USB device found, idVendor=0cf3, idProduct=1002
[14402.459096] usb 1-1.2: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[14402.459114] usb 1-1.2: Product: USB2.0 WLAN
[14402.459129] usb 1-1.2: Manufacturer: ATHER
[14402.459145] usb 1-1.2: SerialNumber: 12345
[14402.560962] usb 1-1.2: reset high-speed USB device number 9 using dwc_otg
[14402.698503] usb 1-1.2: driver   API: 1.9.7 2012-12-15 [1-1]
[14402.698543] usb 1-1.2: firmware API: 1.9.6 2012-07-07
[14403.050326] ath: EEPROM regdomain: 0x809c
[14403.050351] ath: EEPROM indicates we should expect a country code
[14403.050365] ath: doing EEPROM country->regdmn map search
[14403.050377] ath: country maps to regdmn code: 0x52
[14403.050390] ath: Country alpha2 being used: CN
[14403.050401] ath: Regpair used: 0x52
[14403.080221] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[14403.084478] cfg80211: Calling CRDA to update world regulatory domain
[14403.099237] input: phy1 WPS Button as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0/ieee80211/phy1/input2
[14403.099912] usb 1-1.2: Atheros AR9170 is registered as 'phy1'
[14403.559455] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #42 on: April 17, 2016, 03:46:23 AM »
Maybe you could reboot with nothing loaded onboot and then try "tce-load -i carl9170-modules-4.2.9-tinycore" and check dmesg to see if the firmware loaded.

Code: [Select]
$ tce-load -i carl9170-modules-4.2.9-tinycore
firmware.tcz not found!

The bad news is that I deleted all extensions from onboot list and now I can't run x:

Code: [Select]
$ startx
-sh: startx: not found

I tried:
Code: [Select]
tce-load -iw Xvesa Xprogs flwm aterm wbar
Code: [Select]
tce-load -iw Xorg-7.7
Everything seems to be already downloaded.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11879
Re: wicd daemon doesn't start
« Reply #43 on: April 17, 2016, 04:26:17 AM »
If everything is already downloaded, you just need "tce-load -i Xvesa Xprogs flwm aterm wbar" to get a gui with "startx".

It looks like you need to download the firmware extension with "tce-load -w firmware" and then try to load the carl9170-modules-4.2.9-tinycore extension again.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: wicd daemon doesn't start
« Reply #44 on: April 17, 2016, 04:50:05 AM »
If everything is already downloaded, you just need "tce-load -i Xvesa Xprogs flwm aterm wbar" to get a gui with "startx".

After "startx", I get this in green letters:

Code: [Select]
Tiny Core Linux - Xvesa Resolution Setup
 1. 320x200x15
 2. 320x200x16
 3. 320x200x24
 4. 320x200x24
 5. 320x240x15
 6. 320x240x16
 7. 320x240x24
 8. 320x240x24
 9. 320x240x8
10. 400x300x15
11. 400x300x16
12. 400x300x24
13. 400x300x24
14. 512x384x15
15. 512x384x16

Enter selection ( 1 - 37 ) or (q)uit, (n)ext, (p)revious: :
« Last Edit: April 17, 2016, 04:51:38 AM by andfree »