WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Greek keyboard layout  (Read 11843 times)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #45 on: April 18, 2016, 08:10:01 AM »
I tried to open rox-filer from urxvt (with bash) but:

Code: [Select]
Mounting /mnt/sdb1
mount: can't find /mnt/sdb1 in /etc/fstab
Mount failed

Done
There was one error.

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 329
Re: Greek keyboard layout
« Reply #46 on: April 18, 2016, 08:16:42 AM »
What are you trying to mount ??
If you mount a fat system you may use some parameters to get the chars correct.
I google a little bit and found this:
http://www.nslu2-linux.org/wiki/HowTo/MountFATFileSystems

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #47 on: April 18, 2016, 09:18:23 AM »
Unfortunatelly it's NTFS.

I can mount it with rox-filer, but it sees only directories which names consist of latin characters. So, I had the idea that if I started rox-filer from urxvt, it would have maybe seen and the directories which names consist of greek character. I don't know if it makes any sense.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: Greek keyboard layout
« Reply #48 on: April 18, 2016, 09:26:08 AM »
I'm using
Code: [Select]
sudo mount.ntfs-3g -o iocharset=utf8 /dev/sdb1 /mnt/sdb1
Needs  ntfs-3g.tcz .
Download a copy and keep it handy: Core book ;)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #49 on: April 18, 2016, 09:44:49 AM »
I'm using
Code: [Select]
sudo mount.ntfs-3g -o iocharset=utf8 /dev/sdb1 /mnt/sdb1
Needs  ntfs-3g.tcz .

This got the job done. Thanks one more time.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #50 on: April 20, 2016, 01:30:24 PM »
I installed the latest version of firefox and the menus are in greek. Why does this happen and what to do to change it in english?

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 329
Re: Greek keyboard layout
« Reply #51 on: April 20, 2016, 01:37:33 PM »
It's the locale that sets the language of program.
You can try to start firefox with another lang settings from command line.
Code: (bash) [Select]
(export LANG=C;firefox)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #52 on: April 20, 2016, 02:06:38 PM »
If you mean to add this code at the APPEND line of extlinux.conf, it didn't work.

I have already removed mylocale extension from the onboot list and I have also removed at all the "lang=" option from extlinux.conf, but still firefox is in greek.

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 329
Re: Greek keyboard layout
« Reply #53 on: April 20, 2016, 02:10:05 PM »
I don't mean you should change the command line args to kernel.
Just try to start firefox from the terminal command line.
With my suggested command.

Sorry this forum is for core linux questions, you should better find your answers to this type of questions on some regular linux forums and http://lmgtfy.com/?q=change+language+in+firefox+linux and like stackoverflow.

« Last Edit: April 20, 2016, 02:23:45 PM by patrikg »

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: Greek keyboard layout
« Reply #54 on: April 20, 2016, 02:23:23 PM »
When your Firefox extension was created by firefox_getLatest.sh, the script downloaded the Firefox package based on your locale settings at that time.
For whatever reason you want to get back to English, you would need to re-run firefox_getLatest.sh with the locale not set to anything else than the default, to get an English version of Firefox.

I don't mean to e rude, but you seem to run into every possible obstacle new Core Linux users may encounter, if they do not read the f manual.
« Last Edit: April 20, 2016, 02:27:18 PM by Misalf »
Download a copy and keep it handy: Core book ;)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #55 on: April 20, 2016, 11:12:43 PM »
Thank you, it worked.
In fact, I want all menus in english, so I don't think there's a reason to reset the locale to greek again.
You are right. Unfortunatelly, the obstacles were too many for me to face them with only the help of the book, but I'll try to do it better.

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 329
Re: Greek keyboard layout
« Reply #56 on: April 21, 2016, 04:03:18 AM »
Great that your problem get solved.
superuser.com is also a good site to get answers from.
« Last Edit: April 21, 2016, 04:18:27 AM by patrikg »

Offline chattrhand

  • Full Member
  • ***
  • Posts: 100
Re: Greek keyboard layout
« Reply #57 on: May 04, 2016, 04:02:37 AM »
Hi, I'm using German keymap, not Greek, I'm going a different way to set up my keyboard, it may look a bit suboptimal.

But it works reliably and sometimes I explain it successfully to newbies via chat.

It needs a Frugal Installation (on USB-Stick or HDD) and can be done after Restart of a fresh installed Frugal Installation. (but could also be done later)

- If kmaps.tcz isn't just installed, do it now. (using the tc Apps browser)
- open a Terminal and type in the following very long line (extend the terminal to fit into), and press Enter

tc@box:~$ echo 'loadkmap < /usr/share/kmap/qwertz/de-latin1-nodeadkeys.kmap' >> /opt/bootlocal.sh

Check whether it is ok using the following command:

tc@box:~$ cat /opt/bootlocal.sh
#!/bin/sh
# put other system startup commands here
loadkmap < /usr/share/kmap/qwertz/de-latin1-nodeadkeys.kmap
tc@box:~$

The /opt/bootlocal.sh should look like this.
Now open the /home/tc/.xsession file using the editor:

tc@box:~$ editor .xsession

In the editor move to the 3rd line and press enter to insert an empty line
Insert the following content to this line:

sleep 3 && xmodmap -e "clear Mod4" -e "add Mod5 = Mode_switch" &

Save this file and close it, close the terminal and reboot. Up from now this installation uses German keys.


This could easily adapted for a Greek (and other languages) keyboard:
Open a terminal and type in:

tc@box:~$ echo 'loadkmap < /usr/share/kmap/qwerty/gr-pc.kmap' >> /opt/bootlocal.sh

and, within .xsession  insert a new 3rd line containing:

sleep 3 && xmodmap -e "clear Mod4" -e "add Mod5 = Mode_switch" &

Save it and reboot. Now the keyboard should write Greek characters.
TinyCore, SliTaz, LinuxMint, Tails, Mac ...