WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Greek keyboard layout  (Read 11832 times)

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 329
Re: Greek keyboard layout
« Reply #15 on: April 07, 2016, 07:01:10 AM »
Sorry for asking...but do you start bash ??
Or do you change the default shell to bash ??

And do you install kmaps and what commandline args do you use to enable it.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #16 on: April 07, 2016, 11:14:51 AM »
I changed the default shell to bash, but still greek characters displayed as "?":

Code: [Select]
tc@box:~$ echo $SHELL
/bin/sh
tc@box:~$ bash
tc@box:~$ echo $SHELL
/bin/bash
tc@box:~$ ????????

As regards kmaps, I have installed it:

Code: [Select]
tc@box:~$ tce-load -i kmaps
kmaps is already installed!

But I have no idea what commandline args I should use to enable it.

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 329
Re: Greek keyboard layout
« Reply #17 on: April 07, 2016, 11:37:29 AM »
Try to add

kmap=qwerty/gr
or
kmap=qwerty/gr-pc

to your commandline

And how to modify your commandline, you may read the core book.
http://tinycorelinux.net/corebook.pdf


« Last Edit: April 07, 2016, 11:39:24 AM by patrikg »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10069
Re: Greek keyboard layout
« Reply #18 on: April 07, 2016, 11:45:53 AM »
Did you set up a locale? The default, C, supports just ascii. You need either a Greek locale, or an utf8 locale. See the getlocale.tcz extension.
The only barriers that can stop you are the ones you create yourself.

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #19 on: April 07, 2016, 12:46:50 PM »
Code: [Select]
tc@box:~$ sudo getlocale.sh
I choose el_GR.UTF-8/UTF-8:

Code: [Select]
Now processing... /
Locales installed. Creating extension... cp: cannot stat '/usr/lib/locale/locale-archive': No such file or directory
\

Done. The extension is at /mnt/sda1/tce/optional/mylocale.tcz and in onboot.lst
Reboot with lang=xyz (for example lang=) to start using this.


Press enter to quit.

tc@box:~$ ????????

Or I choose el_GR/ISO-8859-7:

Code: [Select]
Now processing... cannot open locale archive "/usr/lib/locale/locale-archive": Read-only file system

Locales installed. Creating extension... /

Done. The extension is at /mnt/sda1/tce/optional/mylocale.tcz and in onboot.lst
Reboot with lang=xyz (for example lang=an_ES) to start using this.


Press enter to quit.

tc@box:~$ ????????


And how to modify your commandline, you may read the core book.
http://tinycorelinux.net/corebook.pdf

Sorry, I can't find where it says about it. Any help to find it?

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 329
Re: Greek keyboard layout
« Reply #20 on: April 07, 2016, 01:39:44 PM »
What platform do you use??
PC
Raspberry PI

If picore edit your config file like this.
I use nano as editor for easiness.
And all text should be at one line...i start nano with -w to disable linewrap.

Code: (bash) [Select]
tce-load -wi nano.tcz
mount /mnt/mmcblk0p1
sudo nano -w /mnt/mmcblk0p1/cmdline.txt

If PC read "Chapter 10. Bootcodes explained" in book.
« Last Edit: April 07, 2016, 01:42:16 PM by patrikg »

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: Greek keyboard layout
« Reply #21 on: April 07, 2016, 02:08:02 PM »
Apart from using bash, an appropriate locale and a capable terminal emulator, it may also be necessary to configure the terminal emulator to use a font which provides requested characters.
--
Note,  tce-load -wi ...  doesn't load the extension if it's already present locally.
So  tce-load -w ... ; tce-load -i ...  is more reliable in such cases.
Download a copy and keep it handy: Core book ;)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #22 on: April 07, 2016, 10:33:56 PM »
The book says:

Quote
If using extlinux, the file is called extlinux.cfg, and the codes are stored in the APPEND line:
Code: [Select]
APPEND initrd=/boot/core.gz quiet showapps

I don't find an extlinux.cfg, but a /mnt/sda1/tce/boot/extlinux/extlinux.conf file.

Code: [Select]
sudo editor /mnt/sda1/tce/boot/extlinux/extlinux.conf
Code: [Select]
DEFAULT core
LABEL core
KERNEL /tce/boot/vmlinuz
APPEND initrd=/tce/boot/core.gz quiet  waitusb=5:UUID="b7c9ae56-0223-4d78-9cfb-9ece1ebe91e2" tce=UUID="b7c9ae56-0223-4d78-9cfb-9ece1ebe91e2"

I change it like this:
 
Code: [Select]
DEFAULT core
LABEL core
KERNEL /tce/boot/vmlinuz
APPEND initrd=/tce/boot/core.gz quiet  waitusb=5:UUID="b7c9ae56-0223-4d78-9cfb-9ece1ebe91e2" tce=UUID="b7c9ae56-0223-4d78-9cfb-9ece1ebe91e2" kmap=qwerty/gr lang=el.GR

I reboot, but greek characters are still displayed as "?" in lxterminal.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: Greek keyboard layout
« Reply #23 on: April 07, 2016, 11:33:42 PM »
I can't get lxterminal to display Greek characters either. Not even German umlauts.
URxvt using Bash works.
Download a copy and keep it handy: Core book ;)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #24 on: April 08, 2016, 12:16:09 AM »
I installed urxvt. But greeks aren't displayed there at all and the cursor doesn't move at all when I type greeks.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: Greek keyboard layout
« Reply #25 on: April 08, 2016, 12:37:38 AM »
You may need to set a different font (f.e. Monospace).
To test, run
Code: [Select]
urxvt -fn xft:Monospace:pixelsize=11
Then run
Code: [Select]
bash
and switch to your keyboard layout.

You can make font settings for urxvt permanent by adding the following to  ~/.Xdefaults .
Code: [Select]
URxvt*font: xft:Monospace:pixelsize=11
Download a copy and keep it handy: Core book ;)

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #26 on: April 08, 2016, 12:50:46 AM »
Code: [Select]
tc@box:~$ urxvt -fn xft:Monospace:pixelsize=11
urxvt: default locale unavailable, check LC_* and LANG variables. Continuing.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: Greek keyboard layout
« Reply #27 on: April 08, 2016, 12:56:47 AM »
Do you get something like this with the "locale" command:
Code: [Select]
$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Offline andfree

  • Full Member
  • ***
  • Posts: 127
Re: Greek keyboard layout
« Reply #28 on: April 08, 2016, 01:07:22 AM »
Code: [Select]
tc@box:~$ bash
tc@box:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=el.GR
LC_CTYPE="el.GR"
LC_NUMERIC="el.GR"
LC_TIME="el.GR"
LC_COLLATE="el.GR"
LC_MONETARY="el.GR"
LC_MESSAGES="el.GR"
LC_PAPER="el.GR"
LC_NAME="el.GR"
LC_ADDRESS="el.GR"
LC_TELEPHONE="el.GR"
LC_MEASUREMENT="el.GR"
LC_IDENTIFICATION="el.GR"
LC_ALL=
tc@box:~$

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11109
Re: Greek keyboard layout
« Reply #29 on: April 08, 2016, 01:12:36 AM »
When you made mylocale.tcz locally, did you set your "lang=" bootcode to "el.GR" or "el_GR.UTF-8"?