WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: QEMU for 64bit?  (Read 12047 times)

Offline flyingfishfinger

  • Jr. Member
  • **
  • Posts: 59
Re: QEMU for 64bit?
« Reply #45 on: February 10, 2016, 01:25:56 AM »
Alright, I think there's one more question. I managed to build the spice-client before, but now it won't work for the life of me. I didn't get this error before and I did the exact same thing. A reboot / norestore doesn't change anything. Here is the issue:

Quote
/usr/local/share/aclocal/glib.m4:8: warning: underquoted definition of AM_PATH_G                                                                                                                                                   LIB
/usr/local/share/aclocal/glib.m4:8:   run info Automake 'Extending aclocal'
/usr/local/share/aclocal/glib.m4:8:   or see http://www.gnu.org/software/automak                                                                                                                                                   e/manual/automake.html#Extending-aclocal
configure.ac:16: warning: AM_NLS is m4_require'd but not m4_defun'd
/usr/local/share/aclocal/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.ac:16: the top level
configure.ac:16: warning: AM_NLS is m4_require'd but not m4_defun'd
/usr/local/share/aclocal/intltool.m4:27: IT_PROG_INTLTOOL is expanded from...
configure.ac:16: the top level
configure.ac:16: warning: AM_NLS is m4_require'd but not m4_defun'd
aclocal.m4:462: IT_PROG_INTLTOOL is expanded from...
configure.ac:16: the top level
configure:12503: error: possibly undefined macro: AM_NLS
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/local/bin/autoconf failed with exit status: 1
Running configure with --enable-maintainer-mode --enable-gtk-doc --with-gtk=3.0                                                                                                                                                    --enable-vala --prefix:/home/tc/spice

This is a slightly different error I got for a long while beforehand, which was the "./configure.lineno: syntax error "unexpected word"  one.
It's really annoying because I had built this before but not made an extension from it... :(

R

    [EDIT]: Fixed quote tag.  Rich
« Last Edit: February 10, 2016, 07:23:32 AM by Rich »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: QEMU for 64bit?
« Reply #46 on: February 10, 2016, 02:25:10 AM »
This looks like you took spice-client from git  - why not use a stable version?

If you have to use git, check that automake, intltool, libtool-dev and gettext-dev are all loaded before running ./autogen.sh - you might also need glib2-dev and/or gtk3-dev.

Offline flyingfishfinger

  • Jr. Member
  • **
  • Posts: 59
Re: QEMU for 64bit?
« Reply #47 on: February 10, 2016, 03:02:15 PM »
Built a stable version. I can connect to a running VM with spicy (included in GTK)!
The only problem now is that it only ever seems to draw one frame, the one it received when I started up the client. I know the VM is working fine because I can click something, kill the client, open it back up and the new (first) frame will be rendered with the action I took.
It seems to be making a great picture viewer, but not so much a functional desktop. Any clues? This might be more of a spice question now though.
Thanks for all the continued help so far! Progress is slow, but steady.

R

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: QEMU for 64bit?
« Reply #48 on: April 09, 2016, 12:24:06 AM »
qemu extension posted

To use with spice-gtk and pulseaudio

In one terminal window:
Code: [Select]
$ QEMU_AUDIO_DRV=pa qemu-system-x86_64 -enable-kvm -cdrom TinyCorePure64-7.0.iso -soundhw hda -m 2G -spice port=5930,disable-ticketing
In another terminal window:
Code: [Select]
$ spicy -h 127.0.0.1 -p 5930
Note: shift f12 to ungrab the mouse

spice-vdagent (to cut & paste host <-> guest) and xf86-video-qxl also posted, but I've not yet figured out how to use them  ::)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11094
Re: QEMU for 64bit?
« Reply #49 on: April 11, 2016, 05:03:08 AM »
..and to enable copy/paste host <-> guest..

Start qemu with:
Code: [Select]
$ QEMU_AUDIO_DRV=pa qemu-system-x86_64 -enable-kvm corepure64.img -soundhw hda -m 2G -spice port=5930,disable-ticketing -device virtio-serial-pci -device virtserialport,chardev=spicechannel0,name=com.redhat.spice.0 -chardev spicevmc,id=spicechannel0,name=vdagent
Connect with gtk-spice:
Code: [Select]
$ spicy -h 127.0.0.1 -p 5930
In the guest vm:
Code: [Select]
$ tce-load -i spice-vdagent
$ sudo modprobe uinput
$ sudo spice-vdagentd
$ spice-vdagent

..and copy/paste is enabled

As an added bonus, once vdagent is up, there's also no need to ungrab the mouse to pass from guest to host  :)