WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: sce-update errors  (Read 8180 times)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: sce-update errors
« Reply #30 on: January 07, 2016, 07:33:14 PM »
I have made what could be a fix, but the main server is down now and will be Saturday before I can test and prove the changes as I am skipping town.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10739
Re: sce-update errors
« Reply #31 on: January 08, 2016, 01:47:14 AM »
?

There's been no break as far as I know. Uptime high, ssh and web all up.
The only barriers that can stop you are the ones you create yourself.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: sce-update errors
« Reply #32 on: January 08, 2016, 03:39:33 AM »
I can't ssh, reach the Downloads page, or import/update anything, but could be something in between in my direction.  Can't try again until tomorrow.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10739
Re: sce-update errors
« Reply #33 on: January 08, 2016, 09:50:21 AM »
http://isup.me/repo.tinycorelinux.net/

isup.me is useful in these situations.
The only barriers that can stop you are the ones you create yourself.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: sce-update errors
« Reply #34 on: January 08, 2016, 04:31:27 PM »
Thanks.  It's all good now, "I can't access the server" would more accurately be what I was meaning to say.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: sce-update errors
« Reply #35 on: January 09, 2016, 09:36:38 AM »
New RC, please test.

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
Re: sce-update errors
« Reply #36 on: January 10, 2016, 12:43:11 PM »
I've chosen to look for updates for the following sces as you can read in the code,
the system updated python-efl and then started checking for the rest of the chosen sces .
Then it asked if I want to see the updateavailable, I typed Y and the script exited.
Unfortunately from the below paste something on the screen has been overwritten by the updateavailable list
Code: [Select]
epymc
express
exterminator
epour
ephoto
epack
epad
lekha

You are about to check for updates to the above SCEs. y to continue, n to exit.
(y/N): y
ubuntu
#################### 100.0% 0.0 kBps DONE

verifying download...checksum matches OK
used 11880448 local, fetched 0
#################### 100.0% 0.0 kBps DONE

verifying download...checksum matches OK
used 1009664 local, fetched 0
Using the repo http://ppa.launchpad.net/enlightenment-git/ppa/ubuntu trusty main
Using the repo http://ppa.launchpad.net/niko2040/e19/ubuntu trusty main
Using the repo http://dl.google.com/linux/talkplugin/deb/ stable main
Using the repo http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu trusty main
Using the repo http://ftp5.gwdg.de/pub/opensuse/repositories/home:/jgeboski/xUbu
ntu_14.04 trusty ./
Using the repo http://sourceforge.net/projects/ubuntuzilla/files/mozilla/apt all
 main
Using the repo http://ppa.launchpad.net/whatsapp-purple/ppa/ubuntu trusty main
Using the repo http://archive.canonical.com/ubuntu/ trusty partner
Using the repo http://packages.bodhilinux.com/bodhi trusty main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updat
es main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updat
es multiverse
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updat
es restricted
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updat
es universe
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backp
orts main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backp
orts multiverse
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backp
orts restricted
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backp
orts universe
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty main

Checking for updates for epymc.sce..
base: Checkup for updates..
xorg-all: Checkup for updates..
gstreamer1: Checkup for updates..
e20-terminology: Checkup for updates..
seamonkey-mozilla-build: Checkup for updates..
python-efl: Checkup for updates..
epymc: Checkup for updates..
Using the -u option.
Using the -n option.
Using the -r option.
Existing dep file found.


Importing python-efl.


Using Package Index: /etc/sysconfig/tcedir/import/debinx/ubuntu_trusty_main_i386
_Packages

Using Package Index: /etc/sysconfig/tcedir/import/debinx/ubuntu_trusty_security_
i386_Packages

Using ubuntu Mirror: http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/

Using ubuntu Security Mirror: http://ubuntu.mirror.garr.it/mirrors/ubuntu-archiv
e/

python-efl is a ubuntu trusty main package from http://ppa.launchpad.net/niko204
0/e19/ubuntu.
Gathering dependency info..




The below SCE's in your SCE directory will be used as
to provide dependencies for python-efl.sce.
SCE:  base
  Available package updates:
    None


SCE:  xorg-all
  Available package updates:
    None


SCE:  gstreamer1
  Available package updates:
    None


SCE:  e20-terminology
  Available package updates:
    None


SCE:  seamonkey-mozilla-build
  Available package updates:
    None


SCE:  python-efl
  Available package updates:
    python-efl        http://ppa.launchpad.net/niko2040/e19/ubuntu trusty main


SCE:  epymc
  Available package updates:
    None


SCE:  express
  Available package updates:
    None


SCE:  exterminator
  Available package updates:
    None


SCE:  epour
  Available package updates:
    None


SCE:  ephoto
  Available package updates:
    None


SCE:  epack
  Available package updates:
    libmagic1   libmagic1.deb2sce startup script has been removed in the repo.
    None


SCE:  epad
  Available package updates:
    None


SCE:  lekha
  Available package updates:
    python-xdg   python-xdg.deb2sce startup script has been removed in the repo
.
    None
jls@box:~$

dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: sce-update errors
« Reply #37 on: January 10, 2016, 01:39:08 PM »
Ok, was the updating succussful for SCEs that needed an update?  Did it check all the SCEs it needed to check?  Was it at the end when asked to press y to see /tmp/updateavailable? 

I am not able to duplicate your repos and SCEs, so I can't test it myself. 

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: sce-update errors
« Reply #38 on: January 10, 2016, 01:55:37 PM »
Ok, I see what is happening, it is leaving out one or more selected entries when checking updates.  Will fix.

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
Re: sce-update errors
« Reply #39 on: January 11, 2016, 11:53:25 PM »
Hi
on a first sce-update it seems that the repos are checked twice, and there also is an error regarding /tmp/PKGEXTRAFILEMD5SUMLIST.

PS the first sce-update paste is cut due, I think, to the "clear" command for showing:
"No updates available for main or dependency SCEs."
maybe that command could be removed, so the user can see all the command output.

Code: [Select]
jls@box:~$ sce-update brasero
ubuntu
#################### 100.0% 0.0 kBps DONE

verifying download...checksum matches OK
used 11880448 local, fetched 0
#################### 100.0% 0.0 kBps DONE

verifying download...checksum matches OK
used 1009664 local, fetched 0
Using the repo http://ppa.launchpad.net/enlightenment-git/ppa/ubuntu trusty main
Using the repo http://ppa.launchpad.net/niko2040/e19/ubuntu trusty main
Using the repo http://dl.google.com/linux/talkplugin/deb/ stable main
Using the repo http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu trusty main
Using the repo http://ftp5.gwdg.de/pub/opensuse/repositories/home:/jgeboski/xUbuntu_14.04 trusty ./
Using the repo http://sourceforge.net/projects/ubuntuzilla/files/mozilla/apt all main
Using the repo http://ppa.launchpad.net/whatsapp-purple/ppa/ubuntu trusty main
Using the repo http://archive.canonical.com/ubuntu/ trusty partner
Using the repo http://packages.bodhilinux.com/bodhi trusty main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates multiverse
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates restricted
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates universe
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backports main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backports multiverse
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backports restricted
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backports universe
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty main
ubuntu
#################### 100.0% 0.0 kBps DONE

verifying download...checksum matches OK
used 11880448 local, fetched 0
#################### 100.0% 0.0 kBps DONE

verifying download...checksum matches OK
used 1009664 local, fetched 0
Using the repo http://ppa.launchpad.net/enlightenment-git/ppa/ubuntu trusty main
Using the repo http://ppa.launchpad.net/niko2040/e19/ubuntu trusty main
Using the repo http://dl.google.com/linux/talkplugin/deb/ stable main
Using the repo http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu trusty main
Using the repo http://ftp5.gwdg.de/pub/opensuse/repositories/home:/jgeboski/xUbuntu_14.04 trusty ./
Using the repo http://sourceforge.net/projects/ubuntuzilla/files/mozilla/apt all main
Using the repo http://ppa.launchpad.net/whatsapp-purple/ppa/ubuntu trusty main
Using the repo http://archive.canonical.com/ubuntu/ trusty partner
Using the repo http://packages.bodhilinux.com/bodhi trusty main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates multiverse
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates restricted
No updates available for main or dependency SCEs.
jls@box:~$ sce-update brasero
ubuntu
#################### 100.0% 0.0 kBps DONE

verifying download...checksum matches OK
used 11880448 local, fetched 0
#################### 100.0% 0.0 kBps DONE

verifying download...checksum matches OK
used 1009664 local, fetched 0
Using the repo http://ppa.launchpad.net/enlightenment-git/ppa/ubuntu trusty main
Using the repo http://ppa.launchpad.net/niko2040/e19/ubuntu trusty main
Using the repo http://dl.google.com/linux/talkplugin/deb/ stable main
Using the repo http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu trusty main
Using the repo http://ftp5.gwdg.de/pub/opensuse/repositories/home:/jgeboski/xUbuntu_14.04 trusty ./
Using the repo http://sourceforge.net/projects/ubuntuzilla/files/mozilla/apt all main
Using the repo http://ppa.launchpad.net/whatsapp-purple/ppa/ubuntu trusty main
Using the repo http://archive.canonical.com/ubuntu/ trusty partner
Using the repo http://packages.bodhilinux.com/bodhi trusty main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates multiverse
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates restricted
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-updates universe
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backports main
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backports multiverse
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backports restricted
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty-backports universe
Using the repo http://ubuntu.mirror.garr.it/mirrors/ubuntu-archive/ trusty main
cat: /tmp/PKGEXTRAFILEMD5SUMLIST: File o directory non esistente
Your SCEs are up to date.
jls@box:~$

dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: sce-update errors
« Reply #40 on: January 12, 2016, 03:12:44 AM »
Ok, I see the extra debGetEnv.  Will fix.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9730
Re: sce-update errors
« Reply #41 on: January 12, 2016, 06:10:07 PM »
The double debinx fetching should be fixed now, thanks for testing and reporting.

EDIT"  Re: the clear command - yeah, I can remove it as it does make bug reporting more difficult.  I will visit it once we see this latest set of changes are stablized. 
« Last Edit: January 12, 2016, 06:26:35 PM by Jason W »