WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: problem with Xorg  (Read 1323 times)

Offline kevinfish

  • Jr. Member
  • **
  • Posts: 72
problem with Xorg
« on: January 09, 2016, 09:27:54 PM »
here's my sceboot.lst

----------------
graphics-3.16.6-tinycore
xorg-all
wbar
Xprogs
flwm_topside

-------------------

And my Xorg log is attached.

I'm not really seeing an error in there.

It clears the screen, resets the video mode, then just returns to the prompt

Any ideas?

Offline nitram

  • Hero Member
  • *****
  • Posts: 1054
Re: problem with Xorg
« Reply #1 on: January 09, 2016, 10:09:46 PM »
Your boot list looks good. Run to confirm all boot extensions installed:
Code: [Select]
ls /tmp/tcloop


As per: http://tinycorelinux.net/dCore/x86/README/README-X-Desktop.txt, you're using the desktop=flwm_topside boot parameter?

Quote
Now using the simple command line import tool, type:

$ sce-import -b Xprogs
$ sce-import -b flwm_topside
$ sce-import -b wbar
$ sce-import -b xorg-all

The above will download all the packages and create the required sces to get a typical TinyCore (flwm_topside & wbar) desktop environment.

Next you must specify the desktop as a boot parameter.

Then add desktop=flwm_topside to the end of the boot parameter line.

When successfully completed, reboot into an environment ready to "startx":
$ sudo reboot

If this fails, may need to create an /etc/xorg.conf file.