WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Logitech Media Server (LMS) on TC.7  (Read 36789 times)

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Logitech Media Server (LMS) on TC.7
« on: January 08, 2016, 08:04:53 AM »
Hence I have the piCorePlayer running on Raspi well, I'm looking for the way how to run the LMS server on Tinycore too.
Has anybody solved this task already? I'd like to use for example this build:
Code: (bash) [Select]
http://downloads.slimdevices.com/nightly/?ver=7.9

Offline beerstein

  • Hero Member
  • *****
  • Posts: 530
Re: Logitech Media Server (LMS) on TC.7
« Reply #1 on: January 08, 2016, 08:22:29 AM »
Hi: This would be great. I am struggling to get the LMS installed and running on debian8
I have no idea  how to convert the .deb into .tgz and i might need help also to install it.
t(w)o be(ers) or not t(w)o be(ers) that is the question

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: Logitech Media Server (LMS) on TC.7
« Reply #2 on: January 08, 2016, 08:32:14 AM »
I've used this tutorial:
Code: (bash) [Select]
http://www.gerrelt.nl/RaspberryPi/wordpress/tutorial-stand-alone-squeezebox-server-and-player-for-bbq/
because the .deb is Debian related installation package.
I'm not sure if it's possible to convert it into tcz. Guess it need to be rebuild from the source code.

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: Logitech Media Server (LMS) on TC.7
« Reply #3 on: January 16, 2016, 04:30:16 AM »
I'm trying to install the LMS on the piCore and hit the error: lib/lsb/init-functions missing.
I've searched, but seems that lsb-base is not in the repo. Some points how to get it?

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Logitech Media Server (LMS) on TC.7
« Reply #4 on: January 16, 2016, 05:08:53 AM »
Hi
I  think that would be great.
We were trying some time ago - see here http://forum.tinycorelinux.net/index.php/topic,16852.0.html

I think we will need somehow to make a script that could build a selfcontained LMS as described here: http://forums.slimdevices.com/showthread.php?99648-Howto-build-a-self-contained-LMS and even better maybe be able to pull files directly from LMS-GIT so that it would be easy to update.

Steen

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: Logitech Media Server (LMS) on TC.7
« Reply #5 on: January 16, 2016, 12:18:41 PM »
Hi Steen,

Seems that nobody was successful to bring it working until now. There are too many steps which need to be clarified.
perl version is one of them, I've used the CPAN patch to repair it. This is not so difficult.
Another point is the RAM space limitation. I'm using the B board with only 512MB and during installation I've hit the roof several times. The only way is to place the working directory to /dev/mmcblk0p2 . This was mentioned in the forum too.

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Logitech Media Server (LMS) on TC.7
« Reply #6 on: January 16, 2016, 12:22:57 PM »
If you have the Perl issue covered i Think you are very close to have it running.
If you have read the thread here on tinycore you Can see that we managed to install LMS. But the next issue was the Perl packages.

Steen

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: Logitech Media Server (LMS) on TC.7
« Reply #7 on: January 16, 2016, 01:48:47 PM »
I've used the night build from here:
http://downloads.slimdevices.com/nightly/?ver=7.9
and used this patch:
http://www.mediafire.com/download/153ccfm16lb5ka2/logitechmediaserver_7.9.0_CPAN_5.20_armv6hf.tar.gz

Than I've hit the issue with the startup script based on lsb. I've used the hard-coppy of the folder /lib/lsb from Raspbian-jessie and the error message disappeared, started, but status reports error and it is not in the top and no logs in the /var folder.
Means that it's not loaded and working. I've used the startup script from here http://forum.tinycorelinux.net/index.php/topic,16852.0.html, but still not working. Guess if the perl version is the same as is in Raspbian. This may be the root cause.

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 842
Re: Logitech Media Server (LMS) on TC.7
« Reply #8 on: January 17, 2016, 07:53:23 AM »
It looks like they are only up to 5.20 in the git distribution

the perl version with TC7 is 5.22.  So the 5.20 files are not of much use. 

You might try getting the perl extension from piCore 6.x which is 5.20

http://repo.tinycorelinux.net/6.x/armv6/tcz/




Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: Logitech Media Server (LMS) on TC.7
« Reply #9 on: January 17, 2016, 11:53:01 AM »
It's not the issue.
I hit this error message:
Code: (bash) [Select]
sudo /usr/sbin/squeezeboxserver
The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
I need the kernel CPAN modules which are NOT compatible from Rasbian.
But there is no result from the modules compilation as mentioned here:
http://forum.tinycorelinux.net/index.php/topic,16852.15.html
Is somewhere possible to download these compiled modules?



Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 842
Re: Logitech Media Server (LMS) on TC.7
« Reply #10 on: January 17, 2016, 03:37:23 PM »
Code: (bash) [Select]
sudo /usr/sbin/squeezeboxserver
The following modules failed to load: DBI EV XML::Parser::Expat HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
I need the kernel CPAN modules which are NOT compatible from Rasbian.
But there is no result from the modules compilation as mentioned here:
http://forum.tinycorelinux.net/index.php/topic,16852.15.html
Is somewhere possible to download these compiled modules?

It has nothing to do with the Kernel.   CPAN modules only perl related, and the error messages above mean that your Perl version does not have appropriate compiled libraries.......the are compiled under the slimserver path.......it has nothing to do with Raspbian too.

For example, on my arm system, I'm running Perl 5.14, the modules for slimserver are here.

/slimserver/CPAN/arch/5.14/arm-linux-gnueabihf-thread-multi-64int/

And the first error message means that  ../XML/Parser/Expat/Expat.so cannot be loaded.   Please try what I recommended.  Remove the Perl 5.22 extension and grab the perl from the 6.x repo......and give it a shot. 


If the version that is on the repo won't work, the next step is to build perl manually.   Slimserver does require some certain compile time options that BMarkus may or may not have used when he built the TC versions of perl.


also, if you want to try to build the modules, the source for that stuff is here
https://github.com/Logitech/slimserver-platforms

but I found building an older version of perl was easier than trying to compile the tools for a newer version.
« Last Edit: January 17, 2016, 03:46:29 PM by Paul_123 »

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 842
Re: Logitech Media Server (LMS) on TC.7
« Reply #11 on: January 17, 2016, 04:14:09 PM »
okay, I just checked.  slimserver requires perl to support 64int, which the version with TC does not.

We are going to have to recompile perl for tc.

I'll give it a shot.

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 842
Re: Logitech Media Server (LMS) on TC.7
« Reply #12 on: January 17, 2016, 07:11:26 PM »
I built perl 5.20.3 with the appropriate compile time options, and downloaded lms 7.9 and it starts just fine.   No errors at  startup and I got as far as opening the web page.  No patches or needed.   All you need to do is edit slimserver.pl and scanner.pl to point at the appropriate perl version.

I would be happy to make an extension for you guys,  right now I have it in /opt/perl5, but since that is a backup location, that is probably not a wise permanent choice.   It needs to be different, so it would not conflict if you installed the normal perl that resides in the repo.   Both versions can live happy together.

I would also need to trim the fat, as documentation is included right now, so the file is 11MB

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7179
    • My Community Forum
Re: Logitech Media Server (LMS) on TC.7
« Reply #13 on: January 17, 2016, 10:06:45 PM »
Let me know exactly which Perl options you need and I will rebuild it.
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline jgrulich

  • Sr. Member
  • ****
  • Posts: 341
    • GRULICH DESIGN - R&D Lab.
Re: Logitech Media Server (LMS) on TC.7
« Reply #14 on: January 17, 2016, 10:54:07 PM »
Hi Paul_123

I've used the perl from the 6.x distro which is 5.20.1 and hit these errors with the latest LMS 7.9.0.
Please share your perl 5.20.3, probably it's is more module rich than the one in the repo.

If it will work with the LMS, we may add it to repo to have at least some working solution until we will have the build solution for the latest perl version 5.22 with is in 7.x repo.