WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: tc6.4.1 gnumeric crash  (Read 919 times)

Offline aug

  • Jr. Member
  • **
  • Posts: 74
tc6.4.1 gnumeric crash
« on: December 18, 2015, 09:51:30 AM »
gnumeric did not start. error message at console is BadValue integer parameter out of range for operation

Offline grandma

  • Full Member
  • ***
  • Posts: 174
  • Never forget Grandma Loves You & made that candy4U
    • Back when a 10MB HD was $500 bucks
GNUMERIC CRASH TC 7.2
« Reply #1 on: April 21, 2018, 11:47:42 PM »
Don't faint.
After riding TC 3.xx since 2010
I finally migrated to 7.2;
very reluctantly I might add.

While Firefox and Abiword seem OK
and some web sites even work better

...OUCH - GNUMERIC WON'T LOAD...

I run an HP laptop 32 bit and the
crash is so fast the error message
is gone with the wind.

I'd be happy to make a DUMP
if someone told me what to look for.

Grandma
~ Luv Grandma
"When children of all nations
play in the sandbox together
all morning-all day-all week, and
one fine sunny day; all year long ...
... then war will become an ancient memory
and Grandma can knit that sweater
you'll hold near to your heart
until long after you're my age.

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5701
Re: tc6.4.1 gnumeric crash
« Reply #2 on: April 22, 2018, 06:36:26 AM »
Hi grandma
Try running:
Code: [Select]
ldd `which gnumeric`and see if any of the lines end with  Not Found.  Those are  backticks,  not  apostrophes  in that command. They are on the  ~  key.

Offline grandma

  • Full Member
  • ***
  • Posts: 174
  • Never forget Grandma Loves You & made that candy4U
    • Back when a 10MB HD was $500 bucks
Re: tc6.4.1 gnumeric crash
« Reply #3 on: April 22, 2018, 04:47:47 PM »
ERROR MESSAGES REQUESTED:

1. NO "NOT FOUND" MESSAGES for Gnumeric

(complete GNUMERIC and FILEZILLA WHICH DUMP
is at the end of this message)

2.

Here's a comparison of 2 gnumeric and filezillas
I have:

Version TC 7.x on /mnt/sdb1

10539008 Apr 20 23:04 gnumeric.tcz
 1921024 Apr 22 23:10 filezilla.tcz

Version TC 3.x on /mnt/sdc1

 9265152 Feb 10 11:15 /mnt/sdc1/tce3xx/optional/gnumeric.tcz
 1871872 Feb 10 11:14 /mnt/sdc1/tce3xx/optional/filezilla.tcz

These are the only 2 TC distros I've used.

Running:
Code: [Select]
gnumeric 2>~/t
is somewhat informative and longer winded than me:


** (gnumeric:21644): CRITICAL **: go_conf_add_monitor: assertion 'node || key' failed
** (gnumeric:21644): CRITICAL **: go_conf_get_node: assertion 'parent || key' failed
(this repeats about 100 times)

AND ALSO:
(gnumeric:21644): GLib-GObject-WARNING **: The property GtkToolButton:stock-id is deprecated and shouldn't be used anymore. It will be removed in a future version.
(gnumeric:21644): GLib-GObject-WARNING **: The property GtkSettings:gtk-menu-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

THEN MORE OF:
** (gnumeric:21644): CRITICAL **: go_conf_add_monitor: assertion 'node || key' failed
** (gnumeric:21644): CRITICAL **: go_conf_get_node: assertion 'parent || key' failed

AND THEN AGAIN:
(gnumeric:21644): GLib-GObject-WARNING **: The property GtkSettings:gtk-toolbar-icon-size is deprecated and shouldn't be used anymore. It will be removed in a future version.

AND:
(gnumeric:21644): GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version.

AND:
(gnumeric:21644): GLib-GObject-WARNING **: The property GtkAlignment:xalign is deprecated and shouldn't be used anymore. It will be removed in a future version.

AND:
(gnumeric:21644): GLib-GObject-WARNING **: The property GtkAlignment:yalign is deprecated and shouldn't be used anymore. It will be removed in a future version.

THEN MORE OF:
** (gnumeric:21644): CRITICAL **: go_conf_add_monitor: assertion 'node || key' failed
** (gnumeric:21644): CRITICAL **: go_conf_get_node: assertion 'parent || key' failed

AND ODD ICONS MESSAGES - (she's trying to load for sure):
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'document-new' for stock: Icon 'document-new' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'document-open' for stock: Icon 'document-open' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'document-save' for stock: Icon 'document-save' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'document-print' for stock: Icon 'document-print' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'document-print-preview' for stock: Icon 'document-print-preview' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'edit-cut' for stock: Icon 'edit-cut' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'edit-copy' for stock: Icon 'edit-copy' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'edit-paste' for stock: Icon 'edit-paste' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'edit-undo' for stock:
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'edit-redo' for stock:
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'view-sort-ascending' for stock: Icon 'view-sort-ascending' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'view-sort-descending' for stock: Icon 'view-sort-descending' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'format-text-bold' for stock: Icon 'format-text-bold' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'format-text-italic' for stock: Icon 'format-text-italic' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'format-text-underline' for stock: Icon 'format-text-underline' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'format-justify-left' for stock: Icon 'format-justify-left' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'format-justify-center' for stock: Icon 'format-justify-center' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'format-justify-right' for stock: Icon 'format-justify-right' not present in theme
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'format-indent-less' for stock:
(gnumeric:21644): Gtk-WARNING **: Error loading theme icon 'format-indent-more' for stock:

THEN AGAIN MORE OF THESE:
** (gnumeric:21644): CRITICAL **: go_conf_add_monitor: assertion 'node || key' failed
** (gnumeric:21644): CRITICAL **: go_conf_get_node: assertion 'parent || key' failed

AND:
(gnumeric:21644): Gdk-ERROR **: The program 'gnumeric' received an X Window System error.

AND FINALLY THIS:
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 1056 error_code 2 request_code 139 (RENDER) minor_code 26)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap


NEXT - FILEZILLA STEPS UP TO THE PLATE:

Running:
Code: [Select]
filezilla --help  2>~/t
graceful dump msg:
filezilla: error while loading shared libraries: libiconv.so.2: cannot open shared object file: No such file or directory

BTW: Abiword, Gimp, Epdfview all A-OK.

Even WINE from the 3.xx distro runs OK from
the 7.x optional folder, though I had to
bring a few dep tcz's over.

Gnumeric was bombing before I did tho WINE tests
and contaminated the 7.xx optional folder with
the older WINE DEP tcz's. I will strip it ALL
out and start over/clean and see if I can get
gnumeric to load clean with a clean 7.xx
optional folder.


SUMMARY: Gnumeric, Filezilla and Firefox

Migrating from 3.5 to 7.2 I also
found  GNUMERIC and  FILEZILLA - broken
delivering the error messages above.

Tried a work around, hoping an older
version might run - tried using ancient
DEPs - but no such luck, which
indicates the bad lib is in a 7.xx
onboot.lst environment, or maybe
the linux kernel itself. Not sure.

While I did get OSS-ALSA and ALSA to
produce audio for VLC (whoo hoo)
FIREFOX changed their policies and now
REQUIRES PULSEAUDIO to play any sounds
(boo hoo).

I might suggest you scrap any version
of Firefox with this fatal BUG in
their design and rollback to a fully functional
version OR write a tutorial on how to get
it to work with Tiny Core, as its useless
as is. This isn't really anyone's fault here,
as the Mozilla kiddies who design and deliver
Firefox updates took something that
wasn't broken and fixed it and now its
pure "broken". Pure genius.

...sounds like you fellas are overworked
and underpaid. Any other ideas would be
apprciated.

Thank you Rich.


GNUMERIC WHICH DUMP:
Code: [Select]

linux-gate.so.1 (0xb7743000)
libspreadsheet-1.12.7.so => /usr/local/lib/libspreadsheet-1.12.7.so (0xb74c8000)
libgoffice-0.10.so.10 => /usr/local/lib/libgoffice-0.10.so.10 (0xb73a6000)
libgsf-1.so.114 => /usr/local/lib/libgsf-1.so.114 (0xb7373000)
libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0xb7237000)
libgmodule-2.0.so.0 => /usr/local/lib/libgmodule-2.0.so.0 (0xb7233000)
libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0xb7231000)
libgtk-3.so.0 => /usr/local/lib/libgtk-3.so.0 (0xb6ceb000)
libgdk-3.so.0 => /usr/local/lib/libgdk-3.so.0 (0xb6c77000)
libpangocairo-1.0.so.0 => /usr/local/lib/libpangocairo-1.0.so.0 (0xb6c6c000)
libpango-1.0.so.0 => /usr/local/lib/libpango-1.0.so.0 (0xb6c28000)
libatk-1.0.so.0 => /usr/local/lib/libatk-1.0.so.0 (0xb6c0a000)
libcairo-gobject.so.2 => /usr/local/lib/libcairo-gobject.so.2 (0xb6c04000)
libcairo.so.2 => /usr/local/lib/libcairo.so.2 (0xb6b4f000)
libgdk_pixbuf-2.0.so.0 => /usr/local/lib/libgdk_pixbuf-2.0.so.0 (0xb6b37000)
libgio-2.0.so.0 => /usr/local/lib/libgio-2.0.so.0 (0xb69e1000)
libgobject-2.0.so.0 => /usr/local/lib/libgobject-2.0.so.0 (0xb6997000)
libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0xb6873000)
libpcre.so.0 => /usr/local/lib/libpcre.so.0 (0xb6815000)
libm.so.6 => /lib/libm.so.6 (0xb67da000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb67c2000)
libc.so.6 => /lib/libc.so.6 (0xb66ad000)
librsvg-2.so.2 => /usr/local/lib/librsvg-2.so.2 (0xb6684000)
libz.so.1 => /usr/lib/libz.so.1 (0xb6672000)
libbz2.so.1.0 => /usr/local/lib/libbz2.so.1.0 (0xb6666000)
libdl.so.2 => /lib/libdl.so.2 (0xb6661000)
liblzma.so.5 => /usr/local/lib/liblzma.so.5 (0xb663d000)
libXinerama.so.1 => /usr/local/lib/libXinerama.so.1 (0xb663a000)
libXrandr.so.2 => /usr/local/lib/libXrandr.so.2 (0xb6632000)
libXcursor.so.1 => /usr/local/lib/libXcursor.so.1 (0xb662a000)
libxcb-dri3.so.0 => /usr/local/lib/libxcb-dri3.so.0 (0xb6626000)
libxcb-present.so.0 => /usr/local/lib/libxcb-present.so.0 (0xb6624000)
libxcb-randr.so.0 => /usr/local/lib/libxcb-randr.so.0 (0xb661a000)
libxcb-sync.so.1 => /usr/local/lib/libxcb-sync.so.1 (0xb6615000)
libxshmfence.so.1 => /usr/local/lib/libxshmfence.so.1 (0xb6613000)
libXi.so.6 => /usr/local/lib/libXi.so.6 (0xb6606000)
libXcomposite.so.1 => /usr/local/lib/libXcomposite.so.1 (0xb6603000)
libpixman-1.so.0 => /usr/local/lib/libpixman-1.so.0 (0xb6585000)
libEGL.so.1 => /usr/local/lib/libEGL.so.1 (0xb656b000)
libxcb-xfixes.so.0 => /usr/local/lib/libxcb-xfixes.so.0 (0xb6566000)
libxcb-shape.so.0 => /usr/local/lib/libxcb-shape.so.0 (0xb6562000)
libgbm.so.1 => /usr/local/lib/libgbm.so.1 (0xb655c000)
libudev.so.0 => /usr/local/lib/libudev.so.0 (0xb6550000)
libxcb-shm.so.0 => /usr/local/lib/libxcb-shm.so.0 (0xb654d000)
libxcb-render.so.0 => /usr/local/lib/libxcb-render.so.0 (0xb6546000)
libXrender.so.1 => /usr/local/lib/libXrender.so.1 (0xb653e000)
libGL.so.1 => /usr/local/lib/libGL.so.1 (0xb64f7000)
libglapi.so.0 => /usr/local/lib/libglapi.so.0 (0xb64dc000)
libXdamage.so.1 => /usr/local/lib/libXdamage.so.1 (0xb64d9000)
libXfixes.so.3 => /usr/local/lib/libXfixes.so.3 (0xb64d5000)
libX11-xcb.so.1 => /usr/local/lib/libX11-xcb.so.1 (0xb64d2000)
libxcb-glx.so.0 => /usr/local/lib/libxcb-glx.so.0 (0xb64c2000)
libxcb-dri2.so.0 => /usr/local/lib/libxcb-dri2.so.0 (0xb64be000)
libXxf86vm.so.1 => /usr/local/lib/libXxf86vm.so.1 (0xb64ba000)
libXext.so.6 => /usr/local/lib/libXext.so.6 (0xb64ad000)
libdrm.so.2 => /usr/local/lib/libdrm.so.2 (0xb64a1000)
libpng16.so.16 => /usr/local/lib/libpng16.so.16 (0xb647b000)
libatk-bridge-2.0.so.0 => /usr/local/lib/libatk-bridge-2.0.so.0 (0xb645b000)
libatspi.so.0 => /usr/local/lib/libatspi.so.0 (0xb6440000)
libSM.so.6 => /usr/local/lib/libSM.so.6 (0xb643a000)
libuuid.so.1 => /lib/libuuid.so.1 (0xb6435000)
libICE.so.6 => /usr/local/lib/libICE.so.6 (0xb6421000)
libX11.so.6 => /usr/local/lib/libX11.so.6 (0xb6326000)
libxcb.so.1 => /usr/local/lib/libxcb.so.1 (0xb630f000)
libXau.so.6 => /usr/local/lib/libXau.so.6 (0xb630c000)
libXdmcp.so.6 => /usr/local/lib/libXdmcp.so.6 (0xb6306000)
libdbus-1.so.3 => /usr/local/lib/libdbus-1.so.3 (0xb62d4000)
librt.so.1 => /lib/librt.so.1 (0xb62cc000)
libpangoft2-1.0.so.0 => /usr/local/lib/libpangoft2-1.0.so.0 (0xb62bb000)
libharfbuzz.so.0 => /usr/local/lib/libharfbuzz.so.0 (0xb6283000)
libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0xb6256000)
libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0xb6239000)
libfreetype.so.6 => /usr/local/lib/libfreetype.so.6 (0xb61c1000)
libresolv.so.2 => /lib/libresolv.so.2 (0xb61ae000)
libffi.so.6 => /usr/local/lib/libffi.so.6 (0xb61a8000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb6192000)
/lib/ld-linux.so.2 (0x8008b000)
libcroco-0.6.so.3 => /usr/local/lib/libcroco-0.6.so.3 (0xb6167000)


FILEZILLA WHICH DUMP:
Code: [Select]

linux-gate.so.1 (0xb77cb000)
libgnutls.so.28 => /usr/local/lib/libgnutls.so.28 (0xb770a000)
libwx_gtk2u_aui-2.8.so.0 => /usr/local/lib/libwx_gtk2u_aui-2.8.so.0 (0xb76b8000)
libwx_gtk2u_xrc-2.8.so.0 => /usr/local/lib/libwx_gtk2u_xrc-2.8.so.0 (0xb7655000)
libwx_gtk2u_adv-2.8.so.0 => /usr/local/lib/libwx_gtk2u_adv-2.8.so.0 (0xb75b3000)
libwx_gtk2u_core-2.8.so.0 => /usr/local/lib/libwx_gtk2u_core-2.8.so.0 (0xb7311000)
libwx_baseu_xml-2.8.so.0 => /usr/local/lib/libwx_baseu_xml-2.8.so.0 (0xb7309000)
libwx_baseu_net-2.8.so.0 => /usr/local/lib/libwx_baseu_net-2.8.so.0 (0xb72e4000)
libwx_baseu-2.8.so.0 => /usr/local/lib/libwx_baseu-2.8.so.0 (0xb71d4000)
libidn.so.11 => /usr/local/lib/libidn.so.11 (0xb71a3000)
libsqlite3.so.0 => /usr/local/lib/libsqlite3.so.0 (0xb70de000)
libgtk-x11-2.0.so.0 => /usr/local/lib/libgtk-x11-2.0.so.0 (0xb6d04000)
libgdk-x11-2.0.so.0 => /usr/local/lib/libgdk-x11-2.0.so.0 (0xb6c6c000)
libpangocairo-1.0.so.0 => /usr/local/lib/libpangocairo-1.0.so.0 (0xb6c61000)
libatk-1.0.so.0 => /usr/local/lib/libatk-1.0.so.0 (0xb6c43000)
libcairo.so.2 => /usr/local/lib/libcairo.so.2 (0xb6b8d000)
libgdk_pixbuf-2.0.so.0 => /usr/local/lib/libgdk_pixbuf-2.0.so.0 (0xb6b75000)
libgio-2.0.so.0 => /usr/local/lib/libgio-2.0.so.0 (0xb6a20000)
libpangoft2-1.0.so.0 => /usr/local/lib/libpangoft2-1.0.so.0 (0xb6a0f000)
libpango-1.0.so.0 => /usr/local/lib/libpango-1.0.so.0 (0xb69cc000)
libgobject-2.0.so.0 => /usr/local/lib/libgobject-2.0.so.0 (0xb6981000)
libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0xb685d000)
libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0xb6831000)
libfreetype.so.6 => /usr/local/lib/libfreetype.so.6 (0xb67b9000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb669e000)
libm.so.6 => /lib/libm.so.6 (0xb6662000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb664d000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb6636000)
libc.so.6 => /lib/libc.so.6 (0xb6521000)
libtasn1.so.6 => /usr/local/lib/libtasn1.so.6 (0xb650f000)
libnettle.so.4 => /usr/local/lib/libnettle.so.4 (0xb64dc000)
libhogweed.so.2 => /usr/local/lib/libhogweed.so.2 (0xb64b2000)
libgmp.so.10 => /usr/local/lib/libgmp.so.10 (0xb6468000)
librt.so.1 => /lib/librt.so.1 (0xb6460000)
libz.so.1 => /usr/lib/libz.so.1 (0xb644e000)
libp11-kit.so.0 => /usr/local/lib/libp11-kit.so.0 (0xb63ff000)
libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0xb63fd000)
libXinerama.so.1 => /usr/local/lib/libXinerama.so.1 (0xb63fa000)
libXxf86vm.so.1 => /usr/local/lib/libXxf86vm.so.1 (0xb63f6000)
libSM.so.6 => /usr/local/lib/libSM.so.6 (0xb63f0000)
libpng16.so.16 => /usr/local/lib/libpng16.so.16 (0xb63ca000)
libjpeg.so.62 => /usr/local/lib/libjpeg.so.62 (0xb637b000)
libtiff.so.5 => /usr/local/lib/libtiff.so.5 (0xb6311000)
libdl.so.2 => /lib/libdl.so.2 (0xb630d000)
libiconv.so.2 => not found
libiconv.so.2 => not found
libwx_gtk2u_html-2.8.so.0 => /usr/local/lib/libwx_gtk2u_html-2.8.so.0 (0xb6292000)
libiconv.so.2 => not found
libiconv.so.2 => not found
libiconv.so.2 => not found
libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0xb6274000)
libiconv.so.2 => not found
libiconv.so.2 => not found
libXrandr.so.2 => /usr/local/lib/libXrandr.so.2 (0xb626c000)
libXcursor.so.1 => /usr/local/lib/libXcursor.so.1 (0xb6264000)
libXcomposite.so.1 => /usr/local/lib/libXcomposite.so.1 (0xb6260000)
libpixman-1.so.0 => /usr/local/lib/libpixman-1.so.0 (0xb61e2000)
libxcb-shm.so.0 => /usr/local/lib/libxcb-shm.so.0 (0xb61df000)
libxcb-render.so.0 => /usr/local/lib/libxcb-render.so.0 (0xb61d8000)
libXrender.so.1 => /usr/local/lib/libXrender.so.1 (0xb61d1000)
libGL.so.1 => /usr/local/lib/libGL.so.1 (0xb6189000)
libglapi.so.0 => /usr/local/lib/libglapi.so.0 (0xb616e000)
libXdamage.so.1 => /usr/local/lib/libXdamage.so.1 (0xb616b000)
libXfixes.so.3 => /usr/local/lib/libXfixes.so.3 (0xb6167000)
libX11-xcb.so.1 => /usr/local/lib/libX11-xcb.so.1 (0xb6165000)
libxcb-glx.so.0 => /usr/local/lib/libxcb-glx.so.0 (0xb6154000)
libxcb-dri2.so.0 => /usr/local/lib/libxcb-dri2.so.0 (0xb6150000)
libXext.so.6 => /usr/local/lib/libXext.so.6 (0xb6143000)
libX11.so.6 => /usr/local/lib/libX11.so.6 (0xb6048000)
libxcb.so.1 => /usr/local/lib/libxcb.so.1 (0xb6031000)
libXau.so.6 => /usr/local/lib/libXau.so.6 (0xb602d000)
libXdmcp.so.6 => /usr/local/lib/libXdmcp.so.6 (0xb6028000)
libdrm.so.2 => /usr/local/lib/libdrm.so.2 (0xb601d000)
libresolv.so.2 => /lib/libresolv.so.2 (0xb600a000)
libharfbuzz.so.0 => /usr/local/lib/libharfbuzz.so.0 (0xb5fd2000)
libgmodule-2.0.so.0 => /usr/local/lib/libgmodule-2.0.so.0 (0xb5fce000)
libffi.so.6 => /usr/local/lib/libffi.so.6 (0xb5fc8000)
libEGL.so.1 => /usr/local/lib/libEGL.so.1 (0xb5fae000)
/lib/ld-linux.so.2 (0x800c6000)
libICE.so.6 => /usr/local/lib/libICE.so.6 (0xb5f99000)
libuuid.so.1 => /lib/libuuid.so.1 (0xb5f95000)
liblzma.so.5 => /usr/local/lib/liblzma.so.5 (0xb5f71000)
libiconv.so.2 => not found
libxcb-dri3.so.0 => /usr/local/lib/libxcb-dri3.so.0 (0xb5f6d000)
libxcb-present.so.0 => /usr/local/lib/libxcb-present.so.0 (0xb5f6b000)
libxcb-sync.so.1 => /usr/local/lib/libxcb-sync.so.1 (0xb5f66000)
libxshmfence.so.1 => /usr/local/lib/libxshmfence.so.1 (0xb5f64000)
libxcb-xfixes.so.0 => /usr/local/lib/libxcb-xfixes.so.0 (0xb5f5e000)
libgbm.so.1 => /usr/local/lib/libgbm.so.1 (0xb5f58000)

added code tags
« Last Edit: April 23, 2018, 02:42:42 AM by Juanito »
~ Luv Grandma
"When children of all nations
play in the sandbox together
all morning-all day-all week, and
one fine sunny day; all year long ...
... then war will become an ancient memory
and Grandma can knit that sweater
you'll hold near to your heart
until long after you're my age.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9758
Re: tc6.4.1 gnumeric crash
« Reply #4 on: April 23, 2018, 12:25:21 AM »
Re gnumeric:
Quote
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 1056 error_code 2 request_code 139 (RENDER) minor_code 26)
This is an incompatibility with gnumeric and/or your gtk2 theme with tinyX. Try changing your gtk2 theme, or use Xorg.
The only barriers that can stop you are the ones you create yourself.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9960
Re: tc6.4.1 gnumeric crash
« Reply #5 on: April 23, 2018, 02:45:04 AM »
filezilla was fixed in tc-9.x x86

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9960
Re: tc6.4.1 gnumeric crash
« Reply #6 on: April 23, 2018, 06:44:32 AM »
in tc-9.x x86, gnumeric fails with this error with Xvesa:
Code: [Select]
$ gnumeric
...
(gnumeric:5628): Gdk-ERROR **: The program 'gnumeric' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 1659 error_code 2 request_code 139 (RENDER) minor_code 26)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap

gnumeric works with Xorg-7.7

If you need icons with gnumeric, you can load adwaita-icon-theme

Offline grandma

  • Full Member
  • ***
  • Posts: 174
  • Never forget Grandma Loves You & made that candy4U
    • Back when a 10MB HD was $500 bucks
Re: tc6.4.1 gnumeric crash
« Reply #7 on: April 23, 2018, 03:34:13 PM »
tried clean install of 9.x
splattered all over the place

filezilla won't load from 7.x
tried Rich solution - deleted Xorg 7.5 - nope

will back down 6 5 4 3 to find stable office
and retry after 9.x matures

Stable Office Needs:

Abiword, Gnumeric, Gimp, Epdfview (view), Cups-PDF or EPF (create) - minimum

Plus fully functional browser - Firefox and a Secure Browser - TOR Browser

Plus functional media - i.e. VLC (works), OSS-Alsa or Alsa and Pulseaudio since Firefox now requires i to play media (does not work)

A Pulseaudio tutorial would be helpful - I did get OSS-Alsa to work with a script - no Pulseaudio yet...

System/Admin Office Needs:

Filezilla, Apache, A SMTP/POP Mailserver, Perl5, TCC (Tiny C Compiler), GCC,

Bonus - Lzip - which works from tc 3x version and Wine which also works from 3x version

A couple of other stable TCZs would be sweet - like SKYPE...

BROkEN IN THIS LIST SO FAR: Gnumeric and Filezilla - will let you know how 6 5 4 works out

~ Luv Grandma
"When children of all nations
play in the sandbox together
all morning-all day-all week, and
one fine sunny day; all year long ...
... then war will become an ancient memory
and Grandma can knit that sweater
you'll hold near to your heart
until long after you're my age.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9960
Re: tc6.4.1 gnumeric crash
« Reply #8 on: April 24, 2018, 12:01:43 AM »
A Pulseaudio tutorial would be helpful - I did get OSS-Alsa to work with a script - no Pulseaudio yet...

Usually all that is needed is to start the dbus daemon prior to "startx" - opening pavucontrol will then start the pulseaudio daemon.

There is a thread somewhere on how to save pulseaudio commands in order to restore custom settings on reboot.