WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] dCore intel i810 graphic chip support issue...  (Read 2227 times)

Offline nitram

  • Hero Member
  • *****
  • Posts: 1051
[SOLVED] dCore intel i810 graphic chip support issue...
« on: December 17, 2015, 03:29:27 AM »
Attempting to run dCore Jessie in graphic mode with old Intel i810 onboard graphic chip.

Onboot loading of vesa driver boots to graphics, poor resolution despite xorg.conf changes.

Unable to boot into graphics using xorg-intel driver(s). Not sure if this is relevant, log output indicates module i915 not present. Tried with/out xorg.conf file.

Debian Jessie xserver-xorg-video-intel (https://packages.debian.org/jessie/xserver-xorg-video-intel) indicates the i810 is supported.

Noteworthy, regular TC 6.4 runs fine in graphics on same hardware using Xorg-7.7.tcz, xf86-video-intel.tcz and custom xorg.conf file.

Does dCore use customized Intel driver? Is something missing? Assistance appreciated, would really like to try dCore on this system.

I'm new to dCore, maybe i'm doing something wrong. Any more information required, please ask. Thanks.

Edit: Should also mention, tried to run dCore several months ago with same issue. Tried both variants of Debian and Ubuntu i believe it was. Today was the first time i was able to boot dCore into graphics using vesa with poor resolution, but it's not functional like this. Thanks.
« Last Edit: December 18, 2015, 05:20:18 PM by Rich »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12404
Re: dCore intel i810 graphic chip support issue...
« Reply #1 on: December 17, 2015, 03:49:33 AM »
Maybe debian xf86-video-intel was compiled with "--enable-kms-only"?

Offline sm8ps

  • Sr. Member
  • ****
  • Posts: 326
Re: dCore intel i810 graphic chip support issue...
« Reply #2 on: December 17, 2015, 09:08:37 AM »
I believe the i915 drivers are present in the extension graphics-<KERNEL>-tinycore that has to be loaded in addition to Xorg.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9707
Re: dCore intel i810 graphic chip support issue...
« Reply #3 on: December 17, 2015, 09:31:53 AM »
I see the module i915 loaded on my box that has an Intel 8xx chip and I have excellent video perfornance.  As stated above, you need the kernel module extension.



Offline nitram

  • Hero Member
  • *****
  • Posts: 1051
Re: dCore intel i810 graphic chip support issue...
« Reply #4 on: December 17, 2015, 10:55:13 AM »
Thanks everyone. Don't see graphics-<KERNEL>-tinycore extension here: http://distro.ibiblio.org/tinycorelinux/dCore/x86/sce/dCore-jessie/ ? Will boot dCore and try using sce-import. Thanks.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1051
Re: dCore intel i810 graphic chip support issue...
« Reply #5 on: December 17, 2015, 11:18:38 AM »
Posting from Dillo on dCore Jessie. Wonderful !

Running without an xorg.conf file, amazing for this old hardware which always required fiddling.

How to confirm desktop resolution? Previously tried installing xrandr without success.

Thanks.

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
Re: dCore intel i810 graphic chip support issue...
« Reply #6 on: December 17, 2015, 11:25:22 AM »
I'm on dCore-trusty and xrandr works. I see is from the  x11-xserver-utils package, like in jessie
dCore user

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 8121
Re: dCore intel i810 graphic chip support issue...
« Reply #7 on: December 17, 2015, 11:26:34 AM »
Hi nitram
Quote
How to confirm desktop resolution?
Use  xwininfo  and click on the desktop.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1051
Re: dCore intel i810 graphic chip support issue...
« Reply #8 on: December 17, 2015, 12:10:21 PM »
Thanks will try one or both options.

jls_legalize how did you confirm this? I'm now spoiled with tce-ab and Apps, feel little lost. Checked sce-import --help, no obvious mechanism to find package information/description, 'provides' functionality, etc. Just use www or Debian site for research as pretty much anything in Debian repos is now potentially available in dCore?

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
Re: dCore intel i810 graphic chip support issue...
« Reply #9 on: December 17, 2015, 12:21:23 PM »
Hi nitram
yes, packages.debian.org
installed packages are in /tmp/.debinstalled
In my system I see that xrandr is in xorg-all sce:
Code: [Select]
jls@box:~$ find /tmp/tcloop/ -iname xrandr
/tmp/tcloop/xorg-all/usr/bin/xrandr
dCore user

Offline nitram

  • Hero Member
  • *****
  • Posts: 1051
Re: dCore intel i810 graphic chip support issue...
« Reply #10 on: December 17, 2015, 01:08:18 PM »
xwininfo does not appear to be in Debian. x11-xserver-utils installed, system defaulted to 1024x768 60.00* with slight off-center, so will probably utilize a known working xorg.conf file to increase resolution. Pretty nice for default though. Otherwise all good. Thanks again.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9707
Re: dCore intel i810 graphic chip support issue...
« Reply #11 on: December 17, 2015, 01:16:46 PM »

Offline nitram

  • Hero Member
  • *****
  • Posts: 1051
[solved] dCore intel i810 graphic chip support issue...
« Reply #12 on: December 18, 2015, 02:10:11 PM »
Thanks Jason. TC and dCore really make you learn packages...eventually :)

Installing a known working /etc/X11/xorg.conf file fixed the resolution issue and dCore utilizes the same TC friendly Control Panel -> Backup/Restore GUI. If a moderator could kindly mark the thread [solved] to help others with similar graphic issue. Everyone's hardware is different, posting my xorg.conf file to complete the thread:

Code: [Select]
Section "Monitor"
Identifier   "Monitor0"
HorizSync       28.0 - 96.0
  VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"            # [<bool>]
        #Option     "SWcursor"            # [<bool>]
        #Option     "ColorKey"            # <i>
        #Option     "CacheLines"          # <i>
        #Option     "Dac6Bit"            # [<bool>]
        #Option     "DRI"                # [<bool>]
        #Option     "NoDDC"              # [<bool>]
        #Option     "ShowCache"          # [<bool>]
        #Option     "XvMCSurfaces"        # <i>
        #Option     "PageFlip"            # [<bool>]
Identifier  "Card0"
Driver      "intel"
VendorName  "Intel Corporation"
BoardName   "82810 DC-100 (CGC) Chipset Graphics Controller"
BusID       "PCI:0:1:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth    16
SubSection "Display"
Depth 16
Modes "1152x864"
EndSubSection
EndSection