WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Epson L11O USB printer won't printed  (Read 2043 times)

Offline Battheo

  • WikiUser
  • *
  • Posts: 4
Epson L11O USB printer won't printed
« on: December 23, 2015, 04:17:09 PM »
Epson L11O USB printer won't printed

My printer installed but won't work. Printer is detected by CUPS but,
when I attempt to print a test page it gives to Status on cusps Printers page:
" Idle - "File "/opt/epson-inkjet-printer-201207w/cups/lib/filter/epson_inkjet_printer_filter"
has insecure permissions (0100755/uid=1001/gid=50)"
and
error.log:
Code: newbielink:javascript:void(0); [nonactive]
D [24/Dec/2015:00:07:01 +0000] [Client 12] GET /admin HTTP/1.1
D [24/Dec/2015:00:07:01 +0000] cupsdSetBusyState: newbusy="Active clients", busy="Not busy"
D [24/Dec/2015:00:07:01 +0000] [Client 12] Authorized as root using Basic
D [24/Dec/2015:00:07:01 +0000] [CGI] argv[0] = "/usr/local/lib/cups/cgi-bin/admin.cgi"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[0] = "CUPS_CACHEDIR=/var/cache/cups"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[1] = "CUPS_DATADIR=/usr/local/share/cups"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[2] = "CUPS_DOCROOT=/usr/local/share/doc/cups"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[3] = "CUPS_FONTPATH=/usr/local/share/cups/fonts"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[4] = "CUPS_REQUESTROOT=/var/spool/cups"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[5] = "CUPS_SERVERBIN=/usr/local/lib/cups"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[6] = "CUPS_SERVERROOT=/usr/local/etc/cups"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[7] = "CUPS_STATEDIR=/var/run/cups"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[8] = "HOME=/var/spool/cups/tmp"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[9] = "PATH=/usr/local/lib/cups/filter:/usr/local/bin:/usr/local/sbin:/bin:/usr/bin"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[10] = "SERVER_ADMIN=root@box"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[11] = "SOFTWARE=CUPS/1.6.2"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[12] = "TMPDIR=/var/spool/cups/tmp"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[13] = "USER=root"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[14] = "CUPS_MAX_MESSAGE=2047"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[15] = "CUPS_SERVER=/var/run/cups/cups.sock"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[16] = "CUPS_ENCRYPTION=IfRequested"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[17] = "IPP_PORT=631"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[18] = "AUTH_TYPE=Basic"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[19] = "LANG=en.UTF8"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[20] = "REDIRECT_STATUS=1"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[21] = "GATEWAY_INTERFACE=CGI/1.1"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[22] = "SERVER_NAME=localhost"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[23] = "SERVER_PORT=631"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[24] = "REMOTE_ADDR=127.0.0.1"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[25] = "REMOTE_HOST=localhost"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[26] = "SCRIPT_NAME=/admin"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[27] = "SCRIPT_FILENAME=/usr/local/share/doc/cups/admin"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[28] = "REMOTE_USER=root"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[29] = "SERVER_PROTOCOL=HTTP/1.1"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[30] = "HTTP_COOKIE=org.cups.sid=f1b0c51fffb4a62d591555d488f40cdb"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[31] = "HTTP_USER_AGENT=Opera/9.64 (X11; Linux i686; U; en) Presto/2.1.1"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[32] = "HTTP_REFERER=http://localhost:631/admin"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[33] = "REQUEST_METHOD=GET"
D [24/Dec/2015:00:07:01 +0000] [CGI] envp[34] = "QUERY_STRING="
D [24/Dec/2015:00:07:01 +0000] [CGI] Started /usr/local/lib/cups/cgi-bin/admin.cgi (PID 6166)
I [24/Dec/2015:00:07:01 +0000] [Client 12] Started "/usr/local/lib/cups/cgi-bin/admin.cgi" (pid=6166)
D [24/Dec/2015:00:07:01 +0000] [Client 12] file=13
D [24/Dec/2015:00:07:01 +0000] [CGI] admin.cgi started...
D [24/Dec/2015:00:07:01 +0000] [Client 14] Accepted from localhost (Domain)
D [24/Dec/2015:00:07:01 +0000] [CGI] http=0xb7af21e8
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: SECTION="admin"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: REFRESH_PAGE=""
D [24/Dec/2015:00:07:01 +0000] [CGI] org.cups.sid cookie is "f1b0c51fffb4a62d591555d488f40cdb"
D [24/Dec/2015:00:07:01 +0000] [CGI] No form data, showing main menu...
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: DEBUG_LOGGING="CHECKED"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: SHARE_PRINTERS="CHECKED"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: USER_CANCEL_ANY="CHECKED"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: KERBEROS=""
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: PRESERVE_JOBS="CHECKED"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: PRESERVE_JOB_HISTORY="Yes"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: PRESERVE_JOB_FILES="1d"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: MAX_CLIENTS="100"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: MAX_JOBS="500"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: MAX_LOG_SIZE="1m"
D [24/Dec/2015:00:07:01 +0000] [CGI] /usr/local/share/cups/drivers/pscript5.dll: No such file or directory
D [24/Dec/2015:00:07:01 +0000] [Client 14] POST / HTTP/1.1
D [24/Dec/2015:00:07:01 +0000] cupsdSetBusyState: newbusy="Active clients", busy="Active clients"
D [24/Dec/2015:00:07:01 +0000] [Client 14] No authentication data provided.
D [24/Dec/2015:00:07:01 +0000] [Client 14] 2.0 Get-Subscriptions 1
D [24/Dec/2015:00:07:01 +0000] Get-Subscriptions ipp://localhost/
D [24/Dec/2015:00:07:01 +0000] Get-Subscriptions client-error-not-found: No subscriptions found.
D [24/Dec/2015:00:07:01 +0000] Returning IPP client-error-not-found for Get-Subscriptions (ipp://localhost/) from localhost
D [24/Dec/2015:00:07:01 +0000] cupsdSetBusyState: newbusy="Active clients", busy="Active clients"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: SERVER_NAME="localhost"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: REMOTE_USER="root"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: CUPS_VERSION="CUPS v1.6.2"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: TITLE="Administration"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: SERVER_NAME="localhost"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: REMOTE_USER="root"
D [24/Dec/2015:00:07:01 +0000] [CGI] cgiSetVariable: CUPS_VERSION="CUPS v1.6.2"
D [24/Dec/2015:00:07:01 +0000] Script header: Content-Type: text/html;charset=utf-8
D [24/Dec/2015:00:07:01 +0000] Script header:
D [24/Dec/2015:00:07:01 +0000] [Client 14] HTTP_WAITING Closing on EOF
D [24/Dec/2015:00:07:01 +0000] [Client 14] Closing connection.
D [24/Dec/2015:00:07:01 +0000] cupsdSetBusyState: newbusy="Active clients", busy="Active clients"
D [24/Dec/2015:00:07:01 +0000] cupsdSetBusyState: newbusy="Not busy", busy="Active clients"
D [24/Dec/2015:00:07:01 +0000] PID 6166 (/usr/local/lib/cups/cgi-bin/admin.cgi) exited with no errors.
D [24/Dec/2015:00:07:11 +0000] [Client 12] HTTP_WAITING Closing on EOF
D [24/Dec/2015:00:07:11 +0000] [Client 12] Closing connection.
D [24/Dec/2015:00:07:11 +0000] cupsdSetBusyState: newbusy="Not busy", busy="Not busy"
D [24/Dec/2015:00:07:11 +0000] [Client 12] Accepted from localhost:631 (IPv4)
D [24/Dec/2015:00:07:11 +0000] [Client 12] GET /admin/log/error_log? HTTP/1.1
D [24/Dec/2015:00:07:11 +0000] cupsdSetBusyState: newbusy="Active clients", busy="Not busy"
D [24/Dec/2015:00:07:11 +0000] [Client 12] Authorized as root using Basic
Any suggestions or comments are welcome.
« Last Edit: December 23, 2015, 08:40:05 PM by Juanito »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12065
Re: Epson L11O USB printer won't printed
« Reply #1 on: December 23, 2015, 08:41:27 PM »
code tags added to reduce the length of the post.

Did you start the cups daemon as root?

Offline Battheo

  • WikiUser
  • *
  • Posts: 4
Re: Epson L11O USB printer won't printed
« Reply #2 on: December 24, 2015, 02:11:26 AM »
Yes , I  have started cups daemon as root from my bootlocal.sh.
newbielink:http://wiki.tinycorelinux.net/wiki:printer_setup_using_cups [nonactive]

I have found that with google : "In cups 1.5 & 1.6, group write permissions for filters and backends have been disabled due to security reasons (release notes)."

I don't have any idea  :-[

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12065
Re: Epson L11O USB printer won't printed
« Reply #3 on: December 24, 2015, 02:20:40 AM »
where did you get the epson printer driver from?

Offline Battheo

  • WikiUser
  • *
  • Posts: 4
Re: Epson L11O USB printer won't printed
« Reply #4 on: December 24, 2015, 06:15:10 AM »
newbielink:http://openprinting.org/printers [nonactive] --> epson-inkjet-printer-201207w_1.0.0-1lsb3.2_i386.deb
I have already used successfully this driver on ubuntu and puppy linux.
« Last Edit: December 24, 2015, 06:16:48 AM by Battheo »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12065
Re: Epson L11O USB printer won't printed
« Reply #5 on: December 24, 2015, 07:12:44 AM »
If you run ldd on the various components:

epson_inkjet_printer_filter
libEpson_201207w.MT.so.1.0.0
libEpson_201207w.so.1.0.0

..do you see any errors?

Offline Battheo

  • WikiUser
  • *
  • Posts: 4
Re: Epson L11O USB printer won't printed
« Reply #6 on: December 24, 2015, 07:57:19 AM »
Yes,  errors: "cannot open shared object file: No such file or directory"