WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Internet isn't working after usb boot on micro core.  (Read 1667 times)

Offline apuboard

  • WikiUser
  • *
  • Posts: 30
Internet isn't working after usb boot on micro core.
« on: November 16, 2015, 12:10:06 AM »
So I booted the Micro Core Linux on an APU. Now, I was trying to install it on the SSD with tc-install but my internet doesn't work. How do I have to troubleshoot.
This is the output I got for ifconfig:
tc@box:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0D:B9:3E:D1:F4
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Or do you have other possiblities to install the micro core from usb?

 

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Internet isn't working after usb boot on micro core.
« Reply #1 on: November 16, 2015, 05:14:44 AM »
Use tinycore or coreplus.  They contain the installer.

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 6905
Re: Internet isn't working after usb boot on micro core.
« Reply #2 on: November 16, 2015, 05:22:34 AM »
Hi apuboard
You don't have an IP address assigned. Create a script called  eth0.sh  and save it in  /opt
Code: [Select]
#!/bin/sh
pkill udhcpc
ifconfig eth0 192.168.1.30 netmask 255.255.255.0 broadcast 192.168.1.255 up
route add default gw 192.168.1.1
echo nameserver 68.237.161.12 > /etc/resolv.conf
echo nameserver 71.243.0.12 >> /etc/resolv.conf
Change the addresses to values suitable for your environment, then:
Code: [Select]
chmod 775 /opt/eth0.sh
sudo /opt/eth0.sh
Then run  ifconfig  again and see if it has an IP address assigned. You are running a wired connection, not wireless, right?