WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Gnumeric and Abiword do not start  (Read 4840 times)

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11107
Re: Gnumeric and Abiword do not start
« Reply #15 on: November 07, 2015, 01:03:48 AM »
The culprit was wv - now reposted.

Since both abiword and gnumeric work without gnome-icon-theme, I believe it should be an optional dep.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Gnumeric and Abiword do not start
« Reply #16 on: November 07, 2015, 02:59:14 AM »
Thanks. Please see attached screenshots, not sure i would call this desirable. Does it work? Sort of, if you're patient enough to wait for the hover text to determine which *icon* is which. Maybe the info files for these extensions could at least make mention of optionally loading gnome-icon-theme.tcz to get functional icons.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11107
Re: Gnumeric and Abiword do not start
« Reply #17 on: November 07, 2015, 03:41:18 AM »
comment added to abiword info file

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Gnumeric and Abiword do not start
« Reply #18 on: November 07, 2015, 03:51:49 AM »
Thanks Juanito. Will make it easier for users like me figure out why something doesn't quite look right.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Gnumeric and Abiword do not start
« Reply #19 on: November 07, 2015, 06:25:07 AM »
Rebooted, Abiword fails to launch.
It really does require libffi5.tcz, once loaded launches fine.

Code: [Select]
tc@box:~$ tce-load -i abiword
harfbuzz.tcz: OK
libEGL.tcz: OK
cairo.tcz: OK
pango.tcz: OK
liblzma.tcz: OK
libtiff.tcz: OK
gdk-pixbuf2.tcz: OK
dbus.tcz: OK
atk.tcz: OK
at-spi2-core.tcz: OK
at-spi2-atk.tcz: OK
libxml2.tcz: OK
shared-mime-info.tcz: OK
gtk3.tcz: OK
libxslt.tcz: OK
bzip2-lib.tcz: OK
libgsf.tcz: OK
wv.tcz: OK
libcroco.tcz: OK
librsvg.tcz: OK
fribidi.tcz: OK
abiword.tcz: OK
tc@box:~$ abiword
abiword: error while loading shared libraries: libffi.so.5: cannot open shared object file: No such file or directory

Code: [Select]
tc@box:/usr/local/bin$ ldd abiword
        linux-gate.so.1 (0xb775c000)
        libabiword-3.0.so => /usr/local/lib/libabiword-3.0.so (0xb71e8000)
        libfribidi.so.0 => /usr/local/lib/libfribidi.so.0 (0xb71d2000)
        libwv-1.2.so.4 => /usr/local/lib/libwv-1.2.so.4 (0xb7161000)
        libgsf-1.so.114 => /usr/local/lib/libgsf-1.so.114 (0xb712e000)
        libbz2.so.1.0 => /usr/local/lib/libbz2.so.1.0 (0xb7121000)
        libxslt.so.1 => /usr/local/lib/libxslt.so.1 (0xb70f2000)
        libgtk-3.so.0 => /usr/local/lib/libgtk-3.so.0 (0xb6bac000)
        libgdk-3.so.0 => /usr/local/lib/libgdk-3.so.0 (0xb6b38000)
        libatk-1.0.so.0 => /usr/local/lib/libatk-1.0.so.0 (0xb6b1a000)
        libcairo-gobject.so.2 => /usr/local/lib/libcairo-gobject.so.2 (0xb6b13000)
        librsvg-2.so.2 => /usr/local/lib/librsvg-2.so.2 (0xb6aea000)
        libpangocairo-1.0.so.0 => /usr/local/lib/libpangocairo-1.0.so.0 (0xb6adf000)
        libpangoft2-1.0.so.0 => /usr/local/lib/libpangoft2-1.0.so.0 (0xb6ace000)
        libharfbuzz.so.0 => /usr/local/lib/libharfbuzz.so.0 (0xb6a96000)
        libpango-1.0.so.0 => /usr/local/lib/libpango-1.0.so.0 (0xb6a52000)
        libgthread-2.0.so.0 => /usr/local/lib/libgthread-2.0.so.0 (0xb6a50000)
        libcroco-0.6.so.3 => /usr/local/lib/libcroco-0.6.so.3 (0xb6a25000)
        libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0xb68e9000)
        liblzma.so.5 => /usr/local/lib/liblzma.so.5 (0xb68c7000)
        libgdk_pixbuf-2.0.so.0 => /usr/local/lib/libgdk_pixbuf-2.0.so.0 (0xb68ae000)
        libgio-2.0.so.0 => /usr/local/lib/libgio-2.0.so.0 (0xb6759000)
        libgmodule-2.0.so.0 => /usr/local/lib/libgmodule-2.0.so.0 (0xb6756000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb6742000)
        libgobject-2.0.so.0 => /usr/local/lib/libgobject-2.0.so.0 (0xb66f8000)
        libffi.so.6 => /usr/local/lib/libffi.so.6 (0xb66f1000)
        libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0xb65cd000)
        libcairo.so.2 => /usr/local/lib/libcairo.so.2 (0xb6518000)
        libpixman-1.so.0 => /usr/local/lib/libpixman-1.so.0 (0xb6497000)
        libEGL.so.1 => /usr/local/lib/libEGL.so.1 (0xb647d000)
        libxcb-xfixes.so.0 => /usr/local/lib/libxcb-xfixes.so.0 (0xb6477000)
        libxcb-shape.so.0 => /usr/local/lib/libxcb-shape.so.0 (0xb6474000)
        libgbm.so.1 => /usr/local/lib/libgbm.so.1 (0xb646a000)
        libudev.so.0 => /usr/local/lib/libudev.so.0 (0xb645e000)
        libpng16.so.16 => /usr/local/lib/libpng16.so.16 (0xb6438000)
        libxcb-shm.so.0 => /usr/local/lib/libxcb-shm.so.0 (0xb6434000)
        libxcb-render.so.0 => /usr/local/lib/libxcb-render.so.0 (0xb642d000)
        libXrender.so.1 => /usr/local/lib/libXrender.so.1 (0xb6426000)
        libGL.so.1 => /usr/local/lib/libGL.so.1 (0xb63b6000)
        libglapi.so.0 => /usr/local/lib/libglapi.so.0 (0xb639f000)
        libXdamage.so.1 => /usr/local/lib/libXdamage.so.1 (0xb639b000)
        libXfixes.so.3 => /usr/local/lib/libXfixes.so.3 (0xb6397000)
        libX11-xcb.so.1 => /usr/local/lib/libX11-xcb.so.1 (0xb6395000)
        libxcb-glx.so.0 => /usr/local/lib/libxcb-glx.so.0 (0xb6385000)
        libxcb-dri2.so.0 => /usr/local/lib/libxcb-dri2.so.0 (0xb6381000)
        libXxf86vm.so.1 => /usr/local/lib/libXxf86vm.so.1 (0xb637c000)
        libXext.so.6 => /usr/local/lib/libXext.so.6 (0xb636f000)
        libdrm.so.2 => /usr/local/lib/libdrm.so.2 (0xb6366000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb634c000)
        librt.so.1 => /lib/librt.so.1 (0xb6344000)
        libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0xb6317000)
        libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0xb62fa000)
        libfreetype.so.6 => /usr/local/lib/libfreetype.so.6 (0xb6282000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb6271000)
        libX11.so.6 => /usr/local/lib/libX11.so.6 (0xb6178000)
        libxcb.so.1 => /usr/local/lib/libxcb.so.1 (0xb6160000)
        libXau.so.6 => /usr/local/lib/libXau.so.6 (0xb615d000)
        libXdmcp.so.6 => /usr/local/lib/libXdmcp.so.6 (0xb6158000)
        libdl.so.2 => /lib/libdl.so.2 (0xb6154000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb6093000)
        libjpeg.so.62 => /usr/local/lib/libjpeg.so.62 (0xb6044000)
        libm.so.6 => /lib/libm.so.6 (0xb6005000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb5ff0000)
        libc.so.6 => /lib/libc.so.6 (0xb5ec3000)
        libffi.so.5 => not found
        libXinerama.so.1 => /usr/local/lib/libXinerama.so.1 (0xb5ebf000)
        libXrandr.so.2 => /usr/local/lib/libXrandr.so.2 (0xb5eb7000)
        libXcursor.so.1 => /usr/local/lib/libXcursor.so.1 (0xb5eaf000)
        libxcb-dri3.so.0 => /usr/local/lib/libxcb-dri3.so.0 (0xb5eac000)
        libxcb-present.so.0 => /usr/local/lib/libxcb-present.so.0 (0xb5eaa000)
        libxcb-randr.so.0 => /usr/local/lib/libxcb-randr.so.0 (0xb5e9f000)
        libxcb-sync.so.1 => /usr/local/lib/libxcb-sync.so.1 (0xb5e9a000)
        libxshmfence.so.1 => /usr/local/lib/libxshmfence.so.1 (0xb5e98000)
        libXi.so.6 => /usr/local/lib/libXi.so.6 (0xb5e8d000)
        libXcomposite.so.1 => /usr/local/lib/libXcomposite.so.1 (0xb5e8a000)
        libatk-bridge-2.0.so.0 => /usr/local/lib/libatk-bridge-2.0.so.0 (0xb5e69000)
        libatspi.so.0 => /usr/local/lib/libatspi.so.0 (0xb5e4e000)
        libSM.so.6 => /usr/local/lib/libSM.so.6 (0xb5e48000)
        libuuid.so.1 => /lib/libuuid.so.1 (0xb5e44000)
        libICE.so.6 => /usr/local/lib/libICE.so.6 (0xb5e31000)
        libdbus-1.so.3 => /usr/local/lib/libdbus-1.so.3 (0xb5dfe000)
        /lib/ld-linux.so.2 (0xb775f000)

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11107
Re: Gnumeric and Abiword do not start
« Reply #20 on: November 07, 2015, 06:43:23 AM »
Did you update the wv extension?

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: Gnumeric and Abiword do not start
« Reply #21 on: November 07, 2015, 02:35:03 PM »
Thanks Juanito. Updated wv, all good.

Offline Bams

  • WikiUser
  • *
  • Posts: 6
Re: Gnumeric and Abiword do not start
« Reply #22 on: November 21, 2015, 01:03:06 AM »
Hi
Im having same concern wiyh GNUMERIC, with same error message
such as plenty of "** (gnumeric:2746): CRITICAL **: go_conf_add_monitor: assertion 'node || key' failed".
librsvg updated & checked ok
libxcb updated & checked ok
wv updated & checked ok
where to dig further ?
(on my box it was working with tc 4x and 5x)