WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: laptop energy-saving managment  (Read 2324 times)

Offline Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 5319
Re: laptop energy-saving managment
« Reply #15 on: October 31, 2015, 03:40:11 PM »
Hi alexo
/tmp/tcloop/  is where extensions get mounted. Extensions are read only file systems and can not be modified.

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4231
Re: laptop energy-saving managment
« Reply #16 on: October 31, 2015, 09:44:30 PM »
Just put your config file in /opt/.filetool.lst , not the whole directory.

Offline alexo

  • Jr. Member
  • **
  • Posts: 54
Re: laptop energy-saving managment
« Reply #17 on: November 01, 2015, 03:59:37 AM »
ok, so I desume that in .optfiletoo.lst there must be files only.
however laptop-tools is not working on my old machine.

Even if I have  /usr/local/etc/init.d/laptop-mode start in my bootlocal.sh nothing happens.
I'll do without it.

stupid question: if /tmp/tclocal/ is where extensions are loaded, config files for the same of them shouldn't be equal to each other? why I have two different files?

for completeness' sake these are my bootlocal.sh and .filetool.lst files:

bootlocal.sh

Code: [Select]
#!/bin/sh
# put other system startup commands here
loadkmap < /usr/share/kmap/qwerty/it.kmap
/usr/local/etc/init.d/cups start
/usr/local/bin/xscreensaver -nosplash
/usr/local/etc/init.d/laptop-mode start

.filetool.lst:

Code: [Select]
opt
home
etc/shadow
usr/local/etc/cups/printers.conf
usr/local/etc/laptop-mode/laptop-mode.conf
usr/local/etc/laptop-mode/lm-profiler.conf


I have also a problem with xscreensaver.
If I start the command /usr/local/bin/xscreensaver -nosplash manually, the screen saver starts regularly but with this message on the CL

xscreensaver: 12:02:56: couldn't get password of "tc"
xscreensaver: 12:02:56: locking is disabled (error getting password).
xscreensaver: 12:02:56: does xscreensaver need to be setuid?  consult the manual

If I add this line in bootlocal.sh the screen saver doesn't start at all.

do you think have I to start a new topic for that problem?
thank you
« Last Edit: November 01, 2015, 04:10:21 AM by alexo »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9478
Re: laptop energy-saving managment
« Reply #18 on: November 01, 2015, 04:14:04 AM »
X apps should not be started in bootlocal.sh, X is not yet up. Start them in .X.d (see our FAQ link on the top).
The only barriers that can stop you are the ones you create yourself.

Offline alexo

  • Jr. Member
  • **
  • Posts: 54
Re: laptop energy-saving managment
« Reply #19 on: November 02, 2015, 02:40:38 AM »
now xscreensaver starts.
For those like me, that don't know how to do it, I added a file named xscreensaver in the .X.d folder in which I wrote the command: xscreensaver -nosplash &.

Thank you.

I cannot still understand why laptop-tools don't work.




Offline alexo

  • Jr. Member
  • **
  • Posts: 54
Re: laptop energy-saving managment
« Reply #20 on: November 19, 2015, 08:09:08 AM »
Hi,
sorry for resuming an old topic, but I've tryed many laptop-mode.conf settings without success.
Can anyone please post here the laptop-mode.conf file that correctly suspend a laptop?

thank you all

Offline alexo

  • Jr. Member
  • **
  • Posts: 54
Re: laptop energy-saving managment
« Reply #21 on: November 19, 2015, 08:50:03 AM »
This is what I get when enabling laptop-mode

Code: [Select]
tc@box:~$ sudo /usr/local/etc/init.d/acpid start
tc@box:~$  sudo /usr/local/etc/init.d/laptop-mode start
/usr/local/sbin/laptop_mode: /usr/local/share/laptop-mode-tools/modules/dpms-standby: line 65: w: not found
/usr/local/sbin/laptop_mode: /usr/local/share/laptop-mode-tools/modules/ethernet: line 156: mii-tool: not found
/usr/local/sbin/laptop_mode: /usr/local/share/laptop-mode-tools/modules/hal-polling: line 41: hal-disable-polling: not found
failed - udev not active?
failed - udev not active?
failed - udev not active?
failed - udev not active?
failed - udev not active?
failed - udev not active?
failed - udev not active?
failed - udev not active?
/usr/local/sbin/laptop_mode: /usr/local/share/laptop-mode-tools/modules/terminal-blanking: line 31: setterm: not found
Laptop mode
enabled, not active
tc@box:~$

Offline drunk

  • WikiUser
  • *
  • Posts: 6
Re: laptop energy-saving managment
« Reply #22 on: January 25, 2017, 11:08:27 PM »
Aloha!

'slash'-symbol missing in package 'laptop-mode-tools.tcz' v1.53 ; tested on TCL v7.2 x86

Code: [Select]
tc@box:~$ cat /usr/local/share/laptop-mode-tools/files/acpi/events/lm_ac_adapter | grep action
action=/usr/localetc/acpi/actions/lm_ac_adapter.sh

also please add some magic in case...esac structure to support kernel 4.2

Code: [Select]
Unhandled kernel version: 4.2 ('uname -r' = '4.2.9-tinycore')
thanks in advance!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 9294
Re: laptop energy-saving managment
« Reply #23 on: January 25, 2017, 11:39:10 PM »
Thanks - updated version posted