WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Xserver doesn't start.  (Read 2881 times)

Offline Cyberium

  • WikiUser
  • *
  • Posts: 8
Xserver doesn't start.
« on: October 01, 2015, 06:50:41 PM »
I'm using CorePlus via a USB and none of my boot codes seem to be working and in the text more doing xstart tells me command not found

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Xserver doesn't start.
« Reply #1 on: October 01, 2015, 07:03:13 PM »
How did you install to USB?
Show us your boot codes.

Offline Cyberium

  • WikiUser
  • *
  • Posts: 8
Re: Xserver doesn't start.
« Reply #2 on: October 01, 2015, 08:06:29 PM »
Well, I used YUMI to install the CorePlus Iso onto my usb as I also have a few other live distros on the usb.

Using the default boot codes for the boot option of Boot Core with X/GUI and Wifi extensions

The screen goes past the setting language to C
Then says skipping loading extensions as per command line.

Then it just brings me to a CLI and the startx command isn't found.

In the boot options I put in either tinycore xsetup, xsetup, core xsetup, plus xsetup, tc xsetup

And they still bring me to the CLI

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Xserver doesn't start.
« Reply #3 on: October 01, 2015, 09:01:44 PM »
That won't work.
Use dd to copy the ISO to the raw thumb drive.
Then boot the thumb drive and use the provided installer to do a normal install to another thumb drive.

Offline Cyberium

  • WikiUser
  • *
  • Posts: 8
Re: Xserver doesn't start.
« Reply #4 on: October 01, 2015, 09:07:29 PM »
So I won't be able to use multiple distros if I have tinycore installed in a usb

Offline Cyberium

  • WikiUser
  • *
  • Posts: 8
Re: Xserver doesn't start.
« Reply #5 on: October 01, 2015, 09:21:53 PM »
Boot code default for Boot Core with X/GUI (TinyCore) + WiFi extension
Code: [Select]
/multiboot/CorePlus-current/boot/vmlinuz initrd=/multiboot/CorePlus-current/boot/core.gz log level=3 cde showapps lst=xwbase.lst base desktop=flwm_topside

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Xserver doesn't start.
« Reply #6 on: October 01, 2015, 09:27:53 PM »
If you already have a bootloader on the USB drive, create a boot stanza that loads vmlinuz and the core.gz initrd.
Then create a tce directory on the root filesystem on the USB.
Boot core and run "tce-load -iw Xvesa Xprogs flwm_topside aterm wbar"
Then run startx.
On reboot X should start automatically.

Offline Cyberium

  • WikiUser
  • *
  • Posts: 8
Re: Xserver doesn't start.
« Reply #7 on: October 01, 2015, 11:08:29 PM »
This is the SYSLINUX Bootloader entry i have for CorePlus

Code: [Select]
#start CorePlus-current
LABEL CorePlus-current
MENU LABEL CorePlus-current
MENU INDENT 1
CONFIG /multiboot/CorePlus-current/boot/isolinux/isolinux.cfg
APPEND /multiboot/CorePlus-current/boot/isolinux
#end CorePlus-current

And This is the entry in the CorePlus boot menu itself
Code: [Select]
LABEL cxw
MENU LABEL Boot Core with X/GUI (TinyCore) + Wifi Extension.
TEXT HELP
Boot Core with flwm_topside with X/GUI and the Wifi Extension.
Extensions are loaded mount mode. Boot media is not removable.
Use TAB to edit desktop= to boot to alternate window manager.
ENDTEXT
kernel /multiboot/CorePlus-current/boot/vmlinuz
APPEND initrd=/multiboot/CorePlus-current/boot/core.gz loglevel=3 cde showapps lst=xwbase.lst base desktop=flwm_topside
« Last Edit: October 01, 2015, 11:12:31 PM by Cyberium »

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: Xserver doesn't start.
« Reply #8 on: October 02, 2015, 12:04:18 AM »
Boot code  cde  is used for CD-ROM only. Remove it from your boot codes and rename the  cde  directory to  tce .
Download a copy and keep it handy: Core book ;)

Offline Cyberium

  • WikiUser
  • *
  • Posts: 8
Re: Xserver doesn't start.
« Reply #9 on: October 02, 2015, 01:10:12 AM »
cde removed and renamed to tce

What do I do in terms of tce-load as I do not have a Ethernet connection

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11063
Re: Xserver doesn't start.
« Reply #10 on: October 02, 2015, 04:19:45 AM »
You find a machine that does have an Internet connection and download the required *tcz, *tcz.dep and *tcz.md5.txt from:

http://repo.tinycorelinux.net/6.x/x86/tcz/

..and then copy them to tce/optional on your machine.

Offline Cyberium

  • WikiUser
  • *
  • Posts: 8
Re: Xserver doesn't start.
« Reply #11 on: October 02, 2015, 04:21:47 AM »
You find a machine that does have an Internet connection and download the required *tcz, *tcz.dep and *tcz.md5.txt from:

http://repo.tinycorelinux.net/6.x/x86/tcz/

Do I have to have my tce folder in the root of my flash drive or does it auto detect its location based on the location of the initrd?

I ask this as I have multiple live distros stored on my usb which are configured via syslinux as a multiboot.

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Xserver doesn't start.
« Reply #12 on: October 02, 2015, 06:04:24 AM »
Remove "base" from your boot options.  It tells it not to load extensions.
Change he line to read:
APPEND initrd=/multiboot/CorePlus-current/boot/core.gz showapps

You can copy the "cde" directory from the ISO to the thumb drive, and rename it "tce"
Then you can edit your /tce/onboot.lst to contain:

Xvesa.tcz
Xprogs.tcz
aterm.tcz
wbar.tcz
flwm_topside.tcz

Offline Lee

  • Hero Member
  • *****
  • Posts: 645
    • My Core wiki user page
Re: Xserver doesn't start.
« Reply #13 on: October 02, 2015, 09:15:22 AM »
Quote
Do I have to have my tce folder in the root of my flash drive or does it auto detect its location based on the location of the initrd?

* The running system has no reliable way to determine from where the kernel and initrd were loaded but...

* it will scan for a tce directory in the root of any available fiilesystem, which can be slow and prone to finding the wrong tce directory if there is more than one match, -but-...

* you can specify a tce clause in the boot loader (in the APPEND line) that specifies not to scan and where to find the desired tce directory.  Something like this:

Code: [Select]
tce=LABEL=apollo80_a1_17/boot/core4.7.7/tce

where you would replace apollo80_a1_17 with the filesystem label of your flash drive and replace /boot/core4.7.7/tce with the path from the root of the flash drive to the actual tce directory.

You might also want to throw in

Code: [Select]
waitusb=30:LABEL=apollo80_a1_17
again using the FS label appropriate to your flash drive (assuming it is a USB device).
32 bit core4.7.7, Xprogs, Xorg-7.6, wbar, jwm  |  - Testing -
PPR, data persistence through filetool.sh          |  32 bit core 8.0 alpha 1
USB Flash drive, one partition, ext2, grub4dos  | Otherwise similar

Offline Cyberium

  • WikiUser
  • *
  • Posts: 8
Re: Xserver doesn't start.
« Reply #14 on: October 02, 2015, 02:06:16 PM »
Got it working through tweakin with the boot codes using UUIDs and a combination of your advice,

Thanks guys, Topic Closed.