WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: dCore-vivid  (Read 2464 times)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9196
dCore-vivid
« Reply #15 on: June 27, 2015, 04:19:16 PM »
For the file in package udisks2, /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy, those lines are set to auth_admin in Trusty just like in Vivid.  Was mounting successful in trusty with auth_admin in those fields?

I am working on a startup script to change them to yes, I am just curious what the difference might be.

« Last Edit: July 02, 2015, 01:43:15 PM by Jason W »

Offline jls

  • Hero Member
  • *****
  • Posts: 1979
    • Core17
Re: ub-dCore-vivid
« Reply #16 on: June 28, 2015, 01:40:32 AM »
Hi
In vivid it was also working with modification as already written in the past in this forum.
in the URL below are the 2 files
http://ge.tt/5B5oDKJ2
dCore user

Offline jls

  • Hero Member
  • *****
  • Posts: 1979
    • Core17
Re: ub-dCore-vivid
« Reply #17 on: June 28, 2015, 03:08:56 AM »
but I want to add that to me this policykit modifications seems like an hack, indicating that something is wrong elsewhere, consolekit maybe?
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9196
Re: ub-dCore-vivid
« Reply #18 on: June 28, 2015, 05:30:44 AM »
Yeah, I am wondering why the mod is needed in vivid and not in trusty.  Which sounds like it is somethig else than that file mentioned, since essentially those files are the same in trusty and vivid.  I will look into it more.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9196
Re: ub-dCore-vivid
« Reply #19 on: June 28, 2015, 05:47:59 AM »
Please re-import and test.  I have added the command "pam-auth-update --force" to the startup script of udisks and udisks2.


Offline jls

  • Hero Member
  • *****
  • Posts: 1979
    • Core17
Re: ub-dCore-vivid
« Reply #20 on: June 28, 2015, 05:54:04 AM »
Ok i'll test. i just want to correct my previous post. The mod was also used in trusty
dCore user

Offline jls

  • Hero Member
  • *****
  • Posts: 1979
    • Core17
Re: ub-dCore-vivid
« Reply #21 on: June 28, 2015, 01:42:15 PM »
Hi
still cannot mount without the hack on the policy file. Strange that the following command works without the modification:
Code: [Select]
jls@box:~$ udisksctl mount -b /dev/sdb1
==== AUTHENTICATING FOR org.freedesktop.udisks2.filesystem-mount-other-seat ===
Authentication is required to mount Verbatim STORE N GO (/dev/sdb1)
Authenticating as: root
==== AUTHENTICATION COMPLETE ===
Mounted /dev/sdb1 at /mnt/sdb1.
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9196
Re: ub-dCore-vivid
« Reply #22 on: June 29, 2015, 04:34:48 PM »
ub-dCore-vivid updated to support the use of the /cde directory on an ISO image.  Details are in this thread:

http://forum.tinycorelinux.net/index.php/topic,18527.msg113514.html#msg113514

Offline jls

  • Hero Member
  • *****
  • Posts: 1979
    • Core17
Re: ub-dCore-vivid
« Reply #23 on: July 01, 2015, 09:54:56 AM »
Hi. Waitusb boot code it seems not to be considered infact the message doesn't appear on the screen during boot
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9196
Re: ub-dCore-vivid
« Reply #24 on: July 02, 2015, 05:59:21 AM »
Ok, I will look into that today.

Oh, are we seeing this issue also in ub-dCore-trusty or ub-dCore-utopic?  I will check them out as I remember a udev rule that had to be in /etc/udev/rules.d.
« Last Edit: July 02, 2015, 06:06:34 AM by Jason W »

Offline jls

  • Hero Member
  • *****
  • Posts: 1979
    • Core17
Re: ub-dCore-vivid
« Reply #25 on: July 02, 2015, 07:54:03 AM »
In dCore-trusty waitusb works
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9196
Re: ub-dCore-vivid
« Reply #26 on: July 02, 2015, 09:51:48 AM »
I think I have it fixed, I tested all the ports besides dCore-wheezy.  Uploaded.  Note the name change to dCore-vivid. 

Offline jls

  • Hero Member
  • *****
  • Posts: 1979
    • Core17
Re: ub-dCore-vivid
« Reply #27 on: July 02, 2015, 12:50:13 PM »
yes Jason, fixed ;D thanks
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9196
Re: dCore-vivid
« Reply #28 on: July 02, 2015, 01:45:05 PM »
Great!

The file that needs to exist is /etc/udev/rules.d/60-persistent-storage.rules, somehow did not get put in.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9196
Re: dCore-vivid
« Reply #29 on: July 02, 2015, 03:28:15 PM »
dCore-vivid has been moved to release.