WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: dCore-vivid  (Read 2972 times)

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9250
dCore-vivid
« on: June 03, 2015, 02:30:43 PM »
Ubuntu Vivid Vervet is available, I will commence work on a ub-dCore-vivid.  ub-dCore-trusty is based on a long term release and will remain.
« Last Edit: July 02, 2015, 01:45:32 PM by Jason W »

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9250
Re: ub-dCore-vivid
« Reply #1 on: June 10, 2015, 01:32:12 PM »
ub-dCore-vivid is now released to the release candidate status.   All seems to work well here, let me know if anything is not.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9250
Re: ub-dCore-vivid
« Reply #2 on: June 17, 2015, 07:55:56 AM »
Uploaded a new release candidate.  References of loadsce have been changed to sce-load in /etc/init.d/tc-config.


Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9250
Re: ub-dCore-vivid
« Reply #3 on: June 22, 2015, 05:45:05 AM »
If I hear no issues regarding ub-dCore-vivid I will move to release in the coming days.

Offline jls

  • Hero Member
  • *****
  • Posts: 1997
    • Core17
Re: ub-dCore-vivid
« Reply #4 on: June 22, 2015, 07:35:27 AM »
trying today to move from trysty to vivid:
  • boot option  waitusb=5:UUID= doesn't work, waitusb=5 only works
  • during boot while loading extension I see this error:
    error opening usb device 'descriptors' file
  • X doesn't start is sayng that libdrm.so.2 is missing, importing it fixes the problem
  • connmand doesn't start:
    Couldn't load target `standard':No such file or directory
    googling for the error I found:
    Looks like you miss the support for the xtables in kernel's netfilter.
    http://comments.gmane.org/gmane.linux.network.connman/16197
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9250
Re: ub-dCore-vivid
« Reply #5 on: June 22, 2015, 09:23:59 AM »
Ok, I will look into the issues.  There was some udev and other updates that meant more deps to bring in, perhaps something is missing.


Offline jls

  • Hero Member
  • *****
  • Posts: 1997
    • Core17
Re: ub-dCore-vivid
« Reply #6 on: June 23, 2015, 05:20:28 AM »
    Hi
    some more differences and bugs since trusty to vivid upgrade:
    • X is on the first console
    • wifi ipw2200 doesn't work: tried wifi.sh since connman doesn't start, the AP is showed but after inserting the passphrase it doesn't get the ip, while an rtl8187 based wifi works
    • mount/unmount via enlightenment doesn't work

Thanks
dCore user

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9518
Re: ub-dCore-vivid
« Reply #7 on: June 23, 2015, 09:22:49 AM »
I think the X-on-first-tty is intentional, because it speeds up boot by a tiny amount when you don't change the tty.
The only barriers that can stop you are the ones you create yourself.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9250
Re: ub-dCore-vivid
« Reply #8 on: June 24, 2015, 08:24:24 AM »
On the connman and netfilter issue, below is the part of the README that deals with what needs to be enabled in the kernel config, and all exists in the current kernel build as either builtin or modules:

Code: [Select]
Kernel configuration
====================
In order to support tethering, the following kernel configuration options
need to be enabled either as modules (m) or builtin (y):
CONFIG_BRIDGE
CONFIG_IP_NF_TARGET_MASQUERADE
In order to enable CONFIG_IP_NF_TARGET_MASQUERADE, the following options need
to be enabled also as modules (m) or builtin (y):
CONFIG_NETFILTER
CONFIG_NF_CONNTRACK_IPV4
CONFIG_NF_NAT_IPV4

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9250
Re: ub-dCore-vivid
« Reply #9 on: June 24, 2015, 09:46:43 AM »
Was X on a different console with ub-dCore-trusty?  Nothing has been changed in the base files that would cause a different behavior.

As for mount, I truecrypt can't set up a loop device though I only have one loop mounted.  So something affecting mounting is broken somewhere since the kernel has not changed nor the truecrypt package.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9250
Re: ub-dCore-vivid
« Reply #10 on: June 24, 2015, 09:55:07 AM »
The mount issue with truecrypt was resolved by adding libsmartcols1 to the deps of the mount package.

I have a hunch it will fix the mount issue in enlightenment as well.   Please re-import and test.

Offline jls

  • Hero Member
  • *****
  • Posts: 1997
    • Core17
Re: ub-dCore-vivid
« Reply #11 on: June 26, 2015, 01:44:09 AM »
Hi
I forgot to say that I'm using "multivt" boot option. On "trusty" X is on tty7 while on "vivid" is on the first console.
dCore user

Offline jls

  • Hero Member
  • *****
  • Posts: 1997
    • Core17
Re: ub-dCore-vivid
« Reply #12 on: June 26, 2015, 02:25:58 AM »
Hi
re-imported mount and after changing
<allow_any>
<allow_inactive>
<allow_active>
from auth_admin to yes
in /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy
section
org.freedesktop.udisks2.filesystem-mount-other-seat

enlightenment is able to mount

dCore user

Offline jls

  • Hero Member
  • *****
  • Posts: 1997
    • Core17
Re: ub-dCore-vivid
« Reply #13 on: June 27, 2015, 04:24:57 AM »
Hi
connman works installing iptables, maybe it should be added as dep.
Thanks
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9250
Re: ub-dCore-vivid
« Reply #14 on: June 27, 2015, 08:48:22 AM »
Great!

I have read that newer Xorg builds use the login tty as it's own, I am not well experienced in the Xorg/tty subject but it seem like it is expected behavior.   Is it causing any issues?

I will see if I can add some startup script function to take care of the  /usr/share/polkit-1/actions/org.freedesktop.udisks2.policy file.