WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Network Ports are not detected - Intel® I210IT GbE LAN  (Read 6794 times)

Offline jim.software

  • WikiUser
  • *
  • Posts: 17
Network Ports are not detected - Intel® I210IT GbE LAN
« on: June 01, 2015, 04:46:02 PM »
My computer (NISE 2400) has two Intel® I210IT GbE LAN ports.  I cannot get TinyCore Plus 6.3 (or TinyCore) to detect these.  The only interface available is "lo".  Does anyone have any advice or suggestions?

FYI - My original TinyCore OS is 4.6.1 and it cannot detect the LAN ports either.

Thanks in advance.
Jim

Online Rich

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 7030
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #1 on: June 01, 2015, 08:19:59 PM »
Hi jim.software
It's possible Tinycore doesn't currently have a driver for your hardware. You may have to compile it yourself, see:
https://downloadcenter.intel.com/download/13663/Network-Adapter-Driver-for-82575-6-82580-I350-and-I210-211-Based-Gigabit-Network-Connections-for-Linux-
A later version can be found here:
http://sourceforge.net/projects/e1000/files/igb%20stable/5.2.18/
« Last Edit: June 01, 2015, 08:22:17 PM by Rich »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10100
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #2 on: June 02, 2015, 01:58:40 AM »
We do ship the IGB driver in the base, but your card could be newer than our kernel. We'd need the pci id to check.
The only barriers that can stop you are the ones you create yourself.

Offline jim.software

  • WikiUser
  • *
  • Posts: 17
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #3 on: June 02, 2015, 08:48:34 AM »
Thanks for the info.  I'll try compiling a driver.

This is the info I have on the NIC:  (taken from a live DVD of Ubuntu)

ubuntu@ubuntu:~$ ethtool -i eth0
driver: igb
version: 5.2.15-k
firmware-version: 3.12, 0x800004fa
bus-info: 0000:01:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: no


ubuntu@ubuntu:~$ lspci | grep Ethernet
01:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection (rev 03)
02:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection (rev 03)


ubuntu@ubuntu:~$ sudo lshw -class network
  *-network               
       description: Ethernet interface
       product: I210 Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 03
       serial: 00:10:f3:4b:32:7b
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi msix pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=igb driverversion=5.2.15-k duplex=full firmware=3.12, 0x800004fa ip=172.16.6.236 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:16 memory:d0a00000-d0afffff ioport:d000(size=32) memory:d0b00000-d0b03fff memory:d0900000-d09fffff
  *-network
       description: Ethernet interface
       product: I210 Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth1
       version: 03
       serial: 00:10:f3:4b:32:7c
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi msix pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=igb driverversion=5.2.15-k firmware=3.12, 0x800004fa latency=0 link=no multicast=yes port=twisted pair
       resources: irq:17 memory:d0700000-d07fffff ioport:c000(size=32) memory:d0800000-d0803fff memory:d0600000-d06fffff


ubuntu@ubuntu:~$ lspci -v
01:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection (rev 03)
   Flags: bus master, fast devsel, latency 0, IRQ 16
   Memory at d0a00000 (32-bit, non-prefetchable) [size=1M]
   I/O ports at d000 [size=32]
   Memory at d0b00000 (32-bit, non-prefetchable) [size=16K]
   Expansion ROM at d0900000 [disabled] [size=1M]
   Capabilities: <access denied>
   Kernel driver in use: igb

02:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection (rev 03)
   Flags: bus master, fast devsel, latency 0, IRQ 17
   Memory at d0700000 (32-bit, non-prefetchable) [size=1M]
   I/O ports at c000 [size=32]
   Memory at d0800000 (32-bit, non-prefetchable) [size=16K]
   Expansion ROM at d0600000 [disabled] [size=1M]
   Capabilities: <access denied>
   Kernel driver in use: igb

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #4 on: June 02, 2015, 08:53:37 AM »
What is needed is the output of "lspci -nn | grep net".

Offline metalucid

  • WikiUser
  • *
  • Posts: 8
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #5 on: June 02, 2015, 08:58:39 AM »
i am also seeing (intermittent, I think) networking; my lshw shows the same as the OP;
PCI ID is 8086:1533.

i am using TinyCorePure64-6.3.iso, i boot with "core" option, plus "superuser", altho default
also gives no networking..

ifconfig -a does not show my I/F's.

Offline jim.software

  • WikiUser
  • *
  • Posts: 17
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #6 on: June 02, 2015, 09:00:31 AM »
Thanks for the help.

ubuntu@ubuntu:~$ lspci -nn | grep Ethernet
01:00.0 Ethernet controller [0200]: Intel Corporation I210 Gigabit Network Connection [8086:1533] (rev 03)
02:00.0 Ethernet controller [0200]: Intel Corporation I210 Gigabit Network Connection [8086:1533] (rev 03)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #7 on: June 02, 2015, 09:13:48 AM »
1533 is supported by module igb   ref: http://cateee.net/lkddb/web-lkddb/IGB.html

Offline metalucid

  • WikiUser
  • *
  • Posts: 8
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #8 on: June 02, 2015, 09:14:57 AM »
on Fed21 the module is igb, but if i try "modprobe igb", i get Unknown symbol, and dmesg says that symbol is "i2c_bit_add_bus".

Thanks in advance,
M

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11195
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #9 on: June 02, 2015, 09:38:04 AM »
is i2c-3.16.6-tinycore loaded?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10100
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #10 on: June 02, 2015, 09:48:29 AM »
Hm, we should probably move i2c-algo-bit to base from the i2c extension.
The only barriers that can stop you are the ones you create yourself.

Offline metalucid

  • WikiUser
  • *
  • Posts: 8
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #11 on: June 02, 2015, 10:32:10 AM »
ah! no...  i downloaded it; where in the FS shouild i put it (so it's loaded early) ?  The docs
seem unclear to me.

thanks!

Offline jim.software

  • WikiUser
  • *
  • Posts: 17
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #12 on: June 02, 2015, 10:48:14 AM »
I've been working with TinyCore 4.6.1.  Even after loading i2c-3.0.21-tinycore.tcz, I still get the same error when trying to modprobe igb, Unknown symbol, i2c_bit_add_bus.  I could be doing something wrong because all the kernel modules in i2c-3.0.21-tinycore.tcz en with *.gz.  i2c-algo-bit appears to be in the correct directory \usr\local\lib\modules\3.0.21-tinycore\kernel\drivers\i2c\algos\i2c-algo-bit.ko.gz, but I cannot modprobe it (error not in modules.dep) and I cannot insmod it because it does not like the gz extension.

I am going to switch to TinyCore 6.3 so that way we are all on the same page.  I'll let you know what I find.

Offline jim.software

  • WikiUser
  • *
  • Posts: 17
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #13 on: June 02, 2015, 11:17:07 AM »
Using TinyCore 6.3, I downloaded i2c-3.16.6-tinycore.tcz.

  Side track - This was not straightforward to do.  Went to http://tinycorelinux.net/downloads.html and clicked the "Browse TCZs" link.  This took me to a text page with no links for downloading.   I took a shot in the dark and appended the file name to the URL like this: http://tinycorelinux.net/6.x/x86/tcz/i2c-3.16.6-tinycore.tcz and pasted it into my browser; it worked!

I put the file in /mnt/sda1/tce/optional.
I edited onboot.lst and put i2c-3.16.6-tinycore.tcz right after glib2.tcz (about 1/3 of the way down the file).

Now it works!   
Thank you all for your help and support.

Now I'm going to try to bang my head some more and try to get TinyCore 4.6.1 up and running.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10100
Re: Network Ports are not detected - Intel® I210IT GbE LAN
« Reply #14 on: June 02, 2015, 11:20:07 AM »
Guys, please use the built-in tools (Apps and tce-load), they will save you much time.
The only barriers that can stop you are the ones you create yourself.