WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: How to disable usbfs from claiming device  (Read 3110 times)

Offline andyj

  • Hero Member
  • *****
  • Posts: 973
How to disable usbfs from claiming device
« on: February 07, 2015, 08:33:49 PM »
I have a USB NFC reader that works, but only if it is physically connected after I start my userspace program. If it's already attached, I need to unplug and plug it back into be seen. It's using libnfc so there aren't any device drivers involved. I've tried an assortment of udev rules but none have worked thus far. The error in dmesg originally looked like this which gave me a hint to my problem:

usb 1-1.3.1: usbfs: interface 0 claimed by usbfs while 'myProg' sets config #1

I added a udev rule so it doesn't say this anymore, but it still doesn't work. Any ideas?

Offline hal9king

  • WikiUser
  • *
  • Posts: 49
Re: How to disable usbfs from claiming device
« Reply #1 on: May 20, 2015, 05:10:39 PM »
Seen similar problems on other devices -- only solution I've heard of is to unplug and plug back in.  Sorry.
In science, we know ... what we don't know.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10693
Re: How to disable usbfs from claiming device
« Reply #2 on: May 21, 2015, 01:28:10 AM »
Your udev rule needs to be remastered in, not placed in backup.
The only barriers that can stop you are the ones you create yourself.