WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: rtcwake blank screen  (Read 3217 times)

Offline tinyuser2

  • WikiUser
  • *
  • Posts: 1
rtcwake blank screen
« on: March 25, 2015, 12:41:03 PM »
I am using core so no desktop GUI.  I run rtcwake from a script to sleep to memory for a period and then automatically wake.  That works.  However, it wakes up to a blank screen.  I cannot get it to turn the screen back on.

rtcwake states:

Some PC systems can't currently exit sleep states such as mem using only the kernel code accessed by this driver. They need help from userspace code to make the framebuffer work again.

I have tried video_post.  I have tried cat'ing the video card state under /proc/bus/pci/xx/xx.x to a file, sleeping, and cat'ing it back.
xset dpms force on does not work since I am not running x.

Any suggestions for waking up the display or another method for sleep and auto wakeup?

Offline onesixright

  • WikiUser
  • *
  • Posts: 10
Re: rtcwake blank screen
« Reply #1 on: March 20, 2017, 01:02:24 AM »

Did you ever figured this out?

I'm having exactly the same problem. Anybody else got a solution?