WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Sound?  (Read 7818 times)

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 821
Re: Sound?
« Reply #15 on: February 13, 2015, 10:01:47 AM »
Bela, I didn't know about the new DT in the latest kernel. Is there a tool that we can use to enumerate like dmidecode or lspci on an x86 box? I'm fine with not loading anything, as at least then I know I need something. in 6.0 modules were loaded and I mistakenly believed that they were the right ones which is why I had so much trouble to begin with. I'm fine with the customization part. I thought it was the custom kernel that I made to get my USB display working that was keeping me from getting sound working which is why I tried the "stock" 6.1. So now I have sound and a USB display on my 6.0 system.

Beerstein, my fix is a few posts back. It works for both 6.0 and 6.1. You can leave all the extra modules loaded in 6.0 in if you want. They don't interfere with the onboard sound.

Andy

I'm not aware of a easy way to see what modules are loaded by device Tree. (Like using lsmod)    What you can do is look at the rpi help on what config file entries cause modules to be loaded.   And also look at dmesg to see what is loaded during boot. 

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Sound?
« Reply #16 on: February 14, 2015, 07:49:19 AM »
Hi
There is a problem with alsamixer using  3.18.6-piCore+ and 6.1alpha2

I have installed
alsa-modules-3.18.6-piCore+.tcz
alsa.tcz
alsa-config.tczd


But alsamixer gives this error
Code: [Select]
tc@piCorePlayer:~$ alsamixer
alsamixer: error while loading shared libraries: libformw.so.5: cannot open shared object file: No such file or directory

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7170
    • My Community Forum
Re: Sound?
« Reply #17 on: February 14, 2015, 08:59:36 AM »
 ncurses.tcz ?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Sound?
« Reply #18 on: February 14, 2015, 09:56:24 AM »
sorry - yes ncurses.tcz is already loaded - no difference.

Steen

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7170
    • My Community Forum
Re: Sound?
« Reply #19 on: February 14, 2015, 09:58:08 AM »
Is it a clean install?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline sbp

  • Sr. Member
  • ****
  • Posts: 429
    • piCorePlayer homepage
Re: Sound?
« Reply #20 on: February 14, 2015, 01:08:42 PM »
Hi Bela.
Started all over again and now it is working OK.
So sorry for the trouble.

Steen