WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: wm_errors  (Read 2114 times)

Offline jls

  • Hero Member
  • *****
  • Posts: 2133
wm_errors
« on: February 01, 2015, 03:23:43 PM »
Code: [Select]
Fontconfig warning: "/etc/fonts/conf.d/40-generic.conf", line 27: Having multiple <family> in <alias> isn't supported and may not work as expected
dCore user

Offline jls

  • Hero Member
  • *****
  • Posts: 2133
Re: wm_errors
« Reply #1 on: February 28, 2015, 06:35:56 AM »
Hi
I solved this warning following
http://www.cromwell-intl.com/linux/font-config-warnings.html
and then I added
etc/fonts/conf.avail/40-generic.conf
to /opt/.filetool.lst
dCore user

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: wm_errors
« Reply #2 on: March 01, 2015, 06:05:14 PM »
Thanks for the info.

I have also seen in various places online that the 40-generic.conf file is obsolete and can be removed.  Doing that also fixes the warnings.  I am not well versed in fonts, do we need that file?  If so, I can add a data .tar.gz file with a fixed 40-generic.conf.  But if not, it is simpler to delete the file with a deb2sce startup script.

Offline sm8ps

  • Sr. Member
  • ****
  • Posts: 321
Re: wm_errors
« Reply #3 on: June 28, 2015, 12:23:04 PM »
I did as suggested by jls_legalize because these annoying warnings have been bothering me. I cannot tell if the file really is necessary but that fix is simple and effective.
Jason, would you please consider including the attached file? (I promise to re-boot before giving feed-back.  :) )

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: wm_errors
« Reply #4 on: June 28, 2015, 01:37:21 PM »
Thanks, but this has already been fixed in the Xtc package, it has that same file.

Update your Xtc.sce, or whichever SCE contains it.

Offline Onyarian

  • Sr. Member
  • ****
  • Posts: 336
Re: wm_errors
« Reply #5 on: June 29, 2015, 07:40:12 AM »
Excuse me Jason, I am wrong or Xtc is part of Xprogs?


Offline sm8ps

  • Sr. Member
  • ****
  • Posts: 321
Re: wm_errors
« Reply #6 on: June 29, 2015, 08:04:43 AM »
It is working well after a fine re-boot. :)
Preliminary answer to Onyarian's question: Xtc.tar.gz seems to be an extension of its own as it appears under 'tce/import/debs/'. It is be pulled in as a dependency of Xprogs.

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9668
Re: wm_errors
« Reply #7 on: June 29, 2015, 06:44:56 PM »
Thanks sm8ps for the explanation.  Xtc is in the dependency list of Xprogs, which is in the dependency list of xorg-base, which is in the dependency list of any of the Xorg server related packages.

Offline sm8ps

  • Sr. Member
  • ****
  • Posts: 321
Re: wm_errors
« Reply #8 on: June 29, 2015, 11:19:55 PM »
I did say that my answer was only preliminary, didn't I?  :)

Offline Onyarian

  • Sr. Member
  • ****
  • Posts: 336
Re: wm_errors
« Reply #9 on: June 30, 2015, 12:44:20 AM »
 :)