WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: piCore-6.0 released  (Read 20143 times)

Offline patrikg

  • Full Member
  • ***
  • Posts: 234
Re: piCore-6.0 released
« Reply #15 on: January 22, 2015, 09:19:34 AM »
Aterm dont support ttf fonts. To bad. :(
Maybe you can compile or use another terminal to get a better font.
To list another fonts to use with aterm you can list them with xlsfonts.
And for use them you can use first the use the -fc command like this
aterm -fc "-sony-fixed-medium-r-normal--0-0-100-100-c-0-iso8859-1"

So the file .Xdefaults in the tc home directory that tries to use Luxi Sans font
dont work at all for the aterm.

Offline meo

  • Hero Member
  • *****
  • Posts: 563
Re: piCore-6.0 released
« Reply #16 on: January 22, 2015, 09:32:29 AM »
Hi patrikg!

No it doesn't. But Béla is about to add lxterminal to the repo and then I can get some selections when it comes to fonts. It's very hard to distinguish some letters i aterm at present so that will be nice. Have compiled the GO language 1.4.1 and trying it out was a hazzle since I haven't fixed my keyboard layout to Swedish yet. But I succeded in hacking a GO program down at last and get it to run as it should. Will have to fix the keyboard layout when I get a chance.

Kind regards,
meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline patrikg

  • Full Member
  • ***
  • Posts: 234
Re: piCore-6.0 released
« Reply #17 on: January 22, 2015, 09:40:22 AM »
Strange......have you just only test to type in this line into a term command line ??
setxkbmap -model "pc105" -layout "se" -variant "nodeadkeys"

And when you want it to be always, just add this into the .xsession file.
nano -w /home/tc/.xsession

And make a backup.
filetool.sh -b -v


Best Regards
//Patrik from a snowy landscape in sweden.

Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: piCore-6.0 released
« Reply #18 on: January 22, 2015, 10:04:39 AM »
Quote
meo wrote:
Béla is about to add lxterminal to the repo
lxterminal is already available and works well.

Offline patrikg

  • Full Member
  • ***
  • Posts: 234
Re: piCore-6.0 released
« Reply #19 on: January 22, 2015, 10:28:46 AM »
Where ??
I think you dont mean the armv6 repo.
http://tinycorelinux.net/6.x/armv6/tcz/

You mean the x86 repo.
http://tinycorelinux.net/6.x/x86/tcz/


Offline nitram

  • Hero Member
  • *****
  • Posts: 1052
Re: piCore-6.0 released
« Reply #20 on: January 22, 2015, 11:21:56 AM »
Sorry - you're correct - the x86 repo.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 6838
    • My Community Forum
Re: piCore-6.0 released
« Reply #21 on: January 22, 2015, 11:38:24 AM »
lxterminal.tcz added to repo
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline meo

  • Hero Member
  • *****
  • Posts: 563
Re: piCore-6.0 released
« Reply #22 on: January 23, 2015, 04:46:26 AM »
Hi guys!

I tried to load the keyboard layout from the terminal as you suggested Patrik but an error message made clear that the commands weren't recognized. Then I've been struggling with the .config file (suggested by Béla) in /usr/local/share/X11/xorg.conf.d/keyboard.config using all kinds of possible kombinations of layout that could be the Swedish I want (like se, sv, sv-latin1 etc.) but I can't get it to work. I guess that I'll have to dive into the documentation to get my answer. Thanks for all your help.

With appreciation,
meo

PS I know that this subject doesn't belong here so from now I'll use my former post DS
« Last Edit: January 23, 2015, 04:48:38 AM by meo »
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline meo

  • Hero Member
  • *****
  • Posts: 563
Re: piCore-6.0 released
« Reply #23 on: January 23, 2015, 05:47:15 AM »
Hi guys!

Well, since this post will finalize the question at hand I might just as well post it here. Browsed around on the internet and found something interesting. I quote the command: "setxkbmap -model pc105 -layout se -option """. First I tried it as a command and it worked. So I followed Patriks tip and put it at the end of /home/tc/.xsession and made a backup followed by a reboot and voilá it works. :) So now I finally have a Swedish keyboard layout. Thanks for your help quys! Probably couldn't have done it without you.

Happy and kind greetings,
meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline patrikg

  • Full Member
  • ***
  • Posts: 234
Re: piCore-6.0 released
« Reply #24 on: January 24, 2015, 03:51:07 PM »
Now i getting it to work with the .conf file.
The X11 correct way. Not any workaround. :)

First take away the workaround line from the ".xsession" file.
Then follow this steps.
To load a pc105 keys swedish keyboard.
With nodeadkeys means that key tilde and another keys don't wait for another press of another key.
And to terminate X11 press <CRTL><ALT><BACK SPACE>.

You can cut and paste.

Best regards
//Patrik

Code: (bash) [Select]
sudo su
mkdir -p /etc/X11/xorg.conf.d/
echo -e "Section \"InputClass\"" > /etc/X11/xorg.conf.d/se_keyboard.conf
echo -e "\tIdentifier \"keyboard defaults\"" >> /etc/X11/xorg.conf.d/se_keyboard.conf
echo -e "\tMatchIsKeyboard \"on\"" >> /etc/X11/xorg.conf.d/se_keyboard.conf
echo -e "\tOption \"XkbModel\" \"pc105\"" >> /etc/X11/xorg.conf.d/se_keyboard.conf
echo -e "\tOption \"XkbLayout\" \"se\"" >> /etc/X11/xorg.conf.d/se_keyboard.conf
echo -e "\tOption \"XkbVariant\" \"nodeadkeys\"" >> /etc/X11/xorg.conf.d/se_keyboard.conf
echo -e "\tOption \"XkbOptions\" \"terminate:ctrl_alt_bksp\"" >> /etc/X11/xorg.conf.d/se_keyboard.conf
echo -e "EndSection" >> /etc/X11/xorg.conf.d/se_keyboard.conf
echo -e "etc/X11/xorg.conf.d/se_keyboard.conf" >> /opt/.filetool.lst
filetool.sh -b -v

And then logout as root with <CTRL><D>
« Last Edit: January 24, 2015, 03:58:34 PM by patrikg »

Offline meo

  • Hero Member
  • *****
  • Posts: 563
Re: piCore-6.0 released
« Reply #25 on: January 25, 2015, 10:54:14 AM »
Hi Patrik!

I've posted how I made it work in the post just before yours. Thanks for helping out!  :)

setxkbmap -model pc105 -layout se -option ""

Either from terminal or the last line in .xsession works.

Kind Regards,
meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline patrikg

  • Full Member
  • ***
  • Posts: 234
Re: piCore-6.0 released
« Reply #26 on: January 25, 2015, 11:02:29 AM »
Yes, I saw it, but if you want to do it in a more accurate manner. according to the X11 standard.

Offline meo

  • Hero Member
  • *****
  • Posts: 563
Re: piCore-6.0 released
« Reply #27 on: January 26, 2015, 06:23:15 AM »
Hej Patrik! 

Actually it might be a good idea to do it the way you suggested. I don't know why, but on at least one occation the layout didn't load, and I had to do it manually. I don't know why this happened,  but I have had a similar irregularity when coding in go. The compiled program wasn't found initially so I had to give the full path to it and then it was recognized. It seems that the X version isn't really "bulletproof", there might be a bug (or just me having done something that shouldn't have been done) that causes irregularities that aren't logical.  ::) Will post when I find out more. Thanks for your help Patrik!  :)

Kind Regards,
Mats
« Last Edit: January 26, 2015, 06:40:05 AM by meo »
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline andyj

  • Sr. Member
  • ****
  • Posts: 375
Re: piCore-6.0 released
« Reply #28 on: January 27, 2015, 03:20:52 PM »
I'd like to see the "correct" way too so I can get dual-head working on the pi. I have an HDMI monitor that is my "console", and a USB display as my X-display. It would be nicer if I didn't have to drop to the prompt to use a terminal (which might not be necessary if I could resize aterm to startup full screen on a 2.8 inch monitor.

Offline falcon

  • WikiUser
  • *
  • Posts: 11
Re: piCore-6.0 released
« Reply #29 on: January 28, 2015, 10:59:16 AM »
Hello,
I installed Apache in piCore 6.0 and when I tried to start it I got the following error:

tc@box:~$ sudo apachectl -k start
/usr/local/sbin/httpd: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory

Whats wrong? Is Nginx coming to 6.0? Havnt found it yet.

Thanks a lot for a good work!

Yours

Magnus in Oslo, Norway