WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TC4.x XFCE4 dependency issue  (Read 974 times)

Offline centralware

  • Sr. Member
  • ****
  • Posts: 320
TC4.x XFCE4 dependency issue
« on: January 22, 2015, 11:36:46 PM »
I was tinkering with xfce4 to see whether or not it would be worthwhile for a project so I dumped all of the extensions with the prefix xfce* including plugins into my tce-load script.  The following is MIA:

Source: 4.x/x86/tcz/xfce4-cpufreq-plugin.tcz.dep
Missing Dependency: 4.x/x86/tcz/cpufreq-KERNEL.tcz

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12089
Re: TC4.x XFCE4 dependency issue
« Reply #1 on: January 23, 2015, 04:01:08 AM »
I seem to recall that the cpufreq modules were included in the base at around that time - are they under /lib/modules somewhere?
« Last Edit: January 23, 2015, 04:03:32 AM by Juanito »

Offline centralware

  • Sr. Member
  • ****
  • Posts: 320
Re: TC4.x XFCE4 dependency issue
« Reply #2 on: January 23, 2015, 05:38:25 AM »
I think so, I'll check here in a moment.  The main reason for the post is simply to update the .dep file (assuming you're correct regarding inclusion) as the ext itself won't download otherwise.

/lib/modules/3.0.21-tinycore/kernel/drivers/cpufreq exists and isn't showing as also being in /tmp/tcloop/anywhere so yes, base it is.  As such, I'm guessing it's safe to assume removal of cpufreq-KERNEL from .dep should be warranted.  I'll try it on our repo...

The error's gone, but the ext crashes when trying to add it to the toolbar.  (Mind you, I'm using Xvesa instead of Xorg so this may be involved since the extension was copied from TC3 and there's not much in the info file as to the expected foundation.)


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12089
Re: TC4.x XFCE4 dependency issue
« Reply #3 on: January 23, 2015, 05:43:31 AM »
dep file corected  :)