WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Firefox - Extension to install the latest version  (Read 33079 times)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Firefox - Extension to install the latest version
« Reply #45 on: November 20, 2015, 12:45:00 PM »
Since Mozilla can't be consistent from one week to the next I have come up with a new plan to prevent the wget from spitting out errors but it will be next week before I can implement the change

So meanwhile Firefox-ESR is available for those who need a current Firefox browser


Sent from my iPhone using Tapatalk

Offline raj

  • WikiUser
  • *
  • Posts: 3
Re: Firefox - Extension to install the latest version
« Reply #46 on: November 20, 2015, 03:14:50 PM »
Thank you coreplayer2,

Look forward to the new solution  :)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Firefox - Extension to install the latest version
« Reply #47 on: November 22, 2015, 01:05:38 PM »
Many minor changes this week, mostly due to Mozilla's restructuring of their servers again.   Seems to be a weekly occurrence so this time I've incorporated a fallback method to overcome these frequent directory changes.  The script will use the fallback method if the version checker fails to find the latest version.


Also restored the manual selection method to full functionality.
remember to use this feature use the "firefox-getLatest.sh -m" command.

extension submitted, but as always pm me if you would like to get the tcz asap

Maybe I can get to adding some useful features now instead of chasing my tail..

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Firefox - Extension to install the latest version
« Reply #48 on: November 22, 2015, 02:20:52 PM »
I feel we're making great progress,  this update brings additional Firefox_"Private" and "Safe-mode" browsing desktop menu items

Desktop menu items
    firefox
        Firefox
        Firefox_private
        Firefox_safe-mode



Thanks Misalf for the contribution
:)



« Last Edit: November 22, 2015, 02:42:33 PM by coreplayer2 »

Offline raj

  • WikiUser
  • *
  • Posts: 3
Re: Firefox - Extension to install the latest version
« Reply #49 on: November 23, 2015, 01:04:37 PM »
Thank you coreplayer2 for swiftly updating the script. Much appreciated.

Offline grandadruss

  • WikiUser
  • *
  • Posts: 2
Re: Firefox - Extension to install the latest version
« Reply #50 on: November 24, 2015, 04:56:15 PM »
Downloaded script above (17.13kb) - had to search and replace 34.0.5 with 42.0 to get it to work. No joy with -m 42.0
Just in case this helps someone.
All up-to-date now with extra menu items, thanks to all!  :)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Firefox - Extension to install the latest version
« Reply #51 on: November 24, 2015, 07:20:06 PM »
you shouldn't have to change anything.  We've been testing the script for the last few days without any issue getting the correct version.   Unless there's been a change at Mozilla within the last 30mins otherwise Ivan explain what happened in your scenario
A screenshot or terminal output would really help with troubleshooting please

If manually entering the version the command is

./firefox-getLatest.sh -m

Then at the prompt type 42.0 enter

Usually this is a backup method, or installing a previous version.

Sent from my iPhone using Tapatalk
« Last Edit: November 24, 2015, 07:36:04 PM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Firefox - Extension to install the latest version
« Reply #52 on: November 24, 2015, 09:49:36 PM »
During recent firefox-getLatest testing, we discovered an issue with FLWM and FLWM_Topside Window Managers.   It appears the new desktop menu feature providing Firefox "Private viewing" and "Safe-Mode" has brought to the forefront an WM incompatibility when two similar extension names are loaded via the onboot.lst, for example "firefox" and "firefox-getLatest" and at least one of the extensions has desktop sub-menu items.  We've discovered the issue is present in all versions of FLWM topside or standard from either tc-5.x or tc-6.x (x86 & x86_64).   Whereas Hackedbox is unaffected.  Openbox is not directly effected by this issue but has another problem mentioned below.
The result of this anomaly occurs when the WM loads at boot, it appears the menu building function can not differentiate between extension names with either Capital letters or Hyphens, resulting in corrupted sub menus. 

Meanwhile, an underscore is recognized by FLWM and when our firefox-getLatest extension is rebuild as firefox_getLatest the desktop menus are build uncorrupted.  So....

Because of this issue I have decided to rename firefox-getLatest.tcz to firefox_getLatest.tcz on all future update submissions to the repo.   Unfortunate as this is it's the easiest resolution to the dilemma.



Note; Openbox require the use of 2x underscores or Hyphens in a menu item name to be recognized and written as one. Not ideal but not as sever as the resulting corruption when building sub-menus in FLWM with Hyphens

Attached for your pleasure is the updated script reflecting this name change,  this will appear in the repo's soon
« Last Edit: November 24, 2015, 10:09:20 PM by coreplayer2 »

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Firefox - Extension to install the latest version
« Reply #53 on: December 15, 2015, 06:40:44 PM »
I've been waiting almost a month for Mozilla to update Firefox again, needed to verify firefox_getLatest extension will perform as expected, I'm happy to say it does :)  Though I was hoping for a minor version update before going straight to v43.0, will try to stay ahead of that..


Run firefox_getLatest from the desktop menu (note: Sorry, had to change the extension name again, a result of an issue with flwm.
So make sure you've downloaded the latest version from the repo).

Anyhow,  Firefox version 43.0 is out and is available for x86, x86_64 in all supported languages as required

...



Anyone needing a different/specific version can always use firefox_getLatest.sh -m from the terminal to fetch their desired version,
see here for more:  firefox_getLatest.sh -h



If interested, this is the current mechanism for detecting Firefox  current/latest version, which appears to be working quite well.
Code: [Select]
addressX='https://download.mozilla.org/?product=firefox-latest&os=linux&lang=en-US'
curl -s $addressX 2>/dev/null | grep -o '[[:digit:]]*\.[[:digit:]]' 2>/dev/null | sort -u | tail -1 >/tmp/ffversion
curl -s $addressX 2>/dev/null | grep -o '[[:digit:]]*\.[[:digit:]]*\.[[:digit:]]' 2>/dev/null | sort -u | tail -1 >>/tmp/ffversion
VER=$(cat /tmp/ffversion | sort -u | tail -1)



Latest script is attached in case of difficulty getting the correct extension
« Last Edit: December 15, 2015, 06:43:25 PM by coreplayer2 »

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: Firefox - Extension to install the latest version
« Reply #54 on: December 17, 2015, 01:58:56 PM »
Seems Firefox version 43 crashes on YouTube.com when playing a video and  ffmpeg.tcz  is not loaded.
Also, if  ffmpeg.tcz  is loaded, Firefox falls back to Flash even though I set YT to use HTML5.
Download a copy and keep it handy: Core book ;)

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1703
Re: Firefox - Extension to install the latest version
« Reply #55 on: December 17, 2015, 03:13:25 PM »
Hmm, no. Settings that were suggested in order to enable HTML5 video actually prevented Firefox from working correctly.
So at  about:config  I set these settings back to default:
media.fragmented-mp4.*
media.mediasource.*
That fixed the crash and HTML5 video works again.
« Last Edit: December 17, 2015, 03:15:17 PM by Misalf »
Download a copy and keep it handy: Core book ;)

Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Firefox - Extension to install the latest version
« Reply #56 on: December 18, 2015, 09:27:20 PM »
Interesting....   so all is well on the Firefox HTML5 and YouTube front  :)
I wish I could say the same for the new signing of add-on's in v43+, but add-ons will catch up eventually..

Meanwhile I didn't have to wait long to test minor updates with the latest script because Firefox v43.0.1 is out and the mechanism works well

No one should experience any difficulties getting the very latest firefox,  enjoy


Offline coreplayer2

  • Hero Member
  • *****
  • Posts: 3020
Re: Firefox - Extension to install the latest version
« Reply #57 on: January 09, 2016, 05:42:06 PM »
Attached "firefox_getLatest.sh" script has been updated to v2.1

with improvements to
I)  detection of older squashfs-tools for compatibility with tc-4.x & tc-5  (x86 versions)
2) detection of architecture

Has been tested on tc-5, tc-6, tc-7 with all possible architectures

Will submit the updated extension asap
thanks for your patience

Offline tp4web

  • WikiUser
  • *
  • Posts: 6
Re: Firefox - Extension to install the latest version
« Reply #58 on: March 18, 2016, 09:09:41 AM »
Hi, when I try the firefox_getLatest.sh from repository, it does download Firefox 45, seems to install fine and also creates a icon on wbar, but will not launch Firefox. It seems to create all files.

I tried it on VMWare and from SD card (installed using TinyCore but using corepure64.gz and vmlinuz64.gz). I can run Firefox ESR fine but not the latest 45. Using flwm or fluxbox has no impact.

Manually trying to execute using PCManFM shows error message [Failed to execute child process "/tmp/tcloop/firefox/usr/local/firefox/firefox" (No such file or directory)]

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Firefox - Extension to install the latest version
« Reply #59 on: March 18, 2016, 09:26:54 AM »
It sounds like you have not loaded firefox.tcz.