WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Core v6.0rc1  (Read 14517 times)

Offline hiro

  • Hero Member
  • *****
  • Posts: 1120
Re: Core v6.0rc1
« Reply #15 on: December 14, 2014, 01:58:38 PM »
Yeah, it seems there was an other unrelated error, the script failed for some unknown reason and the built extension was thus empty.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11096
Re: Core v6.0rc1
« Reply #16 on: December 15, 2014, 03:31:41 AM »
Can't use iproute2.

 iproute2.tcz
A)bout I)nstall O)nDemand D)epends T)ree F)iles siZ)e L)ist S)earch P)rovides K)eywords or Q)uit:
Downloading: bsddb-dev.tcz
Connecting to repo.tinycorelinux.net (89.22.99.37:80)
wget: server returned error: HTTP/1.1 404 Not Found
dep file adjusted - thanks

Offline hiro

  • Hero Member
  • *****
  • Posts: 1120
Re: Core v6.0rc1
« Reply #17 on: December 15, 2014, 04:39:46 AM »
nmap has another dependency error:
md5sum: nmap-dbs.tcz.md5.txt: No such file or directory

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11096
Re: Core v6.0rc1
« Reply #18 on: December 15, 2014, 04:50:23 AM »
nmap-dbs copied over from 5.x repo - thanks

Offline hiro

  • Hero Member
  • *****
  • Posts: 1120
Re: Core v6.0rc1
« Reply #19 on: December 15, 2014, 11:16:06 AM »
x264-dev has both x264 versions as dependency. Is there a reason to keep the old x264.tcz? It doesn't come with the correct header files.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11096
Re: Core v6.0rc1
« Reply #20 on: December 15, 2014, 11:12:08 PM »
'looks like that error has been with us since 2012 - adjusted in 5.x/6.x repos - thanks

Offline pq5190362

  • Sr. Member
  • ****
  • Posts: 286
Re: Core v6.0rc1
« Reply #21 on: December 16, 2014, 02:48:52 AM »
Hello,

I've got a question:

Why is the graphics stack in the 32-bit repo so much older than in the 64-bit repo?

The 64-bit repo has (for example):

glamor-egl.tcz - 0.6.0
libvdpau.tcz - 0.8
xf86-video-ati.tcz - 7.5.0
xf86-video-intel.tcz - 2.99.916
xf86-video-vesa.tcz - 2.3.3
Xorg-7.7-3d.tcz - 10.3.2
xorg-server.tcz - 1.16.1

In comparison, the 32-bit repo only has:

glamor-egl.tcz - 0.5.0
libvdpau.tcz - 0.7
xf86-video-ati.tcz - 7.1.0
xf86-video-intel.tcz - 2.21.15
xf86-video-vesa.tcz - 2.3.2
Xorg-7.7-3d.tcz - 9.1.4
xorg-server.tcz - 1.14.2

Why is that? Why is the graphics stack in the 32-bit repo so much older than in the 64-bit repo?

Any chance you could update the 32-bit repo to be at least on par with the 64-bit version in that regard?

Regards

Offline hiro

  • Hero Member
  • *****
  • Posts: 1120
Re: Core v6.0rc1
« Reply #22 on: December 16, 2014, 04:05:39 AM »
abiword is missing libffi5.tcz dependency

Ironically text selection doesn't work properly in this abiword version, also stuff like shift->ctrl->end to select everything from cursor to end of the document. I am downgrading to 2.x again, I suggest doing the same for this extension. :o
« Last Edit: December 16, 2014, 04:15:44 AM by hiro »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11096
Re: Core v6.0rc1
« Reply #23 on: December 16, 2014, 06:25:52 AM »
abiword recompiled for tc-6.x

I recall that the point of abiword-3 was to use gtk3 - an abword2 (i.e. abiword-2, gtk2 extension) would be a welcome addition  ;)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11096
Re: Core v6.0rc1
« Reply #24 on: December 16, 2014, 06:30:13 AM »
Why is the graphics stack in the 32-bit repo so much older than in the 64-bit repo?

The x86_64 Xorg was updated for various gnome stuff - there is no gnome wm in the x86 repo...

Offline hiro

  • Hero Member
  • *****
  • Posts: 1120
Re: Core v6.0rc1
« Reply #25 on: December 16, 2014, 07:55:55 AM »
ffmpeg wants libiconv.tcz.

I'm using vi now for what I wanted to use abiword for :P
« Last Edit: December 16, 2014, 08:00:48 AM by hiro »

Offline pq5190362

  • Sr. Member
  • ****
  • Posts: 286
Re: Core v6.0rc1
« Reply #26 on: December 16, 2014, 03:13:46 PM »
Hello,

Why is the graphics stack in the 32-bit repo so much older than in the 64-bit repo?

The x86_64 Xorg was updated for various gnome stuff - there is no gnome wm in the x86 repo...

thanks for your reply.

And what about those who would need an updated graphics stack for, let's say, support of new GPUs / bugfixes / new features / better performance?

Would those not count as valid reasons to update the graphics stack?

Any chance you could still update the graphics stack in the 32-bit repo for the reasons mentioned above?

Regards
« Last Edit: December 16, 2014, 03:32:04 PM by pq5190362 »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11096
Re: Core v6.0rc1
« Reply #27 on: December 17, 2014, 01:06:49 AM »
ffmpeg wants libiconv.tcz.

libass and libavcodec recompiled and posted - thanks

bel

  • Guest
Re: Core v6.0rc1
« Reply #28 on: December 18, 2014, 11:36:26 AM »
Hello, 2 items to mention:

1. pidgin.tcz requires libiconv.tcz, so fails.

2. Can we have the pidgin-otr plugin in the repository; I see it was in an older (pre-5) version.

Thanks!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11096
Re: Core v6.0rc1
« Reply #29 on: December 18, 2014, 11:05:23 PM »
Thanks - I sent a pm to the pidgin extension maintainer requesting a recompile without libiconv - the iconv functions are provided by glibc anyway.